« Previous - Version 8/10 (diff) - Next » - Current version
DiRaven, 07/26/2011 12:54



  • [NEW] Introduced code templates (Tools->Options->Editor->Code Templates) (will add more templates later).
  • [NEW] You can now delete project along with the real folder on the disc (not only project from Skufer).
  • [NEW] You can now create new project by importing PBO file contents. Just go into the File->New Project->Projects with Existing Sources and follow the wizard.
  • [NEW] You can now build PBO right from inside the IDE by right clicking the project node and selecting "Build PBO" option. In the dialog you may select folder or *.pbo file, or even put filename yourself, just not forget to put the *.pbo extension. To see the output of the process, press ctrl+4 or use Window->Output->Output menu.
  • [CHANGE] Moved "Empty Sqf" template into the "ArmA" group.


  • [FIX] Fixed code completion not working in the deployed versions.


  • [NEW] Added simple code completion (thanks PvPscene for the database). Aside from the completion itself and internal docs about the command - you can always click the button at the top of the command description window to get to the corresponding wiki page and view full info with examples there.
  • [NEW] Added an ability to create arma mission projects.


  • [CHANGE] Changed look-and-feel a bit. New icons, new splashscreen.
  • [FIX] Fixed multiline comment failures and errors.
  • [FIX] Fixed numerous bugs with the grammar.


  • [NEW] Introduced code coloring (all the colors are customizable via the options menu).
  • [NEW] Introduced new project type "Arma mission".
  • [NEW] Introduced syntax errors reporting.