Bug #9655

YOMA 2009 crashes when querying mods from servers with large repository

Added by Reezo about 5 years ago. Updated about 5 years ago.

Status:Closed Start date:03/17/2010
Priority:Normal Due date:
Assignee:Yoma % Done:

0%

Category:Download
Target version:2010_03_24 1.0.54 Beta

Description

On a XP Pro SP3 32bit 4Gb RAM (controlled via VNC) the client crashes to desktop when requesting mods list from a server with a large repository (tried it on KH's Arma2 repository).

History

Updated by Yoma about 5 years ago

Need more info:
Patched to latest version (v1.0.51)
What does it do exactly? Errormessage?
I have no problem at all when using the same repo.

Updated by Reezo about 5 years ago

This is what Windows Error Reporting says, briefly:

EventType : clr20r3 P1 : addonsync2009.exe P2 : 1.0.51.0
P3 : 4b9e324f P4 : system.data P5 : 2.0.0.0 P6 : 4333aea2
P7 : 1726 P8 : 0 P9 : system.stackoverflowexception

Next up is the Yoma .log

Updated by Reezo about 5 years ago

YOMA's Update error log says:

17-03-10 03:42:45 Upload grid data error.

Updated by laurence99 about 5 years ago

The same happens to me it was working befoure but now i cant update to my private server i also am running xp sp3 i get : EventType : clr20r3 P1 : addonsync2009.exe P2 : 1.0.51.0
P3 : 4b9e324f P4 : system.data P5 : 2.0.0.0 P6 : 4333aea2
P7 : 1726 P8 : 0 P9 : system.stackoverflowexception

Updated by Yoma about 5 years ago

I'll try to look into the problem asap.
My biggest grief is that i cannot reproduce it here.
Meanwhile, you can go back to v50 (it's still online), so you can still update your repo's.
Would it be possible to connect to one of you guys' machines for some testing?

Updated by Reezo about 5 years ago

Yoma, thanks for the help.

You would be more than welcome to try in our servers via VNC at any time. Sorry I wasn't available yesterday and could not reply in time.

Anyway, the bug disappeared with the latest .52 version of AddonSync2009

Thanks!!

for what concerns our side, I hereby state: ISSUE FIXED.

Updated by Yoma about 5 years ago

  • Category set to Download
  • Status changed from New to Closed
  • Assignee set to Yoma
  • Target version set to 2010_03_24 1.0.54 Beta

Also available in: Atom PDF