Bug #9629

Surrendered Units getting killed by AI

Added by mr.g-c over 5 years ago. Updated over 5 years ago.

Status:Rejected Start date:03/16/2010
Priority:Normal Due date:
Assignee:Monsada % Done:

10%

Category:-
Target version:-
Affected Version:503 Difficulty:Not set
Affected ArmA II version:1.06 BETA Reproduced by another DH user:No

Description

Problem: Currently surrendered Units are getting killed by other factions AI.

Proposed Solution: I think they simply need a "_unit setcaptive true" to solve this.

History

Updated by mr.g-c over 5 years ago

  • Status changed from New to Assigned
  • Assignee set to Monsada
  • Affected Version set to 503
  • Affected ArmA II version changed from Please select... to 1.06 BETA

Updated by Monsada over 5 years ago

  • Status changed from Assigned to In progress

Hi, I tried it and kills too, I think this is because the soldier who are put setcaptive has killed someone, I don't know why, in any case I will put setcaptive = true

Updated by Monsada over 5 years ago

  • Target version set to 5.0.4

Updated by mr.g-c over 5 years ago

Monsada wrote:

Hi, I tried it and kills too, I think this is because the soldier who are put setcaptive has killed someone, I don't know why, in any case I will put setcaptive = true

If its because they killed someone, then maybe a "addrating" temporary to adjust its rating? i don't know how much influence that will have. Or let them join a scripted civillian AI group until they joined player squad...

http://community.bistudio.com/wiki/addRating
http://community.bistudio.com/wiki/rating
http://community.bistudio.com/wiki/ArmA:_Rating_Values
http://community.bistudio.com/wiki/createGroup

Updated by Monsada over 5 years ago

  • Status changed from In progress to Resolved
  • % Done changed from 0 to 100

Updated by Monsada over 5 years ago

  • Status changed from Resolved to In progress
  • % Done changed from 100 to 10

Not resolved, AI contines killing some time, I don't know why.

Updated by Monsada over 5 years ago

  • Target version changed from 5.0.4 to 5.0.5
  • Difficulty set to Not set

Updated by Monsada over 5 years ago

  • Target version deleted (5.0.5)

Updated by Monsada over 5 years ago

  • Status changed from In progress to Rejected

I can not avoid AI killing captive units some times.

Also available in: Atom PDF