Bug #9309

People get hurt too easily when moving around, interacting with environment and so on

Added by Rommel over 5 years ago. Updated over 4 years ago.

Status:Expired Start date:02/26/2010
Priority:Normal Due date:
Assignee:Dwarden % Done:

0%

Category:Gameplay
Target version:-
Affected ArmA II version:1.05.62017 First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:No NGUrl:
Related to content of DLC: WIKIurl:

Description

Running into other people can be fatal, but even bumping into them can be bad in the wrong places.
Perhaps SYS_Wounds can detect this by making a minimum "" projectile damage (ie world damage, being hit by a car, falling into water etc) so it won't hurt you as easily, and may require a bit more force.
Should also limit the large amount of hit a bump on the road and the people in the vehicle all get wounded.

I think a good minimum is around 1-2, obviously with some testing, but any serious damage via world, such as being hit by a truck or tank, is in a high damage range, the low end range is limited to being crushed in doors etc.

If this has already been implemented, it isn't working very effectively, at least 10% on average my squads deaths each coop night account for bumping into each other. Which is really really bad.


Related issues

related to ARMA2 Community Issue Tracker - Bug #9310: Living creatures can get hurt too easily Duplicate 02/26/2010 03/07/2010

History

Updated by Xeno over 5 years ago

  • Category deleted (Script)
  • Status changed from Feedback to Rejected
  • Assignee deleted (Xeno)
  • Target version deleted (1.1)
  • Component deleted (sys_wounds)

Running into other units doesn't trigger any damage. Not in vanilla ArmA 2 and not in ACE.

Furthermore there is allready a threshold for minor damages without a bullet hit where nothing happens.

Updated by rocko over 5 years ago

Out of interest do you use other addons?

I have never experienced "bump damage" with other players. And I bump a lot just for fun.
I know BI/Map environemnt has some "objects" that can inflict damage. Small rocks, fallen trees etc.

Did you have stuff attached when it happened ?

Updated by Rommel over 5 years ago

  • Status changed from Rejected to Feedback

Using just ACE, ACEX, CBA, or no addons at all. World damage is very very common. People will walk into a building, close the door, bang they are killed by the door crushing them (ie it moves them at a high velocity in a very very small space and throws them into another wall, killing them). It would look as though they are just being setpos'd out of the way, except dying.

In tight CQB, in 5 runs of entering a room, we had a collision based injury twice, not always death. It is very prominent.
Just two nights ago, mission started, a few of us move to the ammo crate, a player runs into the cluster, a player is displaced and killed in his 'bumping into' them. This happens a lot, and I have solved it by having a high threshold for with the no projectile damage.

Moved back to feedback, although it may not be an ACE problem, it is definitely a problem in ArmA2, and has not been solved since the OFP days...

Should it be in the ArmA2 CIT, yes, but it won't be fixed for a while, so in the meantime there can be a 'bandaid' applied...

Updated by Xeno over 5 years ago

  • Status changed from Feedback to Rejected

Ask BI to fix this.

Updated by Sickboy over 5 years ago

  • Status changed from Rejected to Assigned
  • Assignee set to Rommel
  • Priority changed from Normal to Trivial
  • Target version set to 395

If you would like a bandaid solution Rommel, please work one up. I'm sure we can include it.

Updated by Evil_Echo over 5 years ago

I had a person bump into me with a bicycle moving at very low speed in Domination mission yesterday. It caused 50% damage.

Unless the pedal of that bike had razor blades on it I'd call the damage from that bump excessive.

Updated by tcp over 5 years ago

You could prolly raise the threshold of wounds to not cause pain (requiring morphine) if the damage is below 0.09. That's the worse side effect.

Updated by Lazyman over 5 years ago

I'm also going to add that moving around M119/D30s is very dangerous: on various occasions I have been outright killed after having bumped into one and having been sent flying (both running and walking speed).

Updated by rocko over 5 years ago

  • Status changed from Assigned to Expired
  • Assignee deleted (Rommel)
  • Target version deleted (395)

Updated by zGuba about 5 years ago

  • Project changed from A.C.E. for OA to ARMA2 Community Issue Tracker
  • Status changed from Expired to Assigned
  • Assignee set to Dwarden
  • Affected ArmA II version set to Please select...
  • Maxmem parameter set to Not set
  • Difficulty set to Not set
  • CPU set to Please specify!

Updated by zGuba about 5 years ago

  • Subject changed from Collision Kills - BIS Bandaid to People get hurt too easily when moving around, interacting with environment and so on
  • Due date set to 09/08/2010
  • Category set to Gameplay
  • Priority changed from Trivial to Normal
  • Affected ArmA II version changed from Please select... to 1.05.62017
  • Reproduced by another DH user set to No

Updated by zGuba about 5 years ago

  • Reproduced by another DH user changed from No to Yes

Updated by kju over 4 years ago

  • Due date changed from 09/08/2010 to 02/01/2011
  • Status changed from Assigned to Feedback

Please provide simple demo missions. Ty.

Updated by Swedge over 4 years ago

I confirm that M119 crews can occasionally experience damage.
See YouTube video description for more info.
http://www.youtube.com/watch?v=NvdkGDZdi6U

Updated by kju over 4 years ago

  • Due date deleted (02/01/2011)
  • Status changed from Feedback to Expired
  • CPU deleted (Please specify!)
  • Audio card deleted (Please specify!)
  • Size of OS swap file deleted (Please specify!)

Free free to open, if a demo mission and repro steps are provided.

Also available in: Atom PDF