Bug #9289

standing in vehicle

Added by armajay over 5 years ago. Updated over 5 years ago.

Status:Closed Start date:02/25/2010
Priority:Normal Due date:
Assignee:Xeno % Done:

100%

Category:Script
Target version:1.0.7
Component:sys_wounds Affected Version:
Close Reason:

Description

had this happen with other vehicles including GMV's doesn't happen initially but when team switching into an ai sometimes the character doesn't use the normal vehicle animation and instead stands up sticking out of vehicle, using no addons other than ace and updated using six today pic below.

http://img46.imageshack.us/img46/2756/bugnd.jpg

arma2.RPT (6 kB) armajay, 02/25/2010 20:12

takecontrol.jpg (214.6 kB) gonza, 02/27/2010 06:52

StandingInVehicleTest.utes.7z (900 Bytes) Sickboy, 02/27/2010 11:37


Related issues

duplicates A.C.E. for OA - Bug #9306: command selectPlayer bug with 286 Duplicate 02/25/2010

Associated revisions

Revision 55a26acc
Added by Xeno over 5 years ago

~FIXED: Units standing in vehicles after teamswitch, refs #9289

~CHANGED: handleDamage eventhandler gets when a unit dies, refs #9311

History

Updated by Sickboy over 5 years ago

  • Status changed from New to Feedback

Thanks please attach your arma2.rpt. See Bugz for details.
Have you tried it without ACE, maybe it is a vanilla issue?

Updated by armajay over 5 years ago

Updated by armajay over 5 years ago

tested without ace just normal arma and mh60s and usmc guys and do not get this problem team switching.

Updated by rocko over 5 years ago

  • Status changed from Feedback to Duplicate

Updated by rocko over 5 years ago

  • Status changed from Duplicate to Feedback

Updated by gonza over 5 years ago

same problem

it is an ACE problem because this bug appear with all version of VTS (who work fine with older versions (before my holiday) of ACE)
the only thing who change in arma is the ace version

multiple VTS users tell me about this problem on divers forum (Vts discussions)

------
since a recent version (286 ?) of ACE
the selectPlayer command don't work properly

when you make a selectPlayer on certain vehicle to take driver control the driver (you) stay up

you can try it on VTS 3.5 mission
------

--> see the pic

Updated by Sickboy over 5 years ago

Been unable to reproduce (ACE build 290).
In attached mission, order unit 2 to get in the hmmwv, when he's in, order him to go somewhere far north.
When he's moving try to teamswitch into him. There seems to be no issues.
Teamswitching back to your own unit, telling 2 to move around again, even yourself running around, and then teamswitch again, still no issue.

Is it possible that the player was very exhausted at the moment of teamSwitch, or no indication of Stamina or whatsoever ?
What kind of weight are the units carrying? The player unit, and the unit that is switched into.

Possibly something to do with Stamina and teamswitch improvements?

Updated by Xeno over 5 years ago

  • Category changed from Complex to Script
  • Status changed from Feedback to Assigned
  • Assignee changed from Rommel to Xeno

Will be fixed in next release!

Updated by Sickboy over 5 years ago

  • Target version set to 1.0.7
  • % Done changed from 0 to 30
  • Component set to sys_wounds

Updated by Xeno over 5 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 30 to 100

Also available in: Atom PDF