Bug #9111

Search/Disarm/Arrest not working

Added by Naserve about 5 years ago. Updated about 4 years ago.

Status:Closed Start date:02/15/2010
Priority:Low Due date:
Assignee:Xeno % Done:

100%

Category:Script
Target version:1.1
Component:sys interactive Affected Version:
Close Reason:

Description

Whenever I injure an enemy enough to knock them out I go over to search and disarm them before providing medical aide. The problem is that when I press search/disarm nothing happens. When I press arrest nothing happens. When I press gear nothing happens. I tested this several times in the editor against enemy AI. I've tried healing them then search/disarming them and still no effect.

Associated revisions

Revision 37d27d03
Added by Xeno about 5 years ago

Activated "Search/Disarm" for enemy and friendly units, refs #9111

Revision ac095fc6
Added by Xeno about 5 years ago

~CHANGED: You can now access the gear of unconscious units, refs #9111

History

Updated by Sickboy about 5 years ago

  • Status changed from New to Assigned
  • Assignee set to rocko
  • Priority changed from High to Normal
  • Target version set to 1.0.3

Updated by Xeno about 5 years ago

  • Assignee changed from rocko to Xeno
  • % Done changed from 0 to 50

Activated Search/Disarm.
It will drop the primary and secondary weapon to the ground.

Gear dialog for unconscious units is a no.

Arrest may get implemented or not :)

Updated by Alderman about 5 years ago

I hope some of this gets going so we can have more focus on ROE, and EPW's

Updated by Kenex05 about 5 years ago

btw, What is Rehab. use for ??

Updated by rocko about 5 years ago

Squadleaders or high ranked officers can turn renegade players back friendly, i.e if a player has become hostile due to a FF incident.

Updated by Sickboy about 5 years ago

  • Target version changed from 1.0.3 to 1.1

Updated by Naserve about 5 years ago

Would it be possible to add in arrest as just a function to make the AI to SetCaptive and to hold position? I imagine getting them to follow the player and heed commands would be complicated, but just getting them to chill and keep friendly AI from targeting them would be good enough for most applications.

Updated by Naserve about 5 years ago

I don't suppose the search/disarm will be added in on Friday, will it? My realism unit has an event on Sunday and it would be a great help if we could disarm downed enemies.

Updated by luckyhendrix about 5 years ago

May I add that I would be great if rather than disarm the ennemy we could choose to destroy his weapon ( all his gears vanishes) to prevent someone to retreive his gear.

Updated by rocko about 5 years ago

Naserve wrote:

I don't suppose the search/disarm will be added in on Friday, will it? My realism unit has an event on Sunday and it would be a great help if we could disarm downed enemies.

Versioning says 1.1.0

Updated by Naserve about 5 years ago

Ah my mistake. I just tested it on Wednesdays patch and it works however the enemy retains their grenades.

Updated by Xeno about 5 years ago

Naserve wrote:

Ah my mistake. I just tested it on Wednesdays patch and it works however the enemy retains their grenades.

Currently only the primary and secondary weapon get dropped.

Updated by Naserve about 5 years ago

Xeno wrote:

Naserve wrote:

Ah my mistake. I just tested it on Wednesdays patch and it works however the enemy retains their grenades.

Currently only the primary and secondary weapon get dropped.

Alright. What I personally would like to see is the arrest function setting them to captive and the search/disarm function removing all equipment.

Updated by mr.g-c about 5 years ago

  • Target version changed from 1.1 to 1.0.5

Xeno wrote:

Gear dialog for unconscious units is a no.

Care to explain why? Its for me one of the cool small features missing from ACE1.

Updated by Xeno about 5 years ago

  • Priority changed from Normal to Low
  • Target version changed from 1.0.5 to 1.1

Updated by Xeno about 5 years ago

  • Status changed from Assigned to Closed
  • Target version changed from 1.1 to 1.0.6
  • % Done changed from 50 to 100

Updated by Xeno about 5 years ago

  • Status changed from Closed to In progress
  • Target version changed from 1.0.6 to 1.1
  • % Done changed from 100 to 80

Updated by Xeno about 5 years ago

  • Component changed from Wounding System to sys interactive

Only arrest is missing but rocko promised me to implement it.

Updated by Naserve about 5 years ago

So Xeno what does the final search and disarm do? All gear? All Weapons?

Updated by Xeno about 5 years ago

Naserve wrote:

So Xeno what does the final search and disarm do? All gear? All Weapons?

It removes everything except items (after the drop of primary and secondary weapons).

Updated by rocko about 5 years ago

  • Status changed from In progress to Closed
  • % Done changed from 80 to 100

Arrest only works when SRRS module is active

Also available in: Atom PDF