Bug #9098

Wire-guided missiles drop upon firing.

Added by SimonC979 over 5 years ago. Updated over 5 years ago.

Status:Closed Start date:02/15/2010
Priority:Normal Due date:
Assignee:Sickboy % Done:

100%

Category:Script
Target version:1.0.3
Component:sys_missileguidance Affected Version:256
Close Reason:

Description

In Singleplayer, the missile only drops the first time, any missiles fired afterward guide properly. On Multiplayer, all missiles have this drop.
Here's a quick copy-and-paste of a summary of the bug that I wrote up earlier:

Ok, after testing, there's one thing I can see really. On the first shot of a TOW from a TOW Humvee, the TOW drops. It seems to go perfectly fine on the next few shots, so it seems like it's just the first missile. Firing at a downwards angle (i.e. firing down a hill at a target) seems to make the effect worse, it seems to be a bit more controllable when firing uphill. I tested the following vehicles for this missile drop:

  • TOW Humvee
  • Stryker ATGM (SLAT/M240)
  • M2A2 Bradley
  • Static TOW
  • Static Konkurs
  • Static Metis
  • BMP-2D with Konkurs

As you can see, I tested some OPFOR wire-guided missile systems to see if they were affected, and they were. Interestingly, after firing the first shot with one vehicle, e.g. the TOW Humvee, the first shot of the Stryker would be on target. I can only imagine that the script used to guide the weapons is only called up on the first shot, and that it's clientside. This could cause the momentary missile drop, as the script would take some time to load (about 0.5 - 1 seconds I guess). This would explain why all the other missiles were guided properly after firing one shot from any vehicle, and why it happens with every shot in Multiplayer. If it's being called clientside, then I guess it's only being run once then terminated, which would explain why all other missiles drop after the first one.

This is all just me guessing here, but it makes sense to me. Is this possibly what's happening?

arma2.RPT (2.7 kB) SimonC979, 02/15/2010 16:59

test-tow-mpmission.utes.zip - test mission (1 kB) 1longtime, 02/24/2010 15:43

Arma2.RPT - my very brief ARMA2.RPT recorded while I was running the test mission (1.7 kB) 1longtime, 02/24/2010 15:43


Related issues

related to A.C.E. for OA - Bug #9160: Guided missiles are falling down after start Closed 02/17/2010

History

Updated by KingHomer over 5 years ago

Please attach your RPT. I cannot reproduce this bug atm.

Updated by SimonC979 over 5 years ago

Done. Can't see anything in there about HMMWVs, TOWs or anything, just a custom face error.

Updated by Sickboy over 5 years ago

  • Category set to Script
  • Status changed from New to In progress
  • Assignee set to Sickboy
  • Target version set to 1.0.3
  • % Done changed from 0 to 60
  • Component set to sys_missileguidance
Confirmed with tonights update, working:
  • BMD1-P
  • BMP2-D
  • T90
  • M2A2
  • HHMWV

First shots sometimes seem to dive more than others.

Please check after release.

Updated by SimonC979 over 5 years ago

Will do Sickboy, cheers.

Updated by fireship4 over 5 years ago

i find if you fire a TOW on an uneven surface you have the same problem.

Updated by Sickboy over 5 years ago

Ty. At least the guidance works again right? :)

Updated by Sickboy over 5 years ago

  • Status changed from In progress to Feedback
  • % Done changed from 60 to 80

Updated by Sickboy over 5 years ago

  • Status changed from Feedback to Closed
  • % Done changed from 80 to 100

Updated by 1longtime over 5 years ago

This is not fixed. TOW missile still travels about 10m and hits the ground.

This is only occurring when the TOW_TriPod is created via "createVehicle" command.

Steps to reproduce:

1. Place a TOW_TriPod launcher in the editor (Units -> double left-click -> Nonplayable -> SIDE: Empty -> Static -> M220 TOW 2A [USMC])
2. Place a TOW Hummer in the editor
3. Place a trigger that will create a TOW via "createVehicle" such as:
activationBy="WEST";
name="towPos";
expActiv="hint ""make a TOW with createVehicle""; _towCreate = ""TOW_TriPod"" createVehicle (position towPos);";
4. Place three targets
5. Align crosshairs on target and fire with each TOW
6. Observe that the editor-placed TOW units will hit their targets, the trigger-createVehicle TOW missile will fall and strike the ground within 10m

Updated by luckyhendrix over 5 years ago

I think I noticed if sometime even with vehicle not being created by command.

Updated by 1longtime over 5 years ago

Can this be reopened? The above steps to reproduce are reliable, a TOW placed by createVehicle is still borked.

Updated by Sickboy over 5 years ago

Please include your arma2.rpt in your reports. See Bugz for details.

works fine for me again, is your CBA up2date? dummy = [] spawn { sleep 3; _towCreate = "TOW_TriPod" createVehicle (getPos player) };

Updated by 1longtime over 5 years ago

Using latest at this moment:

@ACE 284
@ACEX 201
@ACEX_PLA 13
@ACEX_SM 20
@CBA 79

I attempted to create a mission to reproduce this bug, but now I can't even get into TOW_TriPod as gunner... I created a new Bug for that issue:

http://dev-heaven.net/issues/9274

...I'll have to come back to this bug (9098) after that is sorted out so I can produce a test mission and provide an ARMA2.RPT (although there isn't anything to see in the RPT for this, if I recall correctly)

Updated by Sickboy over 5 years ago

The RPT confirms info for us, and is used as a baseline for repro situations, or to find warnings or errors, or anything remotely related to it.
Any background info helps :)

In the mean time, I've actually improved the way we compile functions and scripts, maybe the issue depends on how arma performs on your system.

Updated by 1longtime over 5 years ago

After sorting out the other mount-TOW-bug (not an ACE2 issue), I finally retested this. It is only happening on the first TOW missile fired in the mission.

Steps to reproduce:

1) Start the test mission attached
2) Enter the TOW_TriPod (I could only enter it from the front, which is an Arma2 bug)
3) Try to kill a tank
4) Observe the first missile fired dives toward the ground, usually hitting the ground and not the target

This can be repeated (by restarting the mission) and firing the TOW Hummer. You will see the missile fall, but because the Hummer weapon is higher from the ground the missile trajectory will usually correct itself and still strike the target. The TOW_TriPod is very low to the ground, however, and the first shot reliably hits the ground. Each subsequent shot is fine, it's just the first shot.

This is what I'm observing. I have found the TOW accuracy when spawned with a "createVehicle" issue no longer exists, don't know if that was my mistake or what... but I guess it can be ignored.

Attached a test mission and my ARMA2.RPT

running only the ACE related mods:

@cba;@ace;@acex;@acex_sm;@acex_pla;

Mod versions are same as I posted above.

Updated by Sickboy over 5 years ago

  • Target version changed from 1.0.3 to 1.0.5

I have applied improvements to the pre compilation of functions, hopefully resolving the issues. Please retry after update.
(The changes are in CBA btw.)

Updated by Sickboy over 5 years ago

How's that working out for you guys? :)

Updated by 1longtime over 5 years ago

  • Target version changed from 1.0.5 to 1.0.3

Nice work, all functioning as expected now.

Sickboy, I sent you an email to your dev-heaven account (sb@dev.....), did you receive it? If not, how can I contact you with a brief question? Can you email me at 1longtime0 [at] gmail?

Updated by 1longtime over 5 years ago

double post, please disregard

Also available in: Atom PDF