Bug #9018

Update not writing all files

Added by Xiathorn about 5 years ago. Updated almost 5 years ago.

Status:Expired Start date:02/11/2010
Priority:Normal Due date:
Assignee:Yoma % Done:

0%

Category:Download
Target version:-

Description

Hi Yoma,
A new member over at ShackTac has encountered a issue that we haven't been able to remedy. We're not sure of the cause, was wondering if we'd discovered a bug or something. Details as follows :

//start of post
Beagle says :
Hey guys, in the course of trying to get YAS working it was suggested I detail the problem on the boards, so here we go:

As I sit looking at YAS, this is what I see right now - http://img52.imageshack.us/img52/9620/yasnewlocals.jpg

Certain files become marked as 'new local' and become marked in angry looking red, with the extensions of 7z and tmp being added on to the end.

If you look down further to the pink files, you'll see that these same files are still in the pink list too, without these extra extensions and without being named a new local.

If I hit delete extra files, it brings up all the files that are currently marked as new local, without a checkbox - http://img249.imageshack.us/img249/3959 ... delete.jpg

If I check them all and delete them, it'll re compare my files and everything will be nice and happy and pink, like this! - http://img52.imageshack.us/img52/2131/yasnolocals.jpg

So then I'll restart the process by clicking 'Download Addons'. It'll begin downloading caa1_p_buildings.pbo.7z. I think I've downloaded this file like six times now, at least - http://img715.imageshack.us/img715/6563 ... ldings.jpg

As it downloads, it may or may not suddenly stop downloading altogether and sit still for a while, making no progress. It may decide to do this at the start, in the middle, or 200kb from the end. It will sit like that for a while, then eventually decide that it has timed out. - http://img249.imageshack.us/img249/5882/yastimeout.jpg

However, even if it DOES finish completely - and it has several times now - it will still fall prey to new local syndrome next time I start up YAS, for example if YAS crashes and I load it back up. - http://img130.imageshack.us/img130/8817/yasnewlocal.jpg

So, that's pretty much as detailed a report as I can give of what's going on. In the worst case, would it be possible to download each of the files that seem to have trouble making it down and sticking them in manually?

Any help would be appreciated, I'd love to be able to play in the pFNG session tomorrow!

P.S. It just crashed again, here's a picture of the details if that can be of any use: http://img52.imageshack.us/img52/6/yascrash.jpg

//end of post
We've tried a number of approaches, including:
Running in Admin mode
Compatability mode (XP SP3)
Core affinity limited to one core
Going into Settings and then unchecking "Use MD5 cache."
Using an older version of YAS (10410)

History

Updated by Yoma about 5 years ago

He seems to be using vista/win7 => point him to the virtual store folder, have him clear all Bohemia Interactive items in there, thank MS for the most shitty idea they had in times ;-)

The .tmp files are temporary files the tool uses to download to, these are used for resuming downloads, no need to panic about them, the only time they could get you into trouble is if the repo changes while you are downloading.

The time-outs point to a bad internet connection / bad connection to the server. (have him disable the tcp chimney shit that VISTA/WIN7 introduced, verify he's not on some shitty wireless connection, tell him to use cable if so)

Compatibility mode is not needed, core affinity might cause unexpected behaviour.

Tell him to upgrade to v1.0.49

Updated by Beagle23 about 5 years ago

I'd never heard of the virtual store folder before but located it at C:\Users\username\AppData\Local\VirtualStore and found absoloutely nothing in it.

I disabled TCP Chimney (again, had never heard of it) using "netsh int tcp set global chimney=disabled" in the Run prompt, but still no joy.

I just googled the way to do both so if you spot a problem in my execution please correct me! Also, the problem seems to be much worse now - when it first started happening the download-freezing happened at random and sometimes not at all, even though if it did complete the file would not be saved. Now however, it seems to happen almost immediately - after about 6 MB or so the download just stops, which is a far cry from finishing or almost finishing a 300 MB file as it used to.

I can't get my head around what the issue is - YAS has managed to download every file but these 17 (not including the version.txt files), and it's successfully downloaded larger files than this. There doesn't seem to be any link between the files to signify a common problem, at least not to my eye.

Oh, and yes, I'm using a cable.

Thanks for your assistance so far!

Updated by Yoma about 5 years ago

If you want me to, I can connect to your pc this evening so we could look at it together.
What timezone are you in? I'm in UTC/GMT +1 hour (Brussels timezone).

I could try build some different versions with for example different download blocksize settings which might give different results as well.

What virusscanner are you using? Potentially the virusscanner blocks files for write from time to time.
(This should not be the case as they should be locked by my program)

Updated by Beagle23 about 5 years ago

Connect to my PC? Sounds cool.

I'm in timezone GMT +10, but I'm not busy so basically if you name a time I can be around for it

I'm using Avira AntiVir Personal.

Updated by Yoma about 5 years ago

  • Category set to Download

Updated by Yoma about 5 years ago

Is anyone still having problems with this?

Updated by Yoma almost 5 years ago

  • Status changed from New to Expired
  • Assignee set to Yoma

Also available in: Atom PDF