Bug #8973

Formation heading not updating accurately according to leader's body direction

Added by Variable over 5 years ago. Updated about 4 years ago.

Status:Expired Start date:02/10/2010
Priority:Normal Due date:02/01/2011
Assignee:- % Done:

0%

Category:AI Issues
Target version:-
Affected ArmA II version:1.55.75445 First affected build:
Reproduced by another DH user:No First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:No NGUrl:
Related to content of DLC: WIKIurl:

Description

Most of the times the formation heading will not update itself according to the team's direction of movement. It seems that sometimes it is stuck on other directions. In OFP it worked perfectly according to the leader's advance axis. BIS ArmA 2 patch 1.05 should have changed that ("[60323] Changed: Formation direction now adjusts to human leader body direction, not a movement direction.") but it still seems like nothing has changed since ArmA 1 and AI's won't react correctly to both movement direction and body direction.

AIdirectionProblem.jpg (32.4 kB) Alex72, 02/13/2010 14:28

05_reorganized_after_regroup_all_well.jpg (79.1 kB) CarlGustaffa, 05/11/2010 18:49

04_regroup_order_given.jpg (82.9 kB) CarlGustaffa, 05/11/2010 18:49

03_fully_reorganized.jpg (88.3 kB) CarlGustaffa, 05/11/2010 18:49

02_reorganizing_after_stop.jpg (88.6 kB) CarlGustaffa, 05/11/2010 18:49

01_wrong_dir_and_report_moving.jpg (89.8 kB) CarlGustaffa, 05/11/2010 18:49

arrowhead_campaign.zip - savegame which hopefully contains the bug... (8.1 MB) miljo, 10/05/2010 17:24

Distress_Call.Takistan.zip (2.1 MB) miljo, 11/13/2010 14:59

History

Updated by Fireball over 5 years ago

  • Due date set to 02/25/2010
  • Status changed from New to Feedback
  • Affected ArmA II version changed from 1.05 BETA to 1.06 BETA

Do you mean the latest beta which came up since 1.05 final? This is supposedly 1.06 BETA.

Also, we need repro steps, a mission and/or a video.

Updated by Fireball over 5 years ago

  • Assignee set to Variable

Updated by Variable over 5 years ago

The tested version is actually 1.05, but I didn't see it on the list. Can you change the entry?

I thought that this is a very obvious bug, but I can produce a video that examples it.

Updated by kju over 5 years ago

  • Affected ArmA II version changed from 1.06 BETA to 1.05.62017

There is no such thing as obvious.

We need observed behavior, vs expected in short words.
In addition a reproduction steps and best a demo mission.

See the CIT wiki guide.

Updated by CarlGustaffa over 5 years ago

It has been like this forever for me. Note the word 'sometimes' OP uses. I have never been able to reproduce this 'on command'. I don't know what is causing it. It's very hard to impossible to make a repro out of, or an example mission.

When I start on Utes with two additional AI, everything works as expected, and they will try to orient themselves according to the direction I'm facing (according to the change) instead of earlier behavior where they changed according to my moving direction. So far so good.

But!!! Sometimes it appears that direction is completely 'stuck'. When I move, they might try to get into position, and when I stop, the direction is reset to some arbitrary angle I have no control over. A line formation can have me located behind everyone else in the formation, making it look like a reversed file/column. A wegde may appear as a vee, with all "enemy in front of us..." reports actually meaning enemy behind us. It's a real mess.

If Variable can make a video, that would be great. Because I've tried for quite some time now without being able to trigger the bug. But I know it's lurking in there somewhere :)

Updated by Alex72 over 5 years ago

I have pointed this out before but i gave up. Its hard to repro as mentioned as i dont know what really causes it.

I think i noted this behaviour mostly on slopes/hill sides.
When the ground isnt completelly flat the AI sometimes seem to snap into this problem where they cannot form on you (your direction). They do form with LINE, FILE or whatever formation is issued, but their direction is completelly wrong according to you - the leader. The direction that the AI wrongly snap into can be any heading but the leaders.
Order "form on me" does not help. They form in the wrong direction and say "ready".

Made a simple image showing the problem.

Updated by Variable over 5 years ago

I didn't have the time to test. Can someone who experience it video capture this bug and upload it?

Updated by Fireball over 5 years ago

  • Due date changed from 02/25/2010 to 03/25/2010
  • Assignee deleted (Variable)

Updated by Variable about 5 years ago

I managed to capture a video of the bug. Watch it on Youtube http://www.youtube.com/watch?v=8oxFOijo8lo
The mission is Animal mother's Guerrilla Radio v1.1 http://www.armaholic.com/page.php?id=7874 The location is Chernarus, on top of the Radio tower hill on grid 037093.

Updated by kju about 5 years ago

  • Due date changed from 03/25/2010 to 04/25/2010
  • Status changed from Feedback to Assigned

Cheers!

Still repro steps and a demo mission what BI wants and needs.

Updated by CarlGustaffa about 5 years ago

Well kju, it's a big problem for us. It's not mission specific, and repro steps are (seemingly) impossible. We are in the blind as to what is causing this, still it is a big bug causing all sorts of problems and must be addressed.

But alas, they seem to be working on it. Using beta 69782, the AI DO now react after a "return to formation" order is given. Unlike in the video where they will first try, and then go back to the messed up formation direction.

I've attached some images showing the new behaviour of 69782.

Updated by kju over 4 years ago

  • Due date changed from 04/25/2010 to 10/01/2010
  • Status changed from Assigned to Feedback
  • Audio card set to Please specify!
  • Size of OS swap file set to Please specify!
  • I am using some Mods set to No
  • Reproducible for you set to No

Still true in latest OA?

Updated by miljo over 4 years ago

kju wrote:

Still true in latest OA?

Hi kju

unfortunately yes and most annoying. Happens with or without mods on every map (also on Shapur). I love this game but this bug makes it hardly playable. I can't reproduce it, but I know lots of people who have the same problem. I hope they'll fix it soon...

Updated by kju over 4 years ago

  • Due date changed from 10/01/2010 to 12/01/2010
  • Status changed from Feedback to Assigned
  • Affected ArmA II version changed from 1.05.62017 to 1.54.72888

Ty

A demo mission with repro steps would up the chances to get this sorted a lot.

Updated by miljo over 4 years ago

Hi!

As I said I can't repro it BUT last time I played the Arrowhead campaign it happened again. When I saved the game (to prevent myself from heavy keybordbashing ;-)) and loaded it, after rebooting my PC, it was still there.

I uploaded the savegame and the configs which I found in that folder. (hope I got the right one... you should be a tank commander at 089069. btw German version)

hope this works out...

Updated by miljo over 4 years ago

erm... by "it was still there" I meant the chaotic formation, not the savegame itself. ;-)

Updated by kju over 4 years ago

tx

Updated by CarlGustaffa over 4 years ago

What's the status on this? I see it's assigned, but to nobody. Does it mean the bug is abandoned, given up hope on fixing it?

Updated by miljo over 4 years ago

bug is still alive. even with latest OA patch 1.55

this ruins a lot. ai doesn't respond to "back to formation" or anything else. Makes every CQC in towns unplayable if you use AI. If anyone needs more proof I can upload some videos.

One thing's for sure it's definitely not mod-related.

BIS HELP please!

Updated by kju over 4 years ago

  • Due date changed from 12/01/2010 to 02/01/2011
  • Affected ArmA II version changed from 1.54.72888 to 1.55.75445

A demo mission with repro steps would up the chances to get this sorted a lot.

If you cannot repro it, how should BI?
Maybe you want to try gathering evidence one by one which seems to lead to it.

Updated by Variable over 4 years ago

Is repro steps really needed? This bug happens so many times that it seems to me that repro steps would be just "play the game as squad leader, observe the bug". Isn't all the information gathered here enough? there are many jpegs, a youtube link and a mission, what else should we produce?

Updated by kju over 4 years ago

Yes. The coder needs a very specific example of the issue.
Otherwise he can waste many hours trying to reproduce it.

Just read the link explanations of Suma in the wiki.

Updated by miljo over 4 years ago

"a very specific example of the issue" -> ok, I attached a quick mission (pbo or editor friendly) I wanted to develop some time ago. It's pretty rough yet - more like checking out an idea but playable.
The interesting thing is that everytime I play it the formation gets mixed up very fast. If you want you can check it out.

Play as Teamleader. Try to get them into staggered column. (You can even take the group and move it to any position - free of enemies - on the map - the formation gets mixed up after a short period of time.)

That's all I can do since I'm no programmer with deeper understanding of the subject. btw I also "wasted" some hours trying to reproduce it and sadly I'm the paying customer doing another man's job... ;-)

because the mission briefing is in German here's what you have to do. It's simple but fun to play.
First player plays the ambushed US Army teamcommander and tries to reach the extractionzone NE/ second player provides CAS using the Wildcat. (later on 2player switches into the Merlin for extracting player one - Ai should continue giving CAS in a more or less successful way) No Mods needed.

I can reproduce it that way EVERYTIME. Hope that helps. (btw: bug also occurs in BI mission and campaigns)

Updated by Variable over 4 years ago

At last! We have reproduction steps. kju, can this bug be processed now? Seems like all information is available now. Is there anything else that is needed for BIS to debug it?

Updated by kju over 4 years ago

  • Assignee set to Fireball

Fireball can you please check it.

Updated by Fireball over 4 years ago

  • Status changed from Assigned to Feedback
  • Assignee deleted (Fireball)

Checked it, this is no usable repro mission, it's a complete scenario.

A repro mission is specifically designed with a few units and script commands a needed, only to demonstrate that specific issue.

Updated by kju about 4 years ago

  • Status changed from Feedback to Expired

Also available in: Atom PDF