Bug #8843

[EW] Eagle Wing campaign broken due to removed deleteCollection command

Added by CarlGustaffa over 5 years ago. Updated over 3 years ago.

Status:Closed Start date:02/05/2010
Priority:Normal Due date:12/01/2011
Assignee:- % Done:

0%

Category:Campaign
Target version:1.60.87580
Affected ArmA II version:1.57.76815 First affected build:63826
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Affected version, 1.06 beta build 63826: ftp://downloads.bistudio.com/arma2.com/update/beta/ARMA2_Build_63826.log
I assume no further details are necessary? :)

History

Updated by kju over 5 years ago

  • Due date set to 02/19/2010
  • Status changed from New to Feedback

How does it break what?

Updated by alef over 5 years ago

Carl's post

#deletecollection brownFake;
...
Error undefined variable in expression: deletecollection

Updated by kju over 5 years ago

  • Due date changed from 02/19/2010 to 05/05/2010
  • Category set to Campaign
  • Status changed from Feedback to Assigned
  • Assignee set to Luca

Thanks Alef!

Updated by CarlGustaffa over 5 years ago

Sorry, didn't think it was needed. But EW uses a command that is now removed. So EW doesn't start at all for me as the script using the command fails. I thought ticket heading and changelog should point the devs on the right track :)

Updated by 76 over 5 years ago

Never heard of anyone not being able to load EW... until now.

Updated by CarlGustaffa over 5 years ago

Are you telling me your EW is working, with beta patch?

Updated by kju almost 5 years ago

  • Assignee deleted (Luca)
  • Audio card set to Please specify!
  • Size of OS swap file set to Please specify!
  • I am using some Mods set to No
  • Reproducible for you set to No

Updated by kju over 4 years ago

  • Due date changed from 05/05/2010 to 02/01/2011
  • Affected ArmA II version changed from 1.06 BETA to 1.55.75445
  • Reproduced by another DH user changed from No to Yes
  • I am using set to CO (A2+OA)
  • Reproducible for you changed from No to Yes

Still true. Needs a simple replacement of deleteCollection with hideObject in 6 scripts.

Updated by kju over 3 years ago

  • Due date changed from 02/01/2011 to 12/01/2011
  • Affected ArmA II version changed from 1.55.75445 to 1.57.76815
  • CPU deleted (Please specify!)
  • Audio card deleted (Please specify!)
  • Size of OS swap file deleted (Please specify!)
  • I am using deleted (CO (A2+OA))

Updated by Sickboy over 3 years ago

  • Status changed from Assigned to Feedback

http://forums.bistudio.com/showthread.php?p=2039825#post2039825

Looks like deleteCollection is back in game (?)

Updated by Sickboy over 3 years ago

Re deleteCollection, it indeed seems to be back, at least, it pops up on auto completion in editor fields, and pressing F1.

Description says: same as hideObject.

I guess it was reintroduced for backwards compatibility, instead of the full functionality as it was before it was removed.
Which is probably sufficient for the usages in the missions.

Could someone please confirm?

Updated by Hanzu over 3 years ago

  • Subject changed from 1.05 Eagle Wing campaign broken due to removed deleteCollection command. to [EW] Eagle Wing campaign broken due to removed deleteCollection command
  • Maxmem parameter deleted (Not set)
  • Difficulty deleted (Not set)
  • First affected build set to 63826

Updated by Hanzu over 3 years ago

  • WIKIurl (Use new instead) set to http://community.bistudio.com/wiki/deleteCollection

I started Eagle Wing campaing without problems and flew around until first contact. Build 85510. What else should I do to test if this issue is still true?

Updated by OMAC over 3 years ago

Using OA beta 85889 (with tbb4 alloc), I restarted EW and played into End Of The World (chopper down, second mission). All looked fine to me.

Updated by kju over 3 years ago

  • Status changed from Feedback to Closed
  • Target version set to 1.60 BETA

Updated by kju over 3 years ago

  • Target version changed from 1.60 BETA to 1.60.87580

Also available in: Atom PDF