Feature #8632

HK417 maybe 416 too

Added by HSV about 5 years ago. Updated almost 5 years ago.

Status:Closed Start date:01/29/2010
Priority:Normal Due date:02/28/2010
Assignee:- % Done:

50%

Category:-
Target version:-
Component: Affected Version:
Close Reason:

Description

Could you improve this weapons to Ace? Because we need more assault rifles with a caliber of 7,62 x 51mm.
It was one of the best assault rifles in Ace I!

rdr12.jpg (62.5 kB) jhoson14, 01/30/2010 20:00

History

Updated by Sickboy about 5 years ago

  • Tracker changed from Bug to Feature

Updated by Sickboy about 5 years ago

  • Target version changed from 1.0.0 to 395

It is possible these weapons will reappear in the future, please stay tuned.

Updated by HSV about 5 years ago

not a bug, its a feature... sorry my mistake...
but how long does it take?

Updated by M1n1d0u about 5 years ago

you should wait , it's better with a long wait time =)

Updated by jhoson14 about 5 years ago

Well mate, they are way ahead of you.This has been posted on ACE2 release thread some time ago, by Panda if memory dont fail me.

http://img519.imageshack.us/img519/3612/wipl.jpg

Enjoy ;)

Updated by HSV about 5 years ago

Yes i know this picture but its only the HK 416. I think Ace have enough 5,56 weapons like M4, M16, G36 and so on. Many people wants some more 7,62 assault rifles like the HK417, HKG3....

Updated by KingHomer about 5 years ago

HSV wrote:

Yes i know this picture but its only the HK 416. I think Ace have enough 5,56 weapons like M4, M16, G36 and so on. Many people wants some more 7,62 assault rifles like the HK417, HKG3....

I think ACE has enough weapons at all. There is always the question you should ask yourself: What does the weapon contribute to the mod? Just another model for satisfaction or does it really affect gameplay? Who does use the HK41x Series anyway? Lists in ammocrates get longer and longer but don't improve gameplay anyhow.

Updated by HSV about 5 years ago

KingHomer wrote:

does it really affect gameplay?

-Improved rotor bending animation for ACEX AH-1Z [zGuba]
-More realistic main rotor blade bending animation for AH-1W [zGuba]

? Does it affect the gameplay? Nobody wants this update....

Yes 7,62 x 51mm assault rifle would improve the gameplay. Because you dont need 10-20 shots to kill a soldier... like with the M4, M16 and so on. Headshot is the same...

Updated by Sickboy about 5 years ago

If you'd like to stick around here HSV, i'd change your attitude quickly. Unbelievable the crap people write in here, go make your own mod or something!

Updated by PeaceDoctor about 5 years ago

I agree that the addition of those, to me, would not really affect the mod.

About the 7.62 argument, I think an M-14 EBR is under progress so it'll fulfill that need for extra punch.

But FIY: even in real life the 5.56 doesn't always stop right on someone. That's why you aim for the bone structure to transmit the maximum energy and break some bones. Unfortunately I doubt that our common computers could support the complete human body's simulation if that was even possible to start with.

Also about headshots HSV check the M24 needing multiple shots topic. The "20 shots" or so or even multiple headshots is related to servers not the mod.
Try on your editor: there is no problem even with the wounding system enabled. That kind of thing only happens on some servers.
So relax bro, all those guys work for the entertainement of others for free on their own time. This is not a right we have to tell them what to do but a privilege from them.
Imagine being in their shoes: you work, have a life, maybe children and a wife etc... you sacrifice some of your time to please others for free and you get that kind of comments and very rare "thanks".

Updated by HSV about 5 years ago

I know what it means to be a modder. Because I created one of the biggest mod for Company of Heroes .
I asked only could you improve them and said it would be a nice feature. More a feature as the animations....
Arma isnt a simulator for planes or so. Its in the first line a infantry simulation.

P.S. i played Ace 1 too and it was the greatest mod for this game^^

Updated by jhoson14 about 5 years ago

The M-14 and HK 416(7) will be a Blufor weapon, so a OPFOR assault rifle with longer range would be very nice.

The AK-47 do have a large caliber, but laks a good acuraccy on long range.A G3 would fit very well the ACE insurgents recently released.

A friend started to model a G3A3 with intetions to donate to ACE2, but he got really busy and had to stop on the model for a while.If the mod dont get a G3 till he have time to finish, he would love to donate the model.

WIP pic.

Updated by IceShade about 5 years ago

I would love to see the HK416/HK417 pack implemented, but actually only for the HK417 series. 5.56 lacks serious punch in ACE2. We already have an ungodly amount of M4 and M16 variants ingame. Then again, I would also like to see Robert Hammer's M16/M4 pack to get rid of the BIS models that have poor sights and some have incorrect zero ranges (unless ACE could fix this, of course).

Another discussion entirely, but my biggest wish is to see Robert Hammer's AK pack in ACE2, if only for the fact that we'd finally have an AKM with an underbarrel grenade launcher and optics.

Updated by Sickboy about 5 years ago

Guys. We know. It is assigned to Future milestone already. Please disengage.

Updated by Scubaman3D about 5 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 50

Ticket is not necessary. Work on HK weapons is ongoing.

Updated by rocko about 5 years ago

  • Target version deleted (395)

Also available in: Atom PDF