Bug #8504

reported map co-ords wrong

Added by DMarkwick over 5 years ago. Updated about 5 years ago.

Status:Rejected Start date:01/25/2010
Priority:Normal Due date:02/24/2010
Assignee:- % Done:

0%

Category:Other
Target version:-
Affected ArmA II version:1.05.62017 First affected build:
Reproduced by another DH user:No First affected ArmA II version:
I am using some Mods: Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you: NGUrl:
Related to content of DLC: WIKIurl:

Description

During gaming, my AI squad will often report objects of interest via map co-ords. They might use a figure like:
"042066".

But upon checking the actual position of the object, it appears that the Y co-ord element is wrong. Specifically it is increased by 10. So the above reported object is actually at co-ords:
042056.

I see this +10 discrepancy consistently.

Further to this, a screenie showing the problem. You can see the message I received, the position of the mystery tank on the map, and it's co-ords as represented by the side numbers.

The tank might have moved a small amount between me receiving the message and grabbing the map screenie, but you can see that there's definitely a gross Y component problem. Either the tank is being reported at the wrong position, or the numerical details at the edge of the map are incorrect.

[IMG]http://img.photobucket.com/albums/v15/DMarkwick/IncorrectCoords.jpg[/IMG]

gridpos_reading_how_to.jpg (133.9 kB) CarlGustaffa, 01/31/2010 11:34

gridpos_reading_near_edge.jpg (90.9 kB) CarlGustaffa, 01/31/2010 11:34

gridposinverted_reading_near_edge.jpg (96 kB) CarlGustaffa, 02/01/2010 05:19

_Test.rar (821 Bytes) CarlGustaffa, 02/01/2010 09:14

gridNumbersOverLineBroken.jpg (183.8 kB) Nou, 02/10/2010 01:37

History

Updated by DMarkwick over 5 years ago

Updated by Sickboy over 5 years ago

  • Project changed from DevHeaven (Only site issues) to ARMA2 Community Issue Tracker

Updated by DMarkwick over 5 years ago

Sorry for the misplaced issue SB :)

BTW, I fouled up the basic math in the initial issue post. I don't seem to be able to edit it, but the second paragraph co-ord of "042046" needs to read "042056" :)

Updated by Fireball about 5 years ago

  • Due date set to 02/10/2010
  • Category set to Other
  • Status changed from New to Feedback
  • Affected ArmA II version changed from Please select... to 1.05.62017
  • Reproduced by another DH user set to No

Your map screenshot is not zoomed in enough to see the correct sector.

Could you please verify actual location vs. shouted location while zoomed in more?

Updated by Nou about 5 years ago

This is actually an issue that has to do with the World property gridNumbersOverLine in maps.

This is turned on by default in ACE2 and the functionality appears to be broken. The grid numbers will be offset by 100 meters at 6 digits and by 1000 meters at 4 digits.

You can view this easily by zooming in and out slighty and watching the grid lines change when the map moves between showing 4 digit and 6 digit grid reference numbers (or 3 digits and 2 digits per northing and easting values).

The 04 northing will become the 049 northing when you zoom into view 6 digit grid references.

You can doubly verify by place something on the map in the editor and calling mapGridPosition on it. The 6 digit grid reference will be off by 100 meters.

Updated by Trexian about 5 years ago

Ah! It is basically a rounding error. If the line were at 4.5 instead of 4.9, it would alleviate the issue?

Updated by Nou about 5 years ago

I don't think so. I think its an issue with an offset. For example gridsquare 000000 should be the upper left hand corner in the map. Right now its in the upper left but 000 northing starts 100 meters from the top of the map, so really the top of the map is -001000.

Updated by Nou about 5 years ago

This should be fixed in the next ACE2 RC patch. The grid numbers have been moved back to their original position in the middle of the grid squares.

The issue still exists inside of ArmA2.

Updated by kju about 5 years ago

Possible to provide the diff? I guess its s simple config tweak?

Updated by Nou about 5 years ago

kju wrote:

Possible to provide the diff? I guess its s simple config tweak?

Basically.

http://dev-heaven.net/repositories/diff/ace-mod2/Addons/c_ui/ui_map/ui_map.hpp?rev_to=5c24ab8a1c065f7e06b5c0289cb9f762fa60d5b7&rev=7c7f65f19c688e5324295b1aee7a1d5d76be7332&action=diff&id=ace-mod2&path=Addonsc_uiui_mapui_map.hpp&controller=repositories&type=sbs

The odd part is that setting it to 0 didn't seem to make a difference. I had to actually comment out the line (so I commented out the whole class).

Updated by CarlGustaffa about 5 years ago

I actually find nothing wrong with BIS center numbering system or ACE on line numbering system.
http://en.wikipedia.org/wiki/Grid_reference

The only source of all this confusion is because BIS decided to increase grids downwards instead of upwards.

A northing of 02 is when a unit is placed IN the 02 grid on BIS label, or ABOVE the 02 grid on old ACE label.
A northing of 023 is when a unit is placed IN the 023 grid on BIS label, or ABOVE the 023 grid on old ACE label.

For me, when I check a units status (5-5), he will report correct 6 digit grids, with or without ACE labeling.

Or maybe I am just misunderstanding the whole problem?

Updated by Nou about 5 years ago

Misunderstanding the issue.

This is sort of hard to test now since the grid numbers are no longer placed on the line in ACE2.

For an easy example though, place a unit on Utes, start the game, go to your map zoom out till you see 4 digit grid refs (2 digits per direction).

Place a map marker directly on the 02 northing (thats the 02 line running left and right on the sides of the screen). With a 6 digit grid ref that should be 020. When gridNumbersOverLine is enabled when you zoom in the map marker will actually be on the 6 digit northing 029, its jumped 900 meters south.

Updated by kju about 5 years ago

How about a screenshot for your example Nou?

Updated by CarlGustaffa about 5 years ago

I wrote my own "addon" (even comes with error messages, lol, but at least I'm getting numbers on the lines), just to test and try to figure out what I'm not getting. I tried without ACE though, just vanilla 1.05 and this addon. I've attached some images. Please give me pointers to what I'm not getting, as still I'm having no issues with it, other than the counter intuitiveness of numbers increasing in a downward fashion while reading above the line.

Edit: I also checked the tank position DMarkwick shows on the map as wrong. To me, when reading right and up, 042066 is correct (as the engine uses), and not 042056 as DMarkwick suggests to be the correct grid.

Now, if Arma2 labelled its grid updwards, like this:
http://en.wikipedia.org/wiki/File:Fictional_Map_1.jpg
everything would become a lot more intuitive, but it doesn't change the fact that you are able to get the correct grid number when reading right and up, regardless of zoom level.

Updated by Nou about 5 years ago

You can clearly see what is wrong in those two images.

Look at the second one especially.

At 4 digits the units are on or about on the 02 line. 02 means 2000 meters from the top.

At 6 digits the units are on or about on the 029 line. 029 means 2900 meters from the top.

The units have not moved 900 meters between zooming in.

Updated by CarlGustaffa about 5 years ago

Forget the top when all references are supposed to be right and up (meaning bottom left) :) It's impossible to have right and up based reading while keeping compatible with right and down (from the top). It's unavoidable (at least I can't think of a way to fix it, while keeping correct reading procedures, without negating the y axis).

Now, I did an experiment to invert the y axis. 000 is still located at the top (unseen). It avoids the 029 becoming 02 (although it is technically correct and unavoidable on a map with increasing numbers downward), but instead 020 becomes 02 same as the x axis, which I assume is what you and everyone else wants (including me).

Question: Does this grid system make it any easier to read, ignoring top left? Is lower left more intuitive now?

Updated by Nou about 5 years ago

Sorry Carl, I'm really confused by your last post. Did you shift the whole map up?

Right and Up is how its supposed to be read in real life, but for the sake of the game it should probably be left to right and down since thats what everyone is used to (though I am not partial myself). Also AI units wont report the references right anymore.

Updated by kju about 5 years ago

The 4 digit grid seems not correctly positioned.

Updated by CarlGustaffa about 5 years ago

I don't see what is wrong with the 4 digit grid. Seems ok by me, except I didn't put in any offset, so probably that causes the large grid numbers.

No, I didn't shift anything, only inverting y axis so that it increases numbers going upward instead of downward. AI units report grid references just fine, both for own position reports and when I tested with spotted enemies.

http://www.survivaliq.com/navigation/grids_par4.htm
http://en.wikipedia.org/wiki/File:MGRSgridHawaiiSchemeAA.png (from http://en.wikipedia.org/wiki/Military_grid_reference_system)

I've attached the "addon" that makes it happen, so you can try it out for yourself. Warning, I have absolutely no idea what I'm doing as far as addon making goes, so I may break a ton of things. I managed to get back missing stars and moon etc, but who knows what else is missing :) Try without any other addons that may conflict.

For fun, I moved Utes "a bit north", way up north in Russia, north of the arctic circle. Winter daylight and summer nights are, well, a bit special :) I also tried moving it close to the south pole, and got southern stars but clouds were messed up (coordinate problem I guess).

Damn Arma2 is deep :)

Updated by Nou about 5 years ago

Cool, I am already off my PC for the night, I'll look at the code later, but if there is a reliable way to get Northings acting like Northings (which it appears you have found a way to do so) and they work with the label on the grid line (which it looks like is the case when they are inverted) then thats really good news. :)

Updated by CarlGustaffa about 5 years ago

Any luck with this one Nou?

Updated by Fireball about 5 years ago

  • Due date changed from 02/10/2010 to 02/24/2010

Giving some more time to clear this up; let's see if I understand it right;

The AI reports 6 digits coordinates just right, if you read them right - and from what I can tell it seems to me that also the 4 digits grid is right (implicated).

So do we have a non-issue here and potentially a mere misunderstanding or different ideas about how it's supposed to be done? I'll reject after Due Date if the issue is not made clear.

EDIT: Please leave ACE2 out of the issue here - it's not relevant for the A2 CIT.

Updated by Nou about 5 years ago

Fireball wrote:

EDIT: Please leave ACE2 out of the issue here - it's not relevant for the A2 CIT.

It actually is in part related to ACE2. ACE2 turned gridNumbersOverLine on by default on all maps. In vanilla ArmA2 you do not see this. You no longer see it in ACE2 either because we turned it off, because it is broken.

This issue does not appear otherwise. When the grid number appears in the middle of the grid square the number occurs correctly. When gridNumbersOverLine is turned on grid numbers are totally messed up.

Grid 0302 becomes 019020 when you zoom in, etc.

Updated by Nou about 5 years ago

In reality you should re-title the ticket to gridNumbersOverLine is broken. Otherwise the map and reporting position is fine.

Updated by Nou about 5 years ago

I'll try to explain this better... Hopefully this image will do it better. :)

edit

the = 2000,2000 should read = 20000,20000

Updated by Fireball about 5 years ago

Nou wrote:

I'll try to explain this better... Hopefully this image will do it better. :)

edit

the = 2000,2000 should read = 20000,20000

Thank you very much, but I should ask you to open a new ticket with your description rather in the ticket than in the image and is there a possibility for repro steps/mission? This bug has become too cluttered and will be rejected, as soon a new ticket is made. Thanks!

Updated by DMarkwick about 5 years ago

OK, so in summary:
  • It was a map display issue not an AI positional report issue.
  • It was an ACE2 issue due to BIS default map display behavior being changed.
  • It's now fixed since the ACE2 change was reversed.

I think that's a win for the issue tracking process in that case :) Thanks for the time spent on this guys, I can "safely" turn up the realism to lose map icons then, knowing that AI reports are now faithful to the map display now.

Updated by Nou about 5 years ago

Basically. I am not sure its worth making a new ticket either since this is undocumented functionality which is broken and no one else uses it.

Updated by Fireball about 5 years ago

  • Status changed from Feedback to Rejected

As you want; this write-up is not off the world anyway.

Also available in: Atom PDF