Feature #8483

Radios don't work as itemRadio

Added by CarlGustaffa over 5 years ago. Updated over 5 years ago.

Status:Rejected Start date:01/25/2010
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Complex
Target version:-
Component: Affected Version:
Close Reason:

Description

In order for [west,"HQ"] sideChat "message" to get through, a player is required to have itemRadio in his inventory. Having a west radio (i.e. ACE_PRC119) does not have the same attribute set. It would be nice to have that same attribute set for the rucked radios.

Reason: Disabling AI chatter in ace_clientside_config.hpp disables all voices, and makes the battlefield "sterile". If the above worked as I suggest, you could disable AI over the radio network only, by not having itemRadio with you, and still be able to receive scripted messages from HQ or wherever. AI would still chat like normal using direct chat (since you don't have a groupradio, itemRadio). DirectChat has never been a problem for me regarding AI, only their extreme volume on the radio if you have any intentions of using built in VoIP for human players.

History

Updated by Sickboy over 5 years ago

Would be nice if possible. Not sure if ItemRadio can be mounted on back though :)
Otherwise, maybe a system like sys_map, sys_radio, where an ACE PRC ruck etc automatically gives you an itemRadio, and so forth ?

Updated by CarlGustaffa over 5 years ago

Wouldn't work, as then you'd have those screaming AI voices over the radio again :) The point for me would be to not carry itemRadio (to silence AI radio chatter), while having ACE_Radio so that sideChat would work again. This because I don't want to silence AI completely, only their radio voices.

class ItemRadio: ItemCore {
scope = 2;
displayName = "Funkgerät";
simulation = "ItemRadio";
picture = "\ca\ui\data\gear_picture_radio_ca.paa";
descriptionShort = "Funkgerät";
};

Maybe that simulation attribute is enough? I really don't know anything about configs.

Edit: On the other hand, if simulation was put in, that might enable radio as well, ruining what I was looking for. Maybe I should just use globalChat with logics instead.

Updated by CarlGustaffa over 5 years ago

Yeah, I'm able to fix my part of the problem using globalChat, so problem fixed, sort of.

But the root is still at large, ref ace_clientside_config.hpp:

/*//////////////////////////////////////////////
CONFIG SETTING FOR : ACE 2 MOD - NO VOICE, NO RADIO CHATTER
--------------------
FEATURES: Disables AI radio chatter as well as player radio chatter
---------
TO ENABLE: Remove the "//" in front of the #define to enable the NO VOICE, NO RADIO CHATTER feature. To disable, think vice versa.
----------
//////////////////////////////////////////////*/

//#define ACE_NOVOICE

It removes all chatter, including direct chat (which is not annoying), instead of only radio chatter (where the problem is AIs volume overpowering human voice).

So maybe there should have been a separate option, ACE_NOAIRADIO which only removes their voice spoken on the radio? Removing their radio doesn't work, and removing mine works but renders sideChat messages silent. No problem in my own mission, but will be problem in others.

Updated by Evil_Echo over 5 years ago

The itemRadio is really for your tactical communications at squad/platoon level. And that is where the bulk of your AI chatter originates from as well. Pack radios are used for communications with battalion-level or higher assets. It's a larger/heavier item because it has encryption hardware and much more reach than the normal radio. Apples vs oranges.

Updated by rocko over 5 years ago

  • Tracker changed from Bug to Feature

Updated by rocko over 5 years ago

  • Category set to Complex
  • Target version set to Planned (Needs Contributors)

Updated by rocko over 5 years ago

  • Status changed from New to Rejected
  • Target version deleted (Planned (Needs Contributors))

Will not work by simple config.

Also available in: Atom PDF