Bug #8275

Using #include from mission editor with relative path

Added by alef over 5 years ago. Updated almost 3 years ago.

Status:Assigned Start date:01/19/2010
Priority:Low Due date:
Assignee:- % Done:

90%

Category:Game Crash
Target version:Upcoming version
Affected ArmA II version:1.62.95248 First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using:OA only BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

#include crashes ArmA2 using relative paths.

One dump has been sent through WER. Another is attached here inside the mission repro.

Process Monitor details on this event:

Date & Time:    19/01/10 1.41.42
Event Class:    File System
Operation:    CreateFile
Result:    NAME INVALID
Path:    I:\arma2_profiles\Users\CIT\missions\preprocessor.utes\directory\..\directory_2\file_2.sqf
TID:    2352
Duration:    0.0000068
Desired Access:    Generic Read
Disposition:    Open
Options:    No Buffering, Non-Directory File
Attributes:    N
ShareMode:    Read
AllocationSize:    n/a

Repro

  • Open the mission with single-player editor
  • Click "preview"

Observed

  • ArmA II crashes with
  • The path is vaild if used to open file_2.sqf through cmd.exe

crash-dialog.png (5.9 kB) alef, 01/19/2010 00:51

preprocessor.Desert_E.7z (766 Bytes) kju, 07/15/2010 05:17


Related issues

related to ARMA2 Community Issue Tracker - Feature #5121: Allow more flexibility in #include paths Assigned 10/12/2009
related to Community Base Addons - Feature #8344: Functions available as mission scripts (no addon) Closed 01/20/2010
related to ARMA2 Community Issue Tracker - Bug #14303: [73658] Loading config/description with syntax error term... Assigned 10/10/2010 12/01/2010

History

Updated by alef over 5 years ago

Updated by alef over 5 years ago

  • Operating system set to WinXP 32 bit

Updated by Fireball over 5 years ago

  • Assignee set to Dwarden

Updated by Dwarden about 5 years ago

  • Target version set to Upcoming version

Updated by Dwarden about 5 years ago

  • Status changed from Assigned to Expired
  • I am using some Mods set to No
  • Reproducible for you set to No

expiring, if still happens please provide 1.07 crashdumps

Updated by Dwarden about 5 years ago

  • Status changed from Expired to In progress
  • Priority changed from Normal to Low
  • % Done changed from 0 to 90

Updated by Dwarden about 5 years ago

anyone still getting this one?

Updated by kju about 5 years ago

yes. Use new OA demo mission.

ErrorMessage: Include file e:\games\arma2\users\test\missions\preprocessor.Desert_E\directory\..\directory_2\file_2.sqf not found.

The error level needs to be changed to warning instead of application shutdown.

Updated by kju almost 5 years ago

  • Due date deleted (08/01/2010)

Updated by Dwarden almost 5 years ago

  • Status changed from In progress to Resolved

damn, wrong CIT id ... mishap

Updated by Dwarden almost 5 years ago

  • Status changed from Resolved to In progress

Updated by kju over 4 years ago

  • Due date set to 02/01/2011
  • Affected ArmA II version changed from 1.05.62017 to 1.55.75445
  • I am using set to OA only
  • Reproducible for you changed from No to Yes

Still true.

ErrorMessage: Include file c:\arma2\Users\test\missions\preprocessor.Desert_E\directory\..\directory_2\file_2.sqf not found.

Updated by kju over 4 years ago

  • Due date changed from 02/01/2011 to 05/01/2011
  • Status changed from In progress to Assigned
  • Operating system deleted (WinXP 32 bit)
  • Affected ArmA II version changed from 1.55.75445 to 1.58 BETA
  • CPU deleted (n/a)
  • Audio card deleted (Please specify!)
  • Size of OS swap file deleted (Please specify!)

Updated by idl0r almost 4 years ago

Should be also related to #5121, they should be merged probably.

Updated by Fireball almost 4 years ago

Let's not merge bugs with feature tickets.

Updated by ceeeb over 3 years ago

Is it considered normal/acceptable that ArmA crashes when asked to preprocess a non-existent #include file (due to typo or path confusion)?
This seems a little unforgiving to me, but I'm not a programmer/coder and have no experience with C etc.

Updated by kju over 3 years ago

  • Affected ArmA II version changed from 1.58 BETA to 1.61 Beta

Updated by kju about 3 years ago

  • Affected ArmA II version changed from 1.61 Beta to 1.62.95248

Updated by kju almost 3 years ago

  • File deleted (preprocessor.utes.zip)

Updated by kju almost 3 years ago

  • Due date deleted (05/01/2011)
  • Assignee deleted (admin)
  • Private changed from Yes to No

Also available in: Atom PDF