Bug #8168

Rangefinder Broken

Added by ShadowDBOB about 5 years ago. Updated about 5 years ago.

Status:Closed Start date:01/15/2010
Priority:Normal Due date:
Assignee:tcp % Done:

0%

Category:-
Target version:1.0.0
Component: Affected Version:
Close Reason:

Description

Since the latest update, i cant seem to use the SOFLAM or the Vector. Using the fire key the laser fires as it did as default. But none of the rangefinder features are enabled. I cannot use "R" to load the battery in, therefor nothig works. I noticed the battery names have been changed, could this have something to do with it?

History

Updated by Deliverator about 5 years ago

I've been having the same problem. Last night I got the AN/PEQ SOFLAM to work properly by using the R key to reload the battery and the light came on and it worked great. Then this morning I got on and picked up a SOFLAM and tried to load a battery and the name was still red, so I grabbed another battery, same problem. After loading a second battery the first battery came out as a "battery pack" instead of the original "laser marker" battery. I also tried the ctrl+shift+alt+r and it gave me the "reloading battery" message and nothing happened. I'm very confused, why is it only working sometimes but not others?

Updated by ShadowDBOB about 5 years ago

Let me just clarify, previous to update 218, it was all working fine. It has just been since todays update.

Updated by columdrum about 5 years ago

Its strange it works perfectly for me. ┬┐Are you sure that you have the new "ArmA 2\userconfig\ACE\ace_keys.hpp"?

class ace_sys_rangefinder {
class Toggle_Power {
key = 19; // R, Toggle Power to Rangefinding Devices
shift = 0;
ctrl = 0;
alt = 0;
};
class Cycle_Mils {
key = 19; // R, Cycle between Mils for Azimuth (and Elevation)
shift = 0;
ctrl = 0;
alt = 1;
};
class Preload_Battery {
key = 19; // R, Load battery or replace existing battery, also Dispose of a Burnt Out device
shift = 1;
ctrl = 1;
alt = 1;
always=1; // Perform function even if device is not selected
};
};

Updated by tcp about 5 years ago

  • Status changed from New to Feedback
  • Assignee set to tcp

Please do a proper bug report if you expect answers: Bugz

Updated by Minoza about 5 years ago

I have different problem with Vector.

SUMMARY: When firing laser beam it goes to non-optic for a split of a sec.

EXPECTED RESULT: When firing laser, stays in optic mode.

To reproduce:

1. Equip Vector with a battery
2. Turn vector ON
3. Fire laser beam

Notice a brief switch from optics mode to first person non-optic (you can see the back of the laser)

Updated by tcp about 5 years ago

Thanks for the report, Minoza. Not really a bug, but a quirk in the behavior, unavoidable for now until action "useweapon" can be sorted.

Still waiting for a bug report on rangefinder broken...

Updated by KingHomer about 5 years ago

  • Target version set to 1.0.0

Updated by tcp about 5 years ago

  • Status changed from Feedback to Closed

Rangefinder has been reported to work, but will re-open if you provide a proper bug report.

Also available in: Atom PDF