Bug #809

AI squad leaders disappear on occasion, breaking AI team

Added by Doomguy almost 6 years ago. Updated almost 6 years ago.

Status:Closed Start date:04/03/2009
Priority:High Due date:
Assignee:Doomguy % Done:

100%

Category:-
Target version:1.1.7c ACE

Description

Theories:

  • the Common_unitKilled script deletes squad leaders that have died previously and respawned. Somehow their object is still the same after the respawn.
  • The PlaceHolder script still does something.
  • The DoFollow command in Advanced_UpdateSquad.sqs causes the teams to break if squad members are told to follow someone other than the leader (this is possible if another unit temporarily becomes the squad leader)

History

Updated by Doomguy almost 6 years ago

The problem is probably being caused by leaders going unconscious. If that happens, another team member is selected to be the leader. The AI script needs to be aware that this has happened, or else the team may be broken. Killing the (unconscious) squad leader and waiting for respawn should fix it, provided that the squad leader unit is again the leader of the AI team after he has respawned.

Updated by Doomguy almost 6 years ago

  • % Done changed from 0 to 100

Updated by Doomguy almost 6 years ago

  • Status changed from Assigned to Resolved

Updated by Doomguy almost 6 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF