Task #7971

Make AAS running again on ArmA2.ru/Integrate ArmA2ru ruleset

Added by kju over 5 years ago. Updated about 5 years ago.

Status:Closed Start date:01/11/2010
Priority:High Due date:
Assignee:BCA_Cat_Toaster % Done:

100%

Category:-
Target version:- Estimated time:50.00 hours

Description

First basic version.

Use compareIt to merge changes easily.

arma2.ru.7z (20.8 kB) kju, 01/11/2010 16:45

History

Updated by BCA_Cat_Toaster over 5 years ago

  • Status changed from Assigned to Feedback
  • Priority changed from Immediate to Normal
  • % Done changed from 0 to 100

They should be aware of what is going to happen if they set up healing speed so slow: The Medic might kill and revive his patient instead of healing him for a minute or two. If a revive just takes a second, why healing should take ages? If this is the case teamkill+revive is the better choice, this is already "best practice" for us at BCA if we encounter so slow healing speeds, of course we only do that with ourselves, don´t worry. ;-)

Done

Updated by BCA_Cat_Toaster over 5 years ago

  • Status changed from Feedback to In progress

well and messed up, thought this package was completely ready... well, i´ll fix it tomorrow.

Updated by BCA_Cat_Toaster over 5 years ago

  • % Done changed from 100 to 0

Updated by BCA_Cat_Toaster over 5 years ago

  • Status changed from In progress to Feedback
  • % Done changed from 0 to 100

No, it´s not messed up. Man what are u doing? If confusion was your goal you reached that. The stuff was totally ready for commit, right? Why don´t you commit yourself?

Updated by BCA_Cat_Toaster over 5 years ago

Class Description for Engineers is now too long kju, they don´t fit on the Class-Menu because some need two lines.

Updated by kju over 5 years ago

I don't have SVN set up. I only get it via git svn and commit to the git repos at DH. ;)

Updated by kju over 5 years ago

what about

AT Light/Mid/Heavy
or
Anti Tank L/M/H

Updated by kju over 5 years ago

Thanks toaster!

Here is the latest ruleset:
http://pastebin.jonasscholz.de/455

Updated by BCA_Cat_Toaster over 5 years ago

Done in r408.

Updated by kju over 5 years ago

Can you build the latest version with the ArmA2ru ruleset as default please.
The current version should be well playable and it would be good to get feedback,
as well as a vastly improved version out to be played by the public AAS community.

Thank you

Updated by BCA_Cat_Toaster over 5 years ago

Sure but tonight, I´m at work at the moment. Are you sure this is a good idea, you have a better view of the code and the latest changes? I had not time testing anything on a server since r335, which seems good. I´m not sure about later versions and I would like to test them first before I would advice someone else to use it, especially when it comes to a such large and well running public environment like ArmA2.ru. On the other hand we are going to get loads of Feedback if something is wrong, of course :-)

Just want to mention that so everyone is aware.

Please let me test the latest build tonight in LAN at least, just to be sure we don´t miss anything that is obvious, missing semicolons and stuff like that, I´ll post the Download-Link later on here. Is that OK?

Updated by kju over 5 years ago

Of course. Thanks mate!

We will advise ArmA2.ru admins to use the new version carefully,
and monitor it closely. In worst case they can always roll back.

Thankfully the arma2.ru admins are very active on the server.

Updated by BCA_Cat_Toaster over 5 years ago

kju, I put the most recent release (r413) on our server for testing and my ArmA2Client crashed to Desktop within 120s which is not what normally happens. Perhaps it´s completely out of context but I really advice you and everyone else to not use this until it was properly tested with a handful of players running thru a few different maps. We´ll try to do some testing tonight. At least on our server players are aware what´s happening. We should not make anyone mad with this Alpha-Stuff who is not aware. Delgado and me are not going to add/merge more stuff until we know that we are safe again.

If you still like to give it a go, here it is:
REMOVED Link

Sorry, I just experienced further issues: Can´t enter vehicles, can´t capture an objective...it´s just not safe yet. Perhaps really some "Copy&Paste" missing semicolon-syntax-whatever stuff again. This not even ready for Alpha-Testing. I need to review all the latest changes carefully to sort out which change caused it and why as I do it normally. Please be patient, quality needs its time and a totally bugged release helps no one. Thanks!

Updated by kju over 5 years ago

Can you please post rpt logs. That probably helps getting to the source.

Thanks for testing it!

Updated by BCA_Cat_Toaster over 5 years ago

We fixed it but it´s not much tested anyway -> http://www.basecamp-allstars.de/ArmA2/aas-ARMA2RU-alpha-r415.7z

Updated by kju over 5 years ago

Unfortunately the latest AAS seems not functional on a2ru server / for some Russian players.
I spent (way too) much time trying to resolve this. I have no further interest in this.

Updated by BCA_Cat_Toaster over 5 years ago

I read that whole thread on arma2.ru, I´m interested but I´ve no idea either. Don´t even know if those with problems ever tried another server to see what happens there, if certain players experience it always or just at times. Thanks for all your hard work and time helping them kju!

Updated by kju over 5 years ago

From what I can tell, a few of them did play on the BCA server without problems.
However it is not easy to get them to talk or to make precise statements.

Unfortunately the admins, apart from a few notable exceptions, have not shown real interest to resolve this.
It seems that most people from the a2ru community have little to very little computer understanding. They are just players.

Updated by BCA_Cat_Toaster over 5 years ago

  • Status changed from Feedback to Closed

Understood. Thanks again for all your work. Either it must be a language or specific server related problem because we got no single similar reports from other Communities like AGW, Armacalypse (former BMF) or ourselves. However r304 works still fine even on ArmA2.ru. So here is one last thing I can offer:

http://www.basecamp-allstars.de/ArmA2/ArmA2RuTest.7z

This File contains three complete AAS-Packages based on r327, r331 and r335 (BCA-Rules for now, closest to what they want). We know they have issues with r419, so they should try which one of these previous versions might work for them. That could really help us spotting which change is related with the problem and in the worst case with no feedback, they can at least enjoy a version with less bugs (hopefully), might be possible that none of these works but that would be a very good piece of information also. They have still the "key-stuck-issue" in that r304 version they use and it seems player-numbers dropped significantly also...

As you´re registered on ArmA2.ru, it would be nice if you can bring this offer to their attention as your very last action on this kju. Thanks in advance!

Updated by BCA_Cat_Toaster over 5 years ago

  • Status changed from Closed to Feedback

Updated by BCA_Cat_Toaster over 5 years ago

  • Target version changed from Beta 09 V0.5 to release 1.0

Updated by BCA_Cat_Toaster over 5 years ago

  • Subject changed from Integrate ArmA2ru ruleset to Make AAS running again on ArmA2.ru/Integrate ArmA2ru ruleset

So I continue speaking to myself. ;-) From what I´ve heard today from kju, the issue is still present in all three revisions I provided for testing. Further it´s NOT present if just another Ruleset than BCA is chosen. Therefore it must have something to do with a variable that the specific Ruleset changes and others not I guess while it works still fine in our own environment. Whatever causes this, it must have been introduced between r303 and r327 so we´re finally getting closer. Here is another Package, featuring r305, r320 and r322 releases. I´m sure one of these introduces the problem, so please try them and report back -> http://www.basecamp-allstars.de/ArmA2/ArmA2RuTest2.7z

Updated by BCA_Cat_Toaster over 5 years ago

  • Priority changed from Normal to High

Updated by BLRGVOZD over 5 years ago

hello mates :)

tonight we've been testing r419 again
there's a few interesting facts discovered:

1. same version behaviour is different on two different PCs.

2. I had a smooth and correct gameplay with any ruleset chosen, while LEGYICH can only play with "public" ruleset but "arma2ru" ruleset makes a great difference in gameplay for him causing desync and wierd game behaviour. what exactly makes this difference is still unknown for me

3. we've been trying to make LEGYICHs OS settings same as mine, but nothing helps. we both have almost same OS main settings except one thing - his user account name is Cyrillic but mine not. I believe that this could cause a problem because arma folder where some game related files (including all MP missions cache) stored is located in windows user profile folder. This kind of problem present in IL-2 - in case of game folder path contains cyrillic symbols the player profile could not be changed. also it explains why non-russian players do not expirience this problem - none of them have cyrillic user accounts i presume.

so...
one thing remains to be checked - game behaviour on same PC with cyrillic user account name and non-cyrillic. if I'll have problem with cyrillic user account name then something non-compatible with cyrillic should be found in mission scripts. tonight i'm gonna check it on my PC. report will follow soon

Updated by BCA_Cat_Toaster over 5 years ago

Hi BLRGVOZD and thanks for joining and telling us. You´re providing vital information and I´m looking forward to hear more results from your tests. However, if you can play r303 BCA without issues, we need to know why later versions cause trouble. The Arma2-Ruleset is based on the BCA-Ruleset, the problem isn´t the ruleset itself, but one of variables therein causes the problem because of another AAS-code-change. I´m sure it´s language related, but if you prove that we´ve still no idea which code-change caused that incompatibility. So please try these another three missions I provied as well, that will point us directly to the code-change that caused the troube. If we know that, it might be possible to fix it in AAS code itself.

Updated by BLRGVOZD over 5 years ago

as i said i never had any problems playing any version of AAS
now i'm gonna create "specific environment" (Windows Cyrillic user account name) in order to check if something changes in game behaviour.

Updated by BCA_Cat_Toaster over 5 years ago

Understood, sounds good. I would have already done it but my cyrillic skills are really bad (non-existent). ;-) With your test environment or just LEGYICH trying the other missions/revisions in LAN already we´ll hopefully find out which change in AAS-Code introduced the "cyrillic OS/User incompatibility" soon.

Updated by BLRGVOZD over 5 years ago

so i've launched r335 with both Cyrillic OS user account name and Arma 2 player profile name...nothing new so far.
i still experiencing smooth and proper gameplay.
in the same time LEGYICH have his Arma 2 fully reinstalled, but still weird behaving in r335.

i believe he should try all previous releases one by one until proper behaving one encountered.

P.S. i wonder if someone else belives that UAZ exploding after 3 VSS bullet hits is quite weird? nevertheless in r335 it happens :)

Updated by kju over 5 years ago

you mean 305 on the test server?

PS: VSS is strong bullet type of all infantry guns.

Updated by BLRGVOZD over 5 years ago

nope. it was only one mission available on test server tonight - Flight Control r335.
at least r335 was displayed at the bottom of in-game screen

Updated by kju over 5 years ago

Weird!

Someone has move r305 to the subfolder "1" and added three other (AAS) missions.
I have put r305 back for testing.

Updated by BLRGVOZD over 5 years ago

this extra missions were added by me (r419 just to test), but i didn't move anything to subfolder

Updated by kju over 5 years ago

ok strange. anyway now r305 available :)

Updated by BCA_Cat_Toaster over 5 years ago

  • Status changed from Feedback to In progress
  • % Done changed from 100 to 80
  • Estimated time set to 25.00

We made a lot of tests today, can´t wait for the last result. We should be very close now.

Updated by BCA_Cat_Toaster over 5 years ago

  • % Done changed from 80 to 90

OK, it turned out that our "r498 with reverted changes from r305-test" worked perfectly fine today. So r305 already introduced the problem which was the longest possible way coming down from the other end at r419. Next time we´ll start testing from both ends for sure. ;-)

This implementation of this feature is the problem:

  • first implementation of visible-to-all class limits
  • 'report' console command ugpraded to support full breakdown of classes on both teams

That feature is definetely not worth the trouble it caused in my opinion and as I don´t know how to fix it, I´ll remove it completely for now. Maybe it´s because ArmA2.ru and BCA use more Classes (four instead of one engineer) but even that seems only a problem with specific russian Setups.

However, thanks everyone for all the testing and patience! This was the most time-consuming issue (that I´m aware of) we had to track down so far, but we finally made it!

Updated by BCA_Cat_Toaster over 5 years ago

  • Status changed from In progress to Resolved
  • % Done changed from 90 to 100

r502 provided to ArmA2.Ru for Exclusive large scale "Final-Preview".

Updated by kju over 5 years ago

  • Status changed from Resolved to In progress

Unfortunately did not solve all our problems :(

Updated by BCA_Cat_Toaster over 5 years ago

neverending story it seems...should I revert the changes from r502 again?

Updated by BLRGVOZD over 5 years ago

just played r502...
seems good for me except two things:
1. AI bots - it's just real splinter in the ass. despite they are stupid "cheaters" (see you thru vegetations), but they don't have name tags and when you see sniper in camo you don't know whether to open fire or not.
2. some of players (LEGYICH) reported connection problems on both public and arma2ru rulesets.

Updated by BCA_Cat_Toaster over 5 years ago

1. Honestly I´m very happy with the current AI-Integration (just played half an hour "alone"), the best we ever had and it´s still Arma, what do you expect? You can increase/decrease the AI-Abilities in your arma2.profile on your Server as described in #5346. It´s not easy to give them Tags (would like that also), but they are bots, they don´t complain getting teamkilled. I start learning to play without the Tags and watch at the uniforms and weapons they carry. There are also some switches in the Parameter-Setup you can play around with to reduce their numbers. In that version you had for testing you had 24 AI Players on each side, with 50 human players on a server I die more often I would say. Killing Snipers is never wrong, no matter on which team they are. ;-)

2. Can´t confirm that yet. We´ll look into that. I provided a version without AI Enabled, please use that meanwhile, lets avoid mixing up just more and more things just making it more complex. AI uses a lot of CPU-Ressources, lets avoid that for the moment.

Lets stay on topic. If you play current r502 with "Public-Rules" everything is fine for everyone, not just for you, no desync/Kick from the server, right?

Updated by BLRGVOZD over 5 years ago

Yesterday, we've been playing last 2-3 maps without AI support (turned off in start menu) both Public and arma2ru rulesets. As far as i know LEGYICH expirienced connection problems all the way. He managed to play a while (for some undiscovered reason everything just went as it should for him) but mostly i saw him trying to get in and kicked out.
Everything else went fine for me and other players - no reports of sudden disconnect or weird game behaviour have been received

Updated by BCA_Cat_Toaster over 5 years ago

Thank you very much for you report! So am I right, that we´re having just one guy now (LEGYICH) that has problems that he can´t play at all most of the time? For all others the latest fix works fine and you´re not having the problems that you had before with r419?

Or is that fix (r502) ineffective at all and similar to r419?

Updated by BLRGVOZD over 5 years ago

it's hard for me to confirm if any fix makes game better because i never had any problems.
recently i've hard about one game bug - enemy AI bots continue respawning at the point even when 10% to capture remains

Updated by BCA_Cat_Toaster over 5 years ago

I hear you. The AI-Issue you´re talking about is confirmed and has been fixed in r504 already, it´s still work in progress and a lot of tweaking and testing going on to optimize AI behaviour. We gave you the latest Alpha for testing, therefore all Feedback is welcome for the upcoming final release from ArmA2.ru! For any suggestions/Feedback on the AI-Impementation please post here -> #5346 so we can keep this Task here clean and focus on your "special issue".

kju has collected and analyzed lots data from your tests and started a new ticket in the "A2 Community Issue Tracker" as you can see here -> #9719 . Hopefully a BI-Developer can look into it and help us. There must be a reason why only certain russian players are affected and it seems strange that this is caused by some AAS-Code that shouldn´t be "language-dependent".

Is it possible for you to start a poll on your ArmA.ru-Forum or something like that, so we can get an idea how many players have the problem (and just that!) described in #9719 with r502?

Updated by BCA_Cat_Toaster over 5 years ago

  • Target version changed from release 1.0 to thefuture
  • Estimated time changed from 25.00 to 50.00

Updated by AGW-Grimes about 5 years ago

We changed all the rulesets, right? Do we need this ticket?

Updated by BCA_Cat_Toaster about 5 years ago

well, this ticket has nothing to do with Rulesets anymore as it turned into a general "ArmA2.ru-Issue"-Topic later and got renamed therefore into "Make AAS running again on ArmA2.ru". This Issue is still not fixed

Updated by kju about 5 years ago

i think we can close this. it seems to be a general server-client network connection quality issue.

Updated by BLRGVOZD about 5 years ago

hello again, mates.
i'm sorry for being absent for a long time (real-life issues makes me very busy)
but let's go straitght to the point....
last release of AAS runs quite smooth and nice, but lately i've encountered two little bugs:

1st. (also was observed by cat_toaster): map Forsaken Factory, blue team have Echo and red team have Foxtrot, suddenly green DELTA point emerges and disappears few times (just like as at the start of the mission). nothing annoying but i think you should know...

2nd. today i've played couple of maps. i've noticed that no any messages about point capture were seen. and occasionly i left "copy" of my white arrow on the minimap.

i have no idea if any other playes experienced such bug same time i did.

anyway, thank you mates for your great work. keep it coming.

upd: i still have no messages when point captured :(

Updated by BCA_Cat_Toaster about 5 years ago

  • Status changed from In progress to Closed

BLRGVOZD

Great to hear from you. So I´ll close this ticket finally.

1st: I can´t remember. Did it happen just once or every time you play that Mission? Sound´s a bit like a "golden oldie bug" but might be mission-/layout-related as well. Will investigate, please further discussion about this in the new ticket -> #10926

2nd: That´s the one I´ve observed (and caused I guess). Looking into that here -> #10925

3rd: The "magic ghost mirror player-arrow" happens at times on the Mini-map, also confirmed. That´s an older problem already.

Updated by AGW-Grimes about 5 years ago

  • Target version deleted (thefuture)

Also available in: Atom PDF