Bug #7863

Unlimited M136

Added by exall about 5 years ago. Updated about 5 years ago.

Status:Rejected Start date:01/08/2010
Priority:Normal Due date:
Assignee:zGuba % Done:

0%

Category:Script
Target version:-
Component:sys_disposal Affected Version:
Close Reason:

Description

I tried to use searching here but didn't found the thing. So sorry if you know about that already.
I made an mp mission and when i was playing it with my friend by LAN i discovered a bug with m136 (no matter from ace box or from standard at soldier body). It has unlimited ammo. So you fire it, the indicator of ammo gives you 0 but you can hit "R" and it has 1 again.
Furthermore, if you go prone you just don't need to hit R button - it's reloading automaticlly. So the player becomes an artillery system with that firing tons of rockets allover the map.
I believed that there's a conflict with other mods but i tried the same with only CBA and ACE2 and nothing changed. Ver of ACE2 - beta 2 - was downloaded as is not by sixupdater.
Sorry for my english.

History

Updated by zGuba about 5 years ago

Your XEH is broken for the unit You're using in Your mission. Check Your custom addons.

Updated by rocko about 5 years ago

  • Target version changed from 0.9 to 395

Updated by Cossack8559 about 5 years ago

Is this the m136 at4? i don't know much about weapon names but i have the same problem with at4... i can reload unlimited times and when you prone you can fire rapidly without reload!

Updated by zGuba about 5 years ago

  • Category changed from Config to Script
  • Component set to sys_disposal

Could You please give me repro mission/steps? I cannot reproduce it.

Updated by Cossack8559 about 5 years ago

@zGuba

The squad needs to be in combat mode for it to happen...

Go into editor on utes and place down 1 Russian infantry group on one side of the airfield and 1 usmc AT group on the opposite side(make sure both groups can see each other when you press preview and give the Russian group a waypoint to move to the A.T group) put your self as the m136 rifleman in the A.T group... when the commander gives his first order to engage notice how you will be able to fire unlimited ammo with the AT 4..

placing it down with no enemy or without a.i commander in charge of player seems to work normally very strange...

Hope you understand what i just wrote :)

Updated by th3flyboy about 5 years ago

There was a similar situation discussed in skype shortly before release. It turns out, the person in question was using the ACE Test soldier, which was breaking it. I'm not sure if that soldier is still in, but if so, dont use him.

Updated by rocko about 5 years ago

  • Status changed from New to Assigned
  • Assignee set to zGuba
  • Priority changed from Normal to High

Updated by zGuba about 5 years ago

  • Status changed from Assigned to Feedback

Ver of ACE2 - beta 2 - was downloaded as is not by sixupdater

Please try updating ACE2 with six-updater. Having mod up to date is essential for succesful issue tracking.

Cannot reproduce with latest builds no matter how hard I try.

Updated by zGuba about 5 years ago

  • Status changed from Feedback to Rejected

Updated by Cossack8559 about 5 years ago

zGuba wrote:

Ver of ACE2 - beta 2 - was downloaded as is not by sixupdater

Please try updating ACE2 with six-updater. Having mod up to date is essential for succesful issue tracking.

Cannot reproduce with latest builds no matter how hard I try.

I am using the updater and i have the latests version !

Updated by Rommel about 5 years ago

  • Priority changed from High to Normal

I have only seen this while testing with XEH incompatible ad dons. Unable to reproduce in ACE/ACEX alone.

Updated by Sickboy about 5 years ago

Rommel wrote:

I have only seen this while testing with XEH incompatible ad dons. Unable to reproduce in ACE/ACEX alone.

Maybe because you're missing details :D
Cossack8559 wrote:

Did you place it down exactly how i did? i am not able to fire unlimited ammo with just a m136 rifleman... for some reason it only happens when i am in a A.I controlled squad and the squad has to be in combat mode as i said...

Updated by rocko about 5 years ago

  • Target version deleted (395)

Also available in: Atom PDF