Feature #7781

The need for support.

Added by Enforcer almost 6 years ago. Updated over 5 years ago.

Status:Closed Start date:01/05/2010
Priority:Normal Due date:
Assignee:Benny % Done:


Target version:Warfare BE 2.054
Affected Version: I am using some Mods:
Affected ArmA II version:Please select... Reproducible for you:


Since the fuel comsumption of vehicles is nile in ArmA 2 due to the tiny distances on the map, i think it would be good to add
- a fuel consumption multiplier
- longer repair times
- modify instant repair to somewhat like minutes depending on the unit and damage level ( f.e. 1min. per 10% of damage to a MBT )
- same to refuelling and rearm. An acquaintance was part of a Gepard ( german AA tank ) crew, they needed the whole crew to load an ammo belt into the tank which took them a couple of minutes. And that wasn't even a full reload. And 500L of fuel isn't filled in a matter of seconds either.
- remove support/repair in town centers
- modify rights to certain classes such as enginieers ( will be explained a bit lower )
to make supply vehicles a more valuable asset in warfare. Almost nobody uses them because they can have instant support in town centers.
Also the enginieers should not have the ability to fully repair a heavily damaged vehicle and take longer to do so. It might be useful but this should not be Battlefield 2 style where you can fix everything with a wrench and some superglue.

This might add a touch of real combat given that this is "a military simulation" as many cry out when ArmA 2 is beeing called a shooter. I would call it a military game instead ;)


Updated by fambaa over 5 years ago

I understand your point. The thing is that you hardly get any chance to refuel/repair/rearm other than in town centers.
The depots already simulate a kind of battlefield support.

As you said, distances are tiny. Thats why you cant just hide support vehicles behind the lines.
Lengething the times is a good idea. That would actually stop a camping tank at depots you cannot destroy, because hes repairing the whole time.

Reducing support only to engineer classes I find is a bad idea. Its good how is it right now. That everyone can use a repair truck. Pioneers only would fit mre into a non-AI Warfare Version with 100 players and no AIs on either side.

Updated by Crusader over 5 years ago

I agree with fambaa.

I think to keep things from bogging down too much, increasing the rearm, repair, refuel times at the depots is a good idea, but I would make it like 30-60 sec (to circumvent the invincible tank problem) but not longer.

So IMO yes to the point above and no to all others.

(As I partially agree, I will refrain from voting in either direction)

Updated by Zith over 5 years ago

Adjusting the time needed for support actions is a sound idea. Here's a suggestion on taking a bit further:

Factory & Supply Depot: Fully repair any damage to any vehicle.
(new, built by deploying repair truck) FARP: Repair any vehicle to combat level as well as refuel/rearm.
Town center & Engineer: Repair immobilising damage to armor(tracks, engine) and fully repair softskins.

Updated by Enforcer over 5 years ago

Almost forgot anoter reason why repair and rearm times should be increased.

In the BIS forum some player were talking about a cheating Tunguska player. I rather think he used the feature "instant" repair and rearm so it took a couple of missiles to destroy his tank. Giving time to repair and repairing in steps should remove such problems like invincible and fully rearmed tanks, giving assaulting players a chance. Given the size of the battlefield i think 30-60 seconds is not enough compared to taking down an enemy in a blink of an eye. In RL one takes the opportunity to retreat if damaged and return after repairs.

Updated by Benny over 5 years ago

  • Status changed from New to Closed
  • Assignee set to Benny
  • Target version set to Warfare BE 2.054
  • % Done changed from 0 to 100

Rearm/repair/heal/refuel shall have a delay in new version.

Also available in: Atom PDF