Support #7645

Less AI

Added by Enforcer over 5 years ago. Updated over 5 years ago.

Status:Closed Start date:01/02/2010
Priority:Low Due date:
Assignee:Benny % Done:

0%

Category:-
Target version:Warfare BE 2.054
Affected Version: I am using some Mods:
Affected ArmA II version:Please select... Reproducible for you:

Description

I don't know if other players have the same problem or maybe they just don't bother.

When AI has it's first contact with resistance units my PC feezes for a split second then i notice a slight performance drop. Later in the game somehow the performance drop disappears...

I also noticed quite a lot of enemy units running/driving around in the towns.
How about
- reducing the amount of defending units or
- put a trigger which spawns units when west/east players get near the location ( if not already implemented ). I didn't quite figure out how Benny triggered the AI.

To lessen the impact for all participants. At start 1 or 2 towns is not the problem. But when the game develops and there are lots of towns involved it uses up quite a lot of traffic and cpu power. Afaik the amount of defending AI was increased in every version. I didn't have that kind of impact until 051.

Note: My PC is strong enough to run high/very high settings w/o AI only PvP @2000m vd. There are others not so lucky hardwarewise. There also seems to be a problem with the PLA ( causing lag afaik? ) on resistance side. Just keep it in mind for future versions. One day it will be unplayable with too many AI and we can also play coop in the end.

History

Updated by Streeetz over 5 years ago

Theres already a trigger, which spawns AI , if a player reaches the city!

Updated by Enforcer over 5 years ago

Streeetz wrote:

Theres already a trigger, which spawns AI , if a player reaches the city!

At least i know now what causes the momentary freeze. xD

Updated by fambaa over 5 years ago

I noticed too, that PLA seems to use more resources on clientside. This may very well be a model issue due to the custom tank models.
Another fact is that you should avoid the heavier occupation settings. Those on hard and insane. Last time I witnessed such a game Berezino had 14 tanks alone. That maybe adds up to a total of 150-200 ais (Tank crews+infantry squads). Lets say both sides trigger 2 towns, then were already at around 400-500 AIs at the games start. A bit much for most of the servers. Then again such a setting with PLA makes my framerate go down too, and various other people only get around 15 fps anywhere on the map when PLA is activated.

I think for the defenders, Benny uses some kind of spawnscript. The towns spawn and despawn after rules. As a thumbs rule I think they spawn when you enter a radius of 500-600m from the towns depot. And AIs despawn after some minues when nobody is in the zone. This heavily improves servers performance. Warfare would never work if all units of towns would be present the whole time.

Updated by Streeetz over 5 years ago

Right -

ArmA 2 is made for the future. We will have alot of fun in 3-4 years ! ;)

Updated by Benny over 5 years ago

  • Status changed from New to Assigned
  • Assignee set to Benny
  • Target version set to Warfare BE 2.054

as fambaa stated, there is one FSM that run per town, it check via nearEntities if something hostile is in the town's range or not, if there is nothing after 5-7 minutes, the resistance/occupation is removed.

You can also set the amount of AI to be spawned in the parameter (very bottom), but once more, it has to be rewritten.

Updated by Benny over 5 years ago

  • Status changed from Assigned to Closed

Also available in: Atom PDF