Bug #7578

Aircraft AI should not use AA missiles for ground attacks

Added by _William over 5 years ago. Updated 5 months ago.

Status:Feedback Start date:12/31/2009
Priority:Normal Due date:
Assignee:hladas % Done:

0%

Category:AI Issues
Target version:1.63 BETA
Affected ArmA II version:1.59.79384 First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

F35B AI aircraft uses anti-air missiles for ground attack purposes (as first/preferred means).
Su34 AI aircraft uses anti-air missiles for long-range ground attack purposes (even when having available ATGMs).

Observed
In 80% of the Seek-and-Destroy missions against ground targets, the AI F35B immediately engages ground targets with its AIM-9 AA missiles.
AI Su34 uses AA missiles for long-range ground attacks before running out of ATGMs.
See screen shots.

Expected
Aircraft hold on to AA missiles for self-protection (against hostile aircraft).
Aircraft solely use ATGMS, bombs and cannons against ground targets.

Reproduction steps
F35
- run attached f35_sidewinder_groundattack.utes mission (F35B with SAD waypoint against artillery at Utes airstrip, observed as civilian from control tower roof)
- use Troopmon2 to observe F35 fire AIM-9s, or stay on the airstrip watching for incoming missiles (any long-range attack from the F35B is by AIM-9)

Su34
- run attached su34_groundattack.utes mission
- use Troopmon2 to observe Su34. At some time, the Su34 switches to R73 to engage ground targets.

f35b_sidewinder_ground_attack.jpg (85.6 kB) _William, 12/31/2009 08:54

f35_sidewinder_groundattack.utes.zip (1007 Bytes) _William, 12/31/2009 08:54

su34_r73_ground_attack.jpg (130 kB) _William, 12/31/2009 08:54

su34_groundattack.utes.zip (1.2 kB) _William, 12/31/2009 08:54

7578.Desert_E.7z (1.8 kB) kju, 10/04/2011 13:38


Related issues

related to ARMA2 Community Issue Tracker - Feature #11086: Make it possible to have a weapon able to lock air units ... Assigned 06/08/2010

History

Updated by zGuba over 5 years ago

  • Subject changed from Aircraft AI using AIM-9/AA-11 anti-air missiles for ground attacks to Aircraft AI not using AAMs for ground attacks
  • Status changed from New to Assigned
  • Operating system deleted (Win7 64 bit)
  • Graphics card deleted (GeForce 260)
  • Graphics card driver version deleted (195.62)
  • Affected ArmA II version deleted (1.05.62017)
  • Maxmem parameter deleted (Not set)
  • Difficulty deleted (Not set)

It's a bit more complicated. I'd call it feature request due to game mechanics.

Updated by zGuba over 5 years ago

  • Tracker changed from Bug to Feature

Updated by Fireball over 5 years ago

  • Subject changed from Aircraft AI not using AAMs for ground attacks to Aircraft AI should not use AA missiles for ground attacks

Updated by Myke about 5 years ago

I wouldn't call it a feature request. The cause of this AI behaviour is surely related to the fact that the config setting "irLock = 0" doesn't work.
Ususally, on missiles (and other weapons aswell) you can set in the cfgAmmo if the weapon can lock on groundtatgets (irLock), airtargets (airLock) and/or lasertargets (laserLock). While airLock and laserLock settings have the desired effect (weapon can't lock on those targets once disabled), changing the irLock hasn't any effect.

That said, AI has a weapon that can lock on ground targets os it takes it into consideration if it will be used or not.

Fixing the irLock-bug will probably fix the AI behaviour aswell.

Updated by Suma almost 4 years ago

  • Tracker changed from Feature to Bug

I agree. This seems like a bug to me.

Updated by zGuba almost 4 years ago

  • Due date set to 11/01/2011
  • Affected ArmA II version set to 1.59.79384

Updated by Suma almost 4 years ago

  • Status changed from Assigned to Resolved

Both resolved in 83118

Note: the repro would behave even better if some vehicles config bugs were fixed, eg. MLRS correctly marked as not presenting any significant threat to aircraft. Currently the Su34 will use R73 once other missiles are depleted, as it feels "desperate" (considers MLRS threatening it significantly).

Updated by zGuba almost 4 years ago

  • Target version set to Upcoming version

Any details on the fix? I'm quite interested how to control it; for instance - will Ka-52 Vikhrs be considered as AA missiles as well then?

Updated by Suma almost 4 years ago

The fix is:

When AI is evaluates what ammo to use, it artificially increases a guided missile cost whenever:
- the missile is airLock and the target is not airborne
- or the target is soft (soldiers, cars, other unarmed targets, as defined by "kind" config entry)
Moreover, AI will never use such increased cost ammo unless desperate, where desperate is defined as it expects its own "time to live" based on known threats under 1 minute. This should prevent aircraft wasting AA missiles or even guided missiles on unarmed targets.

Updated by kju almost 4 years ago

  • Due date deleted (11/01/2011)
  • CPU deleted (E6600)
  • Mainboard chipset deleted (775)
  • Audio card deleted (Please specify!)
  • Size of OS swap file deleted (Please specify!)
  • Reproducible for you changed from No to Yes

Sounds great. Thanks a lot for these insights!

Updated by alef almost 4 years ago

  • Target version changed from Upcoming version to 1.60 BETA

Updated by Sickboy almost 4 years ago

  • Status changed from Resolved to Closed

Updated by Sickboy almost 4 years ago

  • Status changed from Closed to Feedback
  • Assignee set to kju

Updated by kju almost 4 years ago

Suma any chance to make AI also not use AA missiles onto armored tanks?
At least in the game it is mostly pointless to fire on a T72, T90, M1AX and the likes.

Even vs for example the Shilka or Tunguska the use is very questionable IMO.

Here is a new, advanced demo mission.
  1. Load in the editor
  2. Use radio to create the ground target
    1. 1 = unarmed URAL
    2. 2 = Shilka
    3. 3 = T90
  3. Use radio to create a plane with AA missiles
    1. 4 = Su34
    2. 5 = F35B

You can repeatedly create both the ground vehicle or plane.
The already existing will be replaced automatically.
Also take note by default they all have "allowDamage false".

Obs
Notice how the planes use their AA missiles onto the heavily armored ground vehicles.

Exp
At least vs non AA tanks planes (and IMO also choppers) should not use AA missiles.

Updated by mr.g-c over 3 years ago

Better in a new Ticket Kju?

Updated by Fireball over 3 years ago

mr.g-c wrote:

Better in a new Ticket Kju?

I think kju's example very much belongs to this ticket as the main topic/issue has not been resolved.

Updated by kju over 3 years ago

My main issue is that AI should not waste AA missiles.

It should:
a) use AT missiles first
b) maybe even rockets and the main gun
c) only on real threats to a fast flying plane (AAA type vehicles)

if at all - the minor damage of AA missiles vs armored vehicles makes it mostly pointless.

so in the end an use of aa missiles for air units only (in the air only?) is the way to go in my view.

Updated by Dwarden over 3 years ago

AI should not use AA missiles versus heavy ground targets especially with plenty of guided AT and rockets available

AA rocket warhead would not work against heavy ground vehicles (due to theirs armor) yet it may work against
soft targets with light or no armoring (APC, trucks, jeeps with MG/AA weaponry for example)

Updated by Dwarden over 3 years ago

decision which type of missile (AA vs AT) to use against target missing in the build 83118? http://dev-heaven.net/issues/7578#note-7

will re-adjust as 1.61 target

Updated by Dwarden over 3 years ago

  • Target version changed from 1.60 BETA to 1.61 BETA

Updated by kju almost 3 years ago

  • Target version changed from 1.61 BETA to 1.63 BETA

Updated by Suma 5 months ago

  • Assignee changed from Suma to hladas

Also available in: Atom PDF