Bug #7543

Various issues with Wounding System

Added by Franklin about 5 years ago. Updated about 5 years ago.

Status:Closed Start date:12/30/2009
Priority:Normal Due date:
Assignee:Xeno % Done:

100%

Category:-
Target version:1.0.0
Component: Affected Version:
Close Reason:

Description

1. Once i enabled the ACE wounding system on a mission, it seemed to make the enemies into chuck norris, it took 4 or 5 headshots from nearly any weapon to drop the guys cold. in some instances shooting the body it would take upwards of 10 shots to drop guys. (extra armor is not enabled on the server)

2. After respawn the blurry vision effect remained, and the option to use morphine would appear in the action menu.

3. dont know if this one could be related to a shot respawn time or not but; rarely did i ever see the "tunnel vision" effect where your knocked unconcious and need to be revived via epi, im not sure if the script simply isnt running, or if this is a mission issue.

ACE_Wounding_Domination_R_AC.Chernarus.pbo (2.2 MB) Franklin, 12/31/2009 00:30

History

Updated by Sickboy about 5 years ago

Please add rpt.
Bugz

Updated by Xeno about 5 years ago

  • Status changed from New to Feedback

Attach the mission and your RPT.

Is the mission with Revive ?
Mission using BIS AIS ?

It doesn't need 4 or 5 headshots to kill an AI or player. In 99% one headshot will kill the entity.

I can only guess without further information.

Updated by Franklin about 5 years ago

i actually modified your Domi Map Xeno. I commented out the define revive in the setup. ensured that the BIS AIS werent present on the map, and added the ACE Wounding module. then ran setupcopy.bat and exported to MP missions.

Unfortunately ive already overwritten that map (re-enabling the revive system), and the RPT was deleted this morning coincidentally in order to single out an unrelated issue with our server this morning.

ive reproduced the changes in order to attempt to help the best i can, however this version was not the exact same as what was on our server yesterday.

Updated by Xeno about 5 years ago

  • Target version set to 395

Updated by Crusader about 5 years ago

Had this just now, put me and another soldier in the editor, with the ace wounding module and just shot the guy in the face. Repeatedly. It took multiple shots (3-4) to take him down.

Updated by Xeno about 5 years ago

This only happens for units in the player group.

Somehow when a player shoots his own team members (AI) other values are transfered to the handleDamage handler.

Ungroup the unit and it will die.

Updated by TheVoodoo about 5 years ago

Same problem while playing this mission... http://www.armaholic.com/page.php?id=8629

Updated by Xeno about 5 years ago

TheVoodoo wrote:

Same problem while playing this mission... http://www.armaholic.com/page.php?id=8629

Could you explain which problems exactly ?
And did you play on a dedicated server, hosted or SP ?
And was it with the latest ACE update ?

See, I can only solve the problems if I get a little bit more information.
Just "Same problem..." doesn't help.

BugZ

Updated by Franklin about 5 years ago

tested according to the methods prescribed in "BugZ", could not reproduce this effect, other than with AI in my own group.

Updated by rocko about 5 years ago

  • Assignee set to Xeno

Updated by Xeno about 5 years ago

  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100

Except the first problem everything else is or should be resolved.

The "Chuck Norris behaviour" occurs only if the AI is in the player group and the player shoots at his own AI.
I'll try to find a workaround once I get back to wounds again. But for now it is ok as most of the time you won't shoot your own AI ;)

Updated by rocko about 5 years ago

  • Target version changed from 395 to 1.0.0

Also available in: Atom PDF