Bug #7473

Alt-Enter from windowed to full=screen mode does not restore resolution

Added by sbsmac over 5 years ago. Updated over 3 years ago.

Status:Closed Start date:12/28/2009
Priority:Normal Due date:12/01/2011
Assignee:sbsmac % Done:

0%

Category:Interface
Target version:1.59.79384
Affected ArmA II version:1.57.76815 First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:No NGUrl:
Related to content of DLC: WIKIurl:

Description

If you don't seem to exhibit the issue, delete your ArmA2.cfg first.

Repro
Start ArmA2 in full-screen mode
Alt-enter to windowed mode
Interface and rendering resolution will be changed from (example) 1920x1200 to 800x600
In case you're in native resolution with windowed mode, resize your window
Alt-enter back to full-screen mode

Observed
Interface and rendering resolution will be left at 800x600 (or some other random resolution)

Expected
Interface and rendering resolution should be set back to 1920x1200

History

Updated by BlueSteel over 5 years ago

I can confirm this. Different repro:

Start ArmA 2 with a ArmA2.cfg containing this:

Resolution_Bpp=32;
Resolution_W=1680;
Resolution_H=1050;
Render_W=1680;
Render_H=1050;
winW=800;
winH=600;
winDefW=800;
winDefH=600;
Windowed=1;

Start the game and switch back to fullscreen with Alt+Enter.

Expected behaviour: Screen- and render-resolution should both switch to 1680x1050, as specified in the ini.

Observed behaviour: Fullscreen resolution is completely incorrect, these changes appear in the cfg:

Resolution_W=816;
Resolution_H=638;
Render_W=1440;
Render_H=900;
winW=800;
winH=600;
winDefW=800;
winDefH=600;
Windowed=0;

Updated by kju over 5 years ago

  • Due date set to 03/28/2010
  • Status changed from New to Assigned

Updated by kju over 5 years ago

  • Due date changed from 03/28/2010 to 02/17/2010

Any improvement with the latest beta patch?

  • [62687] Fixed: 3D resolution now maintained correctly when Alt-Tabbing.
  • [62492] Fixed: Window size/position was not stored after a change.

Updated by CarlGustaffa over 5 years ago

Works for me now. I'm naturally not getting arbitrary resolutions while in full screen, only the native ones. It seems to pick the closest native, and resets fine to arbitrary when I go back to windowed again.

I would say, "problem solved", unless somebody objects.

Updated by kju over 5 years ago

  • Due date deleted (02/17/2010)
  • Status changed from Assigned to Resolved
  • Target version set to 1.06 BETA

Updated by Fireball about 5 years ago

  • Due date set to 06/12/2010
  • Status changed from Resolved to Feedback
  • Target version deleted (1.06 BETA)

For me this still does set some random "fitting" resolution in windowed mode when I resize the window. As soon I restore full screen I'm stuck with the approximate setting of the last window size and need to reset the resolution(s) manually, thus not resolved.

Works for me now. I'm naturally not getting arbitrary resolutions while in full screen, only the native ones. It seems to pick the closest native, and resets fine to arbitrary when I go back to windowed again.

1024x768 from the small windows I just made is nowhere native to my monitor, not even the correct aspect.

IMO this needs to be split up to a full screen resolution and windowed resolution setting in the cfg, so it can switch between the two resolutions when Alt-Enter'ing. This sounds more like a feature request though.

Updated by Fireball about 5 years ago

  • Due date changed from 06/12/2010 to 07/12/2010
  • Status changed from Feedback to Assigned
  • Assignee set to Dwarden
  • Reproduced by another DH user changed from No to Yes

Updated description.

Updated by kju over 4 years ago

  • Due date changed from 07/12/2010 to 06/01/2011
  • Status changed from Assigned to Feedback
  • Affected ArmA II version changed from 1.05.62017 to 1.55.75445
  • I am using some Mods set to No
  • Reproducible for you set to No

Still true?

Updated by zGuba about 4 years ago

  • Due date changed from 06/01/2011 to 09/01/2011
  • Assignee changed from Dwarden to sbsmac

Wrong assignment, thus I'll prolong it - please review

Updated by kju almost 4 years ago

  • Due date changed from 09/01/2011 to 12/01/2011
  • Affected ArmA II version changed from 1.55.75445 to 1.57.76815

Updated by zGuba over 3 years ago

  • Status changed from Feedback to Closed
  • Target version set to 1.59.79384

Seems to be alright, I don't know since when exactly.

Also available in: Atom PDF