Feature #7410

Removal of AH1 Z Cobras in ACE version

Added by fambaa over 5 years ago. Updated about 5 years ago.

Status:Closed Start date:12/26/2009
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:-
Affected Version: I am using some Mods:
Affected ArmA II version:Please select... Reproducible for you:

Description

Since no russian helicopter has any means of defending against other aircraft and helicopters its only fair to remove the Stingercobras from the Pool.

No Chopper of east has the means of fighting another airtarget while cobra and AH 64 have turrts which deal great damage. Even the Yak cannon does no damage, they are not explosive shells nor armorpiercing. It takes around 800 shots to completely destroy a littlebird with it.

Remove the AH1 Z versions, blufor will still have cobras with hellfires. (1 Hellfire blows up a T 72 while you need 3 kamov missiles to blow a M1A1)

History

Updated by ICE over 5 years ago

Maybe not, but the Su34 is by far and away the most dominent aircraft in the game and is more than a leveller. with the ability to fire 4 x r73's and 6 ch24's.

Red team still have the BIG advantage in ACE2

Updated by Benny over 5 years ago

Su34 CH29 is now KH29 which require laser guidance. so su 34 can just lock air with r73 now.

Updated by fambaa over 5 years ago

Additional you need to correct the prices on the choppers. The AGM Cobras with 16 hellfires are now more close to the vanilla Kamov than the actual ACE Kamov. There should be a difference in price for the 8 Hellfire and 16 Hellfire versions.

I didnt say that in the initial post because it has nothing to do with my request but. In ACE West tanks can barely be defeated by east aircraft. The only exception is the Kamov with 3 missiles, where the cobra needs 1 or 2 missiles.

FFAR is useless against tanks now. I measured 40 direct or close hits to a Tusk to blow him up. Also made a feature request to ACE team to add different FFAR ammotypes, actual ones are only HE.

For defeating Tanks the only 1 man mission plane possible to do the job is the A10. All others need laser now. The bombers like Av8 with MK82 are not supposed to fight moving targets. Same counts for the Bomberhind now. Ataka and Shturm missiles 4 each are able to defeat 1 Tank only, or APCs respectively .

This leave us with Air which can defeat tanks in larger numbers:

for BLUFOR:

A10
AH64
AH 1 Z+W

for OPFOR

Kamov

Except AH64, AH1W and Kamov. All Cobras have Stinger, and the A10 got Stinger. This leaves OPFOR at a disadvantage in defeating tanks and has to rely on teamwork to protect the Kamovs.
Blufor team will only chose AH1Z AGM or A10. (Noobs still buy AH64 ofc, and some maybe AH1W versions, because its new)

On this note I want to add that russian planes seem to have more antiair missiles, but those appear much less lethal than the AIM 9 Stingers (correct me if im wrong) One game I played, it needed 6 or 7 r73 to completely destroy an already downed AH64.

Just my opinion on balance.

Updated by Enforcer about 5 years ago

We just need very high prices for very high firepower.

If you want to force that gather a large group for backup so Benny understands.

Updated by Benny about 5 years ago

  • Status changed from New to Closed

Also available in: Atom PDF