Bug #7364

Different Artillery ammo for Playercontrolled Arty

Added by fambaa about 5 years ago. Updated about 4 years ago.

Status:Closed Start date:12/25/2009
Priority:Normal Due date:
Assignee:Benny % Done:

100%

Category:-
Target version:Warfare BE 2.067
Affected Version: I am using some Mods:
Affected ArmA II version:Please select... Reproducible for you:

Description

Saw that on a modded domination map, m119s and mortars were able to use either phosphour or high explosive. The guns were synced with arty module so kills with it seem not to show, so you dont know if you even hit anything.
In Ace the phosphour rounds seem to have good area of effect.

If its possbile could you try to make the virtual arty use various ammotypes? Sadarm, HE, WP. You can skip smoke, illum laser in my opinion, smoke and illum would be barely used, and laser would be exceptional strong defeating bases but its your call if you do it ;)

I think with the use of the arty module and only one playercontrolled gun per player would lighen up the uberness of squadsized artillery batteries. So the gamemasters could deside to whether allow big artillery batteries or only playercontrolled arty or both. Playercontrolled arty is overdue, since you want to stay with your guns reloading/defending build new guns and defenses to protect your investment.

Sincerely your artillery loving player
fambaa :D

History

Updated by fambaa about 5 years ago

Ah my bad, change it to feature request plz Benny.

Updated by Jemimus about 5 years ago

Voted this up. Would be awesome to have more options. Arty is very popular in Warfare and there are so many situations where some of the different types of rounds would be effective.

Updated by helling3r about 4 years ago

Same here, but i would suggest to also put laser guided, illum and smoke to the guns supporting it in real life.
It would be of tactical benefit and surely be used if available.

Also laserguided shells are not that overbalanced as firstly tought, because if the base is properly defended against RECON, this is not that an issue. And Arty can be pretty precise already nowadays if the target is properly marked.

Updated by Benny about 4 years ago

  • Status changed from New to Assigned
  • Priority changed from High to Normal
  • Target version set to Warfare BE 2.067

Updated by Benny about 4 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

Updated by quoestudio about 4 years ago

would this feature only available if the human player is sitting in the Arty, or you could change the ammo and order your AI to fire from a distance?

Updated by Benny about 4 years ago

You can change the ammo remotely via the action menu (6)

Also available in: Atom PDF