Bug #7140

Crash on savegame/loadgame

Added by Sickboy about 5 years ago. Updated about 5 years ago.

Status:Closed Start date:12/19/2009
Priority:Normal Due date:
Assignee:ViperMaul % Done:

0%

Category:Complex
Target version:1.0.0
Component: Affected Version:
Close Reason:

Description

http://forums.bistudio.com/showpost.php?p=1518908&postcount=3306

Does this happen with or without the official ArmA 2 beta loaded?
I know this is a little cumbersome, but could you test it without ACEX and ACEX_SM ?
If that doesn't change anything, it would be extremely helpful if you guys could move 5-10 ace_sys_* or ace_c_* addons away at a time, until the problem goes away.
If the problem is gone, if you report the addons you moved away last, this will speed up the tracing/solving very much.


Related issues

related to A.C.E. for OA - Bug #7048: Savegame bug, loading a savegame is not possible with ACE Closed 12/17/2009

History

Updated by rocko about 5 years ago

I'd like to know wether this is reproduceable with any other mod/addon. And then close it, if thats the case.

Updated by Herr_Kalashnikov about 5 years ago

I tested it some to pinpoint the problem, no real luck sofar.

The way i repro it is:

- from the editor i load a mission which gives a autosave fast
- revert back to that autosave

With my setup when i load the save game it always get stuck on 50% progress bar. Arma2.exe just hangs in my process explorer (at a steady 50% cpu usage). Tried it with and without latest beta. I'll try to disable more parts of ace to pinpoint it better.

Update.. tried with 1.05 and is still a problem. Actualy i can load a vanilla saved game in Ace2, but can't load a Ace2 saved mission

Updated by ViperMaul about 5 years ago

Please attach the mission that crashes.
Also attach an RPT file as well. So we can see if we can duplicate the problem.

Updated by Herr_Kalashnikov about 5 years ago

There is maybe a misunderstanding about what the precise problem is, because I 'hijacked' the issue halfway, but the main problem i describe is:

Every mission which u save in Ace2 can't be loaded again

That means if I play any mission which saves the game (while running Ace) u can't revert to that save. U can save the game without a problem, but when u try to revert to that save point u will experience the problems described above. I can load a game which is saved with just vanilla Arma.

Tried with just running cba and ace (without acex/acex_sm) but that didn't resolve it.

Regarding the RPT the only thing i see worth mentioning is these lines..

SetFace error: class CfgFaces.CooperHead.Face107 not found
Error: Error during SetFace - class CfgFaces.CooperHead.Face107 not found
No speaker given, patched to Male01EN
String str_callsign_consiglieri not found
0:01:35.124 (0) [x\ace\addons\sys_blood\init_bloodMonitor.sqf:11] BloodMonitor activated!
0:01:35.373 (0) [x\ace\addons\sys_goggles\XEH_postClientInit.sqf:21] WARNING: Initializing... FAILURE! Please check your ACE userconfig. ACE Goggles feature has been disabled on your computer!
0:01:35.374 (0) [x\ace\addons\sys_goggles\XEH_postClientInit.sqf:22] Reason: "YOUR PLAYER NAME DOES NOT MATCH NAME GIVEN IN ACE USERCONFIG."

Weird error but goggles seem to work fine (I also manuly updated the ./userconfig/ace/ace_clientside_config when there was a patch which changed the way it was defined).

A repro mission would be as easy as starting up the editor and create a savegame trigger and try to load it again.

Realy surprised there isn't alot of people talking about this problem because in mycase it's a real showstopper because I rarely never die in a SP game :)

Thanks in advance

Updated by rocko about 5 years ago

Please check this ticket #7048.

Create a new profile and reopen if issue is still present.
Make sure no bad addons used.

Updated by rocko about 5 years ago

  • Status changed from Assigned to Closed

Also available in: Atom PDF