Bug #7085

Flashlights have wrong axis for rotation

Added by Minoza over 5 years ago. Updated over 5 years ago.

Status:Rejected Start date:12/17/2009
Priority:Normal Due date:12/31/2009
Assignee:- % Done:

0%

Category:-
Target version:-
Component: Affected Version:
Close Reason:

Description

All flashlights attached to the weapons have wrong axis for vertical rotation. For example, if you lower your weapon 10 degrees towards ground/sky flashlight will go 20 or 30 degrees up/down...

flashlight1.jpg (23.6 kB) VKing, 12/18/2009 14:29

flashlight2.jpg (33.6 kB) VKing, 12/18/2009 14:30

History

Updated by Minoza over 5 years ago

I forgot

They also aren't aligned (flashlight light source) with model of flashlight on guns.

Updated by rocko over 5 years ago

Please take a screen. Cannot reproduce.

Updated by nuttex over 5 years ago

Well, I noticed the same problem. Flashlight light source isn't aligned with the model when you're sprinting with 1st Person view.

Updated by VKing over 5 years ago

Updated by VKing over 5 years ago

Dang, pressed submit too early.

Anyway, as you can see, the lightbeam isn't connected to the weapon, and moves in mysterious ways that have less to do whith where the weapon is pointing at the time.

Updated by rocko over 5 years ago

  • Category changed from Animations to Script
  • Target version set to 395

Updated by rocko over 5 years ago

  • Category deleted (Script)
  • Status changed from New to Rejected
  • Target version deleted (395)

By design.
Wait for OA for proper flashlights, if at all.

Also available in: Atom PDF