Feature #6985

Stamina recovery too long

Added by Minoza over 5 years ago. Updated over 2 years ago.

Status:Closed Start date:12/15/2009
Priority:Normal Due date:02/09/2010
Assignee:Rommel % Done:

90%

Category:Complex
Target version:1.0.1
Component:sys_stamina Affected Version:
Close Reason:

Description

Dear ACE team,

Stamina is good. No point to argue on that. BUT! Recovering time is TOO LONG! ACE team you can say whatever you want on this, but it is too long, and I'm sure many will agree on this.

Effect of closing eyes is one way to simulate soldier being exhausted, ok, but muting sound during black screen is annoying, please, remove that and keep only ''blackouts''. Personally, it's not perfect effect for this situation but I can't think of anything better now.

The way it's done now is annoying even for experienced ACE players and real life trained soldiers, recovery time should really be shortened.

Also, make heart buming faster and make it sound louder, you should make running animation slower when you get tired.

In conclusion, having stamina as feature is great, just please, don't leave it as it is, I know you can make it better, that's why I'm asking you to do it this way.

Thank you!

Run_20Test.utes.zip (1 kB) Pyrodox, 02/01/2010 11:45


Related issues

related to A.C.E. for OA - Task #5257: TEST: Stamina system Closed 10/17/2009 11/15/2009
related to A.C.E. for OA - Bug #7159: Super stayer US man & weakling russian man Closed 12/19/2009
related to A.C.E. for OA - Bug #7991: Stamina system is detrimental to gameplay in current state Rejected 01/11/2010
related to A.C.E. for OA - Feature #7912: Please reduce stamina effects Rejected 01/10/2010
duplicated by A.C.E. for OA - Feature #6986: Stamina recovery time Rejected 12/15/2009

History

Updated by Sickboy over 5 years ago

  • Project changed from ARMA2 Community Issue Tracker to A.C.E. for OA

Updated by Scarecrow over 5 years ago

Totally agree, its meaningless to me to make the character so handicapped that he cant recover in the time it takes to clear a town in domi, I had to respawn to get back in the game, and that because of the stamina system.. I dropped my gear at first to be able to recover fast i thought but still I was not even able to get up walk slowly, that feature where you drop down and lay there is annoying as hell. in real life i am able to stop myself from getting that exhausted, this only makes it annoying.. its still a game folks!

Updated by rocko over 5 years ago

Scarecrow wrote:

Totally agree, its meaningless to me to make the character so handicapped that he cant recover in the time it takes to clear a town in domi, I had to respawn to get back in the game, and that because of the stamina system.. I dropped my gear at first to be able to recover fast i thought but still I was not even able to get up walk slowly, that feature where you drop down and lay there is annoying as hell. in real life i am able to stop myself from getting that exhausted, this only makes it annoying.. its still a game folks!

You cannot blame the stamina system if you cannot adapt your style of play to it. That simple.
Don't exhaust yourself. Stop before you collapse and recover. The system tells you when to do so.

Anyway, without suggestions for recovery times or anything else, don't expect things fixed.

Complaining rants help no one, just makes me reject stuff much much faster.

Updated by Minoza over 5 years ago

Totally agree, its meaningless to me to make the character so handicapped that he cant recover in the time it takes to clear a town in domi, I had to respawn to get back in the game, and that because of the stamina system.. I dropped my gear at first to be able to recover fast i thought but still I was not even able to get up walk slowly, that feature where you drop down and lay there is annoying as hell. in real life i am able to stop myself from getting that exhausted, this only makes it annoying.. its still a game folks!

Can't agree on this, as I already said, stamina is great, and I have nothing against stopping the player from sprinting around like maniac with 30+ kg of equipment... It's the time needed to recover that bothers me. It should be much shorter.

Also I don't like loss of the sound during short blackouts, they annoy me and many other people.

Another suggestion was to bring up the volume of heart bumps and to speed up beats.

Please keep critics constructive and stop whining about stamina itself... That will lead us nowhere...

Updated by BigMorgan over 5 years ago

I also don't like the blackouts. Its really quite silly that your character is losing consciousness from exhaustion after so short a run.

But like Minoza I really do enjoy the stamina system, and am more than eager to adapt my style of play to it.

However, the way its executed feels cheesy.

If you'd like specific numbers I would suggest enhancing all character's stamina by about 20%. I.e. if a character was carrying a load that caused him to collapse after jogging 500m, he could then jog 600m without blacking out. However if that character could jog 1000m without blacking out he could now jog 1200m.

Also, I would like to see the "black-out" effect removed. Pumping heart rate, inability to move while standing are nice. Even blurred vision is good. But the short flashes of black screen come off as silly.

In all honesty I feel like I've adapted to the system pretty well so I have no comment on recovery time since I never reach the point of collapse.

Updated by rocko over 5 years ago

  • Target version set to 395

Updated by Nimrod over 5 years ago

recovery time is really annoying :(
can't be possible that if i stand crouched, it takes forever to recover. I got always to lay down..quite annoying..

Updated by rocko over 5 years ago

What time comes close to "forever", Nimrod?

Updated by Alanthegrate over 5 years ago

I thank we should go more to what ARMA2 was at that you slowed down to a slow jog. My self and others at are server Can not stand the Stamina system as is know, it takes you too far away from the game. I mean a Engineer can not carry anything and he still falls down and blacks out it is not very real. That you black out running I could carry all that and more and run or jog and then hike when I get tired then stop and go to the knee and rest then get back up that is how it should be. I mean when have anyone here ever drop to the ground and could not get up for 10 minutes because you jogged for 100m not run. it is Not REAL PLEASE Recovering time faster and no black unless Full load and ran for 1000m then I could see that in real life.

Also BigMorgan is right I like his ideas and so do everone that plays in on our server LastSight. The Black out is Way silly and old school the Blurred effect for like 1-4 sec would tell you you are getting tired that is a great idea. If you are not going to change it please let us know how we can not use it or a shout off switch so we do not have to waite for set to Future, because we have lost some members to our no ace arma2 servr because or just lost them as members because of the Stamina systems not the bugs. This is not ment to insulte you just to show you the Feed back I have gotten on our servers.

Updated by rocko over 5 years ago

  • Status changed from New to Rejected
  • Target version deleted (395)

Updated by Sickboy over 5 years ago

If you want to know all the ins and outs as to why the Stamina system is how it is, please search 'stamina' in the search box right up, and at the BIS forums thread.

To disable Stamina; Add to mission init or server-side addon:
if (isServer) then { ACE_NoStaminaEffects = true; publicVariable "ACE_NoStaminaEffects" };

Updated by Sickboy over 5 years ago

  • Status changed from Rejected to Feedback

Still waiting for nimrod feedback.

Updated by Alanthegrate over 5 years ago

I did not mean to ruffle any Fathers Rocko. it is just feed back I got form others, I though it would help I like Stamina system, but as it is know it is bad and needs dialing in that is all. You did not put it to Rejected, that is not accepting others peoples Perspective on how Stamina should work it is just a opinion. I miss wrote befor for that I am sorry. I should have wrote "Can not stand the Stamina system as is know" forgive my bad typing my mind gets ahead of my hands. Thanks Sickboy for the Help.

Updated by rocko over 5 years ago

  • Target version set to 395

Updated by Nimrod over 5 years ago

rocko wrote:

What time comes close to "forever", Nimrod?

forever i meant, really looooooong time.
Here i go:
Seen playing BE Warfare's v.2.050a@ACE2, i run, fire and start to get tired. Then stopped, crouched, the fatigue level sometimes takes more than 5 minutes to recover, sometimes more than 10 mins. If u try to get in a car, and drive around for also 5 minutes or even more, when u disembark ur fatigue level has NOT decreased at all, it's still there.
Moreover, sometimes after i'm killed and if i was tired before got killed, i respawn with the same fatigue level i had before my death, with my character breathing deeply.
Oh and yeah for forever i meant forever, for real, it occured 2 times, but my fatigue level did not raise up at all. Even if i killed myself i respawned tired, and then i recovered.
I can say that if i lay on the ground, i can recover, but... is it imperative all the times? In crouched position i should recover too, or not? Never layed on the ground anyway in real life to recover myself ^^
Oh and i noticed this
equip urself with
m16 acog m203
4 mags
Smaw
2 rockets
8 HE rounds

u can recover ur breath easily

but with one more rocket u have to wait a very long time.

Updated by TimRiceSE over 5 years ago

Perhaps the stamina system could be in some way tied to the difficulty setting of the mission. e.g. public servers playing domination (where it seems most of the complaints come from, as theres generally a lot of movement on foot) are usually set on normal difficulty, perhaps the "easier" settings could have more forgiving stamina system settings, i.e. longer time before you get tired out, or quicker recovery time. Hardest difficulty setting could be the same stamina system values as we have now.

Updated by DirTyDeeDs over 5 years ago

I must support criticisms that describe fatigue level unchanged after respawn or sitting in a vehicle many minutes. I cant believe this is an intended feature. Please address the recovery of the low stamina effects or many servers will just disable the system, to my sadness.
If this critique is in the wrong issue, please tell me and I will create one specifically for this.
thanks.

Updated by rocko over 5 years ago

Stamina system is a core feature of the mod.

And just to prevent more comments about stamina in ACE2:

If you don't like, don't use. No other advice can be given here.
If you cannot adapt to ACE2, learn how to adapt.
If you are unwilling to learn, stay away from ACE2. Probably ACE2 isn't the right mod for you to use.

Other than that I cannot do much without repro missions. And no, I won't waste my time in the editor to find out myself.

The rest will be looked into it.

Updated by tcp over 5 years ago

Some classes are pretty weak (Engineer), so I avoid them now. Although, in Domination, I usually carry a rambo loadout (M249,SMAW,satchels), but I can still make it around the map with (frequent) rest stops. I used to even carry a ruck, but the ruck system still needs work so that you can drop it strategically.

I tend to agree that these grunts are in poor shape. Well it's true that they may not be able to sprint with certain loads, they should be able to shuffle all day long. They don't even gradually start to move sluggishly, they just face plant even while walking. You would have to trip hard or just plain quit if you can't control your body enough to just take a knee. Really, the only way to move efficiently is to spread the equipment between your teammates to make for very light loads or put all your stuff in the back of a vehicle.

Updated by rocko over 5 years ago

  • Category set to Complex
  • Priority changed from Normal to Low

Updated by Trexian over 5 years ago

I picked this stamina-related ticket for this, hope it is ok. :)

There is an animation for the player to "sit." Perhaps make something in the stamina system recognize that position and rejuvenate more quickly? As I understand it, you can't fire or take any offensive action from that position.

Edit:
Also, in digging around the pbo, I think there is another issue. In fnc_staminaFX, there does not appear to be a time-component to the rejuvenation. It appears to "lose" fatigue/regain stamina based on a modifier of ACE_MvmtFV, and how that affects ACE_FV. But, without an in-game time component, it relies on the number of iterations of the script itself. For those of us with older systems, the math-intensive parts of this script, along with all the other stuff that might be going on, means that this script may not be executed very often.

Sincerest apologies if I'm off base with these observations. I respect the hell out of you guys who can code all of this and make it work.

Updated by Xeno over 5 years ago

  • Due date changed from 12/29/2009 to 11/18/2010

Updated by DMarkwick over 5 years ago

I can confirm by direct observation that the "script-lag" effect that the current 3ms script time limit effects time based calculations.

The JTD Hide addon moves an invisible viewblock object based on time. During testing (in which the hide is visible) I can see that the 3ms limit sometimes means that the hide is not updated every 1 second like it should be, instead it's actioned "as & when" the engine has time for it. This means the hide moves slower, more slower the more action is going on. I think this is a direct analogy to what people are seeing here.

Ive often thought that this logic needs to be changed from loop-dependant to Time dependant, so instead of relying on the loop cycling each 1 second, I loop it but then check the current time against the last Time the loop was actioned:
Calculation_Time = Time - Script_Time; {code based on size of Calculation_Time};
Script_Time = Time;
Sleep 1;

Something along those lines.

Updated by rocko over 5 years ago

Not sure what the problem is now about the fsm running.

It does "sleep" 1.3 sec for each cycle.
Gear weight (intensive, IMO) is calculated every 30 seconds.

In comparison, the ACE1 stamina system did calculate everything every second. So in ACE2 you gain .3 seconds + 29 seconds where no weight is calculated.

Stamina is calculated based on Movement (Animations, i.e SPRINT, WALK). So is recovery (WALKING, STANDING, SITTING, LYING).
And ofc Weight.

Updated by Trexian over 5 years ago

But in my experience (with what is now a lower-end PC), the scripted "sleep" does not equate to in-game time. Sometimes, it also means the script in-process does not ever get run. DM has more experience with the script-lag issue, but by way of example, if I've reached the maximum fatigue and fall prone, ideally it will increment back ~ every 1.3 seconds.

But, if the script is not processed one iteration, then I have to wait ~ 2.6 seconds for that bit of rejuvenation, which may be very small. Or, worse, it is not based on a 1.3 second "cycle", but rather whenever the engine has time to get back around to the script. This can be particularly problematic if there is alot of action going on, which would increase the chances of getting the script-lag effect, further delaying rejuvenation.

I noticed the pdfs in the repository do an EXCELLENT job of describing how fatigue is accrued. However, I'm not sure that it is rejuvenated at the same rate?

Also - my apologies regarding ACE1. I didn't spend much time in it at all, so I can't comment on any comparison. :)

Updated by KingHomer over 5 years ago

  • Assignee set to Rommel
  • Priority changed from Low to High
  • Target version changed from 395 to 1.0.0

Updated by Rommel over 5 years ago

  • Status changed from Feedback to In progress
  • % Done changed from 0 to 10
  • Component set to sys_stamina

Those that are worried about the script intensiveness of the staminaFX.fsm (fnc_staminaFX.sqf is deprecated, and not in use); need not worry, I have worked on it timelessly in making it as friendly to the CPU as possible. There are approximately ten mathematical equations, all of which are simple expressions and executed by the engine in under 2.3e-6 seconds. The 0.3 ms delay (perhaps a show of experience when they are calling it a 3ms delay...) only occurs in the state compartments within the FSM, and they are all optimised for a much slower PC than even ArmA2 could run on.
The only time a delay could be expected is over 10,000 loops/instances are in the script scheduler, then you may experience a slight delay of around 3s. There are under 100 (until further documentation, assume under 30) loops within the ACE mod itself, therefore there is no way assuming all are in the script scheduler (there are many ways to bypass) that you would feel the 0.0075s delay extra.

Hope that helped some one.
Now onto the issue, I am doing a lot of testing with testers (funny aye?) and we have concluded the same problem, something is lengthening the recovery time to a unplayable mean. And something is also causing sudden stamina loss. Both of which are heavy issues.

I am looking into this, and plan to have it completed and dusted by (not the next update) but the next.

Updated by Rommel over 5 years ago

  • Status changed from In progress to Feedback
  • % Done changed from 10 to 70

Awaiting feedback from next update.

Updated by DirTyDeeDs over 5 years ago

rocko wrote:

...

Stamina is calculated based on Movement (Animations, i.e SPRINT, WALK). So is recovery (WALKING, STANDING, SITTING, LYING).
And ofc Weight.

Is the stamina also determined by the weapon you have 'in hand'? ie; pistol vs rifle.

It is my experience that equipping a pistol can extend your stamina during long foot travel. That and crouch/fastwalk enable me avoid collapse the most.

Updated by Rommel over 5 years ago

  • % Done changed from 70 to 80

Is this now a non issue? Feed back please!

Updated by Sickboy over 5 years ago

  • Target version changed from 1.0.0 to 1.0.1

Updated by Rommel over 5 years ago

  • Due date changed from 11/18/2010 to 01/27/2010
  • Priority changed from High to Normal
  • % Done changed from 80 to 90

Please provide feedback soon. Otherwise assumed this is no longer an issue.

Updated by Minoza about 5 years ago

So far didn't experience long recovery times. I'll do few tests and let you know. Also, if I encounter same problems I will attach rpt and mission.

Updated by Rommel about 5 years ago

  • Status changed from Feedback to In progress

Experienced this. Unable to reproduce. Key information for investigation (by myself) is irregular items, and a particular mission. When it does happen, it happens to everyone, at least in my experience, therefore it must be situational.

Updated by CarlGustaffa about 5 years ago

Is stamina currently disabled? With 52kgs on my back (4 satchels I needed for the mission) I was able to run like forever, and when I started to suspect I went into sprinting which didn't trigger any stamina as well. Hope this is a temporary thing.

Updated by Rommel about 5 years ago

No, are you able to produce a bugZ report; have you been able to reproduce? Is the mission disabling Stamina?

Updated by CarlGustaffa about 5 years ago

No, it's my own mission, and I can't remember ever having putting in that thing.
Ok, I'll make a ticket out of it eventually. I wasn't sure since status now said in progress, and it could be a temporary thing during development. Thanks though.

Updated by Yuka about 5 years ago

Stamina is a great system, but the numbers are a bit unrealistic.

I'm in the US Army as an Infantryman - we ruck and carry heavy loads every day. The stamina system in ACE2 makes me feel as if the player is an out of shape, disgusting fat body who has been sitting on the couch playing COD every day of his life and then just got off his ass and for some reason is in a warzone now trying to carry what he needs to fight. If a real soldier were to collapse or have problems like we face with the stamina system in ACE2 - he'd go in for a medical eval and then he'd probably get discharged for failure to maintain phyiscal fitness levels.

Some of the related requirements of AIT for infantrymen in the US Army are as follows:
Run 2 miles in less than 15 minutes (for 26 years old or younger)
Run 5 miles in less than 45 minutes
Complete a 17 mile ruck march with ~115 pounds of total equipment on them

Those really aren't hard requirements. Here's what I've been able to do recently with my unit:

The Load:
In my ruck was 22 kg before ammo.
I was carrying an M240B. (12.5 kg)
700 rounds of belted ammunition for the M240B, distributed between my ruck and on my IBA in pouches, most of it was in the ruck (~22 kg)
M192 Tripod (5.2 kg)
My IBA with side plates (9.25 kg)
My MICH2000 (1.63 kg)
Uniform, boots, etc (2-3 kg)

75.58 kg total

With that on I was able to ruck march at a brisk walk with elongated steps for 21 miles in a little over 4 hours. At the end of 21 miles I was able to run at an encumbered sprint for 1/2 mile and then I was able to return to the brisk walk.

With just my IBA, my weapon (M240B) about 300 rounds of ammo, I could easily run (not sprint) for 2-3 miles. I can sprint about 300 meters in the same equipment.

Now, this wasn't just me that is/was able to do this. I did this with my battalion - over 200 soldiers. Not everyone had the load I had, most were carrying loads of 60 to 65 KG (poor machinegunners had the real weight). But they all completed it.

I hope this information helps you out in making decisions to change the stamina system's properties.

Updated by Sickboy about 5 years ago

What version of ACE2 are you running?
The data you provided is nearly identical to that which is used throughout the system, maybe still a bug left or maybe an issue related to the stance your soldier was in the game during testing?
There's crouch-walk/run, stand-walk/run, etc.

Updated by Pyrodox about 5 years ago

I made this post over on the BIS forums, too.

I love that ACE2 has implemented the stamina system, but I agree it needs a bit of tweaking.

What I would personally like to see would be something along the lines of:

In 75kg total load you can "walk" (as in the in-game walk speed) for pretty much as long as you want.

In the same load, you can "sprint" about 300m, at which point instead of just going "oops I ran too much time to pass out" you exhibit signs of fatigue (heavy breathing, heart pounding in your ears, blurred vision, etc) drop back down to a walk, and you can not sprint anymore until your stamina builds back up.

Now, if you continue to walk, your stamina will build up slowly, if you sit, or lay down, it will build back up much faster.

Then implement a "force sprint" key, maybe attach it to the standard control for "Evasive Forward" so if you take fire while exhausted you can still sprint... Here's where the "pass out" type of effects we see now would come in. If you're forced to sprint, allow maybe 50 or 100m of "forced sprint" in your exhausted state, then you start to experience the blacking out effect, gasping for air, and eventually fall over.

I think this would be a bit more realistic, because in real life you wouldn't just run till you passed out, and if you really needed to sprint out of the line of fire (until you had absolutely no energy left and just passed out) you would push yourself that hard under adrenaline until you do just that.

I think having a system where you get "tired" and slow down, but can force yourself to use up the last of your energy to the point you pass out if absolutely necessary, is better than just having it use up all your energy and fall over and seems a bit more realistic to me.

I have recently installed 235, if you say these values are close to what's stated now, I will try to do some testing and see what I get.

But also consider the "two-stage" system I'm proposing and tell me what you think.

Updated by Yuka about 5 years ago

.version.txt in ..\arma 2\@ACE\ claims 235

I played a long time yesterday and I was experiencing all sorts of, what I'd like to call problems, where I'd run maybe 100 meters and collapse and not be able to move for 5-10 minutes. And this was under a base combat load without a ruck on.

I know in real life after running 100 meters in a base combat load that I'd be out of breath and maybe have problems aiming my weapon in a stance higher than prone supported, but I know for a fact that I wouldn't collapse. I'd be able to stabilize myself and control my breathing after about 15 seconds enough to make a critical shot should I need to and get my breathing controlled and heartrate down enough to get up and move quickly again in less than 60 seconds.

I'm no PT stud either. I'm young but I'm definitely not a super PT stud around here.

Updated by Sickboy about 5 years ago

Aye, there have been improvements in past versions. Re evasive forward, 2 stage stuff; Have you considered actually using the Panic Button that is already included in the system? :)

Re collapse ingame versus no collapse in the realworld; There are only a few ways we can simulate Stamina in the game, please understand we have to work within these limitations ;)

Updated by Yuka about 5 years ago

Sickboy, totally understood about the limitations of the game. Do what you must.

Pyrodox posted on the BIS boards in the ACE2 thread a suggestion that I really like.

To sum it up, after sprinting/running and achieving the exhaustion point, the player slows to a run. (I'd suggest another stage of exhuastion where the player slows to a walk, if the game engine can do that.)

He also made mention of the ability to sprint past exhaustion but at the risk of collapse.

But going back to what I had said - I think the point of collapse comes too soon and the recovery from collapse-level exhaustion takes way too long.

Updated by Sickboy about 5 years ago

There is no way to our knowledge to lower (or change at all) a unit's speed in any reliable and cheap way.
The engine does limit the amount of time you can sprint vs normal run though.

Tweaks are ongoing.

Updated by Pyrodox about 5 years ago

I've done a bit of testing on the stamina issue, I'm getting some weird results. Is stamina based solely on weight?

There might be some bugs involved here.

I made a test mission on Utes, running down the middle of the runway. I used the rangefinder to confirm distances.

I'm using 75kg as a base, since someone has stated here before what they are capable of having actually carried that weight themselves.

I allowed 14kg for armor, helmet, uniform, etc. Leaving me with 61kg of weight to carry in my inventory.

Using the run key, not sprint, I was able to run about 350m with 61kg (plus 14kg theoretical "hidden" weight) totaling 75kg carrying 3 mines and 2 satchel charges and a GPS in my inventory.

Now, here's the weird part. When I carry 3 mines, a rangefinder, battery, a satchel charge, 4 claymores and 2 grenades, all totaling 61kg again (plus 14kg theoretical "hidden" weight, again, exactly the same weight stated in my inventory as the previous test totaling 75kg) I can only run 215m, again using the run key.

So, this brings to question, is the displayed weight and the weight used to calculate the stamina effects on the unit different based on gear, even though both sets of gear are displayed as weighing an equal amount?

Edited to add: Just did a little more testing, with 4 mines, a claymore, a rangefinder, a battery and a GPS totaling 61kg again I could run 260m. I also tried to "sprint" with the exact same loadout and I got 130m.

So:
61kg displayed, carrying 3 mines, 2 satchel charges and a GPS = 350m+ running before collapse
61kg displayed, carrying 3 mines, a rangefinder, a rangefinder battery, a satchel charge, 4 claymores, 2 grenades and a GPS = 215m running before collapse
61kg displayed, carrying 4 mines, a claymore, a rangefinder, a rangefinder battery and a GPS = 260m running before collapse

Updated by Sickboy about 5 years ago

Just a check, did you restart the mission in between your tests ? Cancel/Preview etc, afaik doesnt restart the mission, maybe there's some issue in this regard ?

The calculations are based on the weight, and on the class. Afaik SF are considered stronger. Machine gunners too.
Terrain (uphill = bad!), movement speed, etc too.

Updated by Pyrodox about 5 years ago

I did the tests using a standard USMC rifleman for every test.

From Editor I selected Preview, ran the test. Selected Suspend, went back into the Editor, selected Preview again, ran the test again.

I tested it a few times with each varying loadout, each one gives the same results when I switch to it. Maybe displayed weight for certain items is not the same as the weight being used in the calculations for the stamina system?

This was done on the flat runway in Utes with a target placed at 300m so I could use the rangefinder on it and a couple colored markers placed on the map along the runway so I could watch my progress as I ran down the runway on GPS.

I will try again completely exiting the game between each test.

Edited to add:

I just ran similar tests, exiting the game completely between each test.

61kg displayed, carrying 3 mines, a rangefinder, a rangefinder battery, a satchel charge, 4 claymores, 2 grenades and a GPS = 220m running before collapse
61kg displayed, carrying 4 mines, a claymore, a rangefinder, a rangefinder battery and a GPS = 280m running before collapse
One run gave me an strange result where the vision was blacking out but there was no collapse and I kept running.

Updated by Rommel about 5 years ago

Are you able to provide a mission (with team switch between those two units), and instructions to re-produce. And I will run debugging to find the reason as to that seemingly strange incident.

Updated by Pyrodox about 5 years ago

Mission I'm using is attached.

Just to be clear, I'm not switching between units. There is one unit on the map, I placed an ordnance crate and a special weapons crate next to the unit, I start the game, open the mission in the editor, click preview, take whatever loadout (I've been trying to take whatever loadouts I can from the crates to equal 61kg) and run (not sprint) towards the target which is 300m from the point at which the Rifleman starts.

Then, I exit the game completely, restart the game, go back into the Editor, open the same mission (no changes made in between) click Preview and run the test again with 61kg of weight added to the unit via a different loadout.

Each time I add enough equipment to the unit to equal 61kg of weight displayed in the Gear/Inventory screen of the unit. The only variable between runs is the gear I select from the crates to equal that amount.

Updated by Rommel about 5 years ago

This was my test data.

Data(1): 17s, 7m/s, 72.75kg, 4 Mines, Claymore, 5 Tripflares,
Data(2): 17s, 7m/s, 72.59kg, M240 (Full mags), Glock 18 (2 Mags)

theory_distance(1): 17s * 7m/s = 119m
theory_distance(2): 17s * 7m/s = 119m
actual_distance(1): ~122m
actual_distance(2): ~122m

Distance is assumed to be higher due to the stamina module cycle rate.

Unable to reproduce.


I suggest you watch the data yourself.
Put a trigger down with radio alpha, and the following in the on activation line:

ACE_STAMINA_DEBUG_MODE = true

A simple stop watch is suffice, and you should be able to record the speed and monitor the weight as well. Taking note the weight updates every 30 seconds.

Updated by Pyrodox about 5 years ago

Hmmm, I wasn't taking into account that weight is only calculated every 30 seconds. I was taking loadouts (different loadouts took different amounts of time to select into my inventory) and running... Possibly I was running "light" for a longer period of time with the loadouts which took less time to select into my inventory from the crates.

Updated by Rommel about 5 years ago

  • Status changed from In progress to Feedback

Any further feedback? Can I close this issue?

Updated by Rommel about 5 years ago

  • Due date changed from 01/27/2010 to 02/09/2010

Updated by rocko about 5 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF