Support #6966

Teamspeak keybinds stop working while fullscreen focus is on game with ACE2 mod enabled

Added by 1longtime over 5 years ago. Updated about 5 years ago.

Status:Expired Start date:12/15/2009
Priority:Low Due date:
Assignee:- % Done:

0%

Category:Complex
Target version:-
Component: Affected Version:
Close Reason:

Description

Initially, Teamspeak keybinds worked properly (combinations such as "LEFT CTRL + numpad 1" or "CTRL + H" or "LEFT ALT + numpad 5") during Arma 2 gameplay with ACE2 185 enabled, and had been working properly since early release. After updating to 186 and starting Arma 2 with ACE 2 186 enabled, I noticed all Teamspeak keybinds were failing. The only TS key that worked was a single key (LEFT CTRL) which I used as push-to-talk. All keybinds (under Teamspeak's Settings -> Key Settings menu) failed but ONLY while fullscreen focus in Arma2 with ACE2 enabled. I attempted many keybinds (even just single-key keybinds, such as "Q" to switch to a specific TS channel).

I alt-tabbed out of game and ALL keybinds worked properly again (every combination, single, double, and three-key-combinations using any key on the keyboard... in short, expected behavior from TS). Keybinds worked even with the Teamspeak window out of focus or minimized (also expected behavior from TS). When I maximized back into Arma 2, the keybinds seemed to be "swallowed" by the game again.

I exited Arma 2 and started the game without ACE 2 enabled, and all Teamspeak binds worked properly as before. I tested this several times (launching again with ACE2 186 and also ACE2 187 and without) and ---this problem only occurred when ACE2 186 was enabled.---

I rebooted my computer and the entire problem was resolved. Keybinds were no longer "swallowed" by the game, even when ACE2 186 and 187 were enabled. (why???)

NOTES:
1) I only had an opportunity to test this with ACE2 186 and 187. The problem did not exist when I used 185, but I could not obtain 185 to re-test when my machine was in the "bad" state. Another player reported the same problem with 185 however.
2) I have a USB keyboard on Windows 7, and I have several other USB accessories (TrackIR, two joysticks). I have experienced zero USB problems for several months and not performed any significant OS changes recently.
3) At least one other player has reported this problem as well, simply saying "i have a problem with some of the key binds that do not work" with no apparent reason behind it. That player was using 185 at the time. I don't know his keyboard type or OS right now.
4) Although the reboot solved the issue, I rarely reboot my computer. It is not unusual for my computer to run for weeks at a time. It had been running without reboot during several other ACE2 updates without any problems with TS keybinds.

Please advise if there is further information needed. I will add info if this occurs again. This bug is difficult to report because the behavior is so odd and because it self-corrected after a computer reboot, but because it is clearly specific to ACE2 and has been experienced by at least one other person, it seemed appropriate to report.

History

Updated by 1longtime over 5 years ago

CORRECTION:

---this problem only occurred when ACE2 186 was enabled.---

...should read...

---this problem only occurred when ACE2 186 and 187 were enabled.---

Also, I want to stress that Arma2 vanilla 1.04 did NOT have this problem. I could start with/without ACE2 enabled and the problem would disappear/reappear. Restarting Teamspeak had no effect, the problem continued whenever Arma2 was started with ACE2 enabled.
After the "reboot fix" the problem has not been reproduced. I will watch and see if it reproduces spontaneously (since it occurred spontaneously).

Updated by rocko over 5 years ago

  • Target version set to 395

Updated by rocko over 5 years ago

  • Category set to Complex
  • Status changed from New to Feedback
  • Assignee set to ViperMaul
  • Priority changed from Normal to Low

Updated by rocko about 5 years ago

  • Tracker changed from Bug to Support

Updated by rocko about 5 years ago

  • Target version deleted (395)

Updated by 1longtime about 5 years ago

Still occurs with ACE 205. No other mods enabled.

Many players now experience this. The current fix is to launch outside applications with "Run as administrator" permissions in Windows 7. Then, keybinds for the outside applications are not "swallowed" by Arma2/ACE.

Updated by tcp about 5 years ago

Not to say that ACE isn't aggravating the problem (although it seems unlikely), but this is a known issue for voice chat programs in many games not just ArmA2. Many people disable UAC to get rid of the problem.

Updated by Sickboy about 5 years ago

It should be unrelated to ACE. If it is related to anything it is related to the Six Updater Suite, and the fact that this software runs in Administrator Mode, and thus when running the game (through the updater) you run it also on Administrator Mode.

Workarounds are: Use your own launching way of ArmA, without admin mode. Or run your voice software as Admin.

Updated by rocko about 5 years ago

  • Assignee deleted (ViperMaul)

Updated by rocko about 5 years ago

  • Status changed from Feedback to Expired

Also available in: Atom PDF