Support #6946

CutRsc use in ACE2 interferes with pvp scriptpack

Added by sbsmac over 5 years ago. Updated over 5 years ago.

Status:Rejected Start date:12/14/2009
Priority:Normal Due date:
Assignee:ViperMaul % Done:

0%

Category:-
Target version:-
Component: Affected Version:
Close Reason:

Description

I've had a report (though not yet verified) that the HUD in my scriptpack disappears after a player respawns when ACE2 is active.

I'm assuming that ACE2 using using cutRsc (perhaps for respawn/revive options?) which is clobbering my own rsc.

Can anyone confirm this?

If so, what is the preferred way to work around this and make sure the two co-exist ? One possibility would be to look for the 'unload' event but there doesn't seem to be a clean way of ensuring that rscs don't clobber each other.

History

Updated by Sickboy over 5 years ago

  • Assignee set to ViperMaul

Updated by Vigilante over 5 years ago

How about naming your namespace variable not 'HUD' but something else?
and using unload with it wont hurt i guess too.
1 class VIG_Javelin_RscGUI 2 { 3 idd = -1; 4 movingEnable = 0; 5 duration = 9999999; 6 fadein = 0; 7 fadeout = 0.06; 8 9 name = "VIG_Javelin_RscGUI"; 10 11 // any idd under RscTitles is invisible to getDisplay, but: 12 onLoad = "uiNameSpace setVariable ['VIG_Javelin_RscGUI', (_this select 0)]"; // Assign display handle to global 13 onUnload = "uiNameSpace setVariable ['VIG_Javelin_RscGUI', displayNull]"; // Assign display handle to null 14 ...etc...

Updated by rocko over 5 years ago

ACE2 is using layered cutRsc.

Also need more info what HUD rsc you are referring to. And other circumstances if possible.

Updated by sbsmac over 5 years ago

Here's the report from my tester...

"Only the HUD disappears after you respawn the first time and stays off throughout the rest of your lives."

The hud is a resource called "scoreRSC" which is usually loaded only once at the beginning of the game. Onload code is ...

onLoad = "uiNamespace setVariable [""HUD"", _this select 0];

The resource is loaded with

cutRsc ["ScoreRsc","PLAIN"] ;

I've seen a similar problem when using the BIS halo code which also uses cutRsc to blank the screen temporarily.

Hooking the unload event doesn't seem like a great solution since there is no way to know when the over-riding rsc (assuming that is the cause) has itself unloaded.

I'll try downloading the mod and see if I can reproduce this.

Updated by rocko over 5 years ago

You should use layering aswell, to prevent accidental closing/overwriting.
ACE2 layers start with 135 (1 = A, 3 = C, 5 = E) and then an individual number from 00 to 99.

Updated by sbsmac over 5 years ago

Thanks, will give this a try.

Updated by rocko over 5 years ago

Solved?

Updated by rocko over 5 years ago

  • Status changed from New to Rejected

Also available in: Atom PDF