Task #6738

TEST: Server-Side Performance (I.E. Server-Side FPS etc)

Added by ViperMaul about 5 years ago. Updated about 5 years ago.

Status:Closed Start date:12/09/2009
Priority:High Due date:01/25/2010
Assignee:Rommel % Done:

90%

Category:Review
Target version:1.0.1
Component: Affected Version:
Close Reason:

Description

Now to properly test server performance for our needs we need the server to have the following MOD line and in the following recommended order.

-MOD=@cba;@ace;@acex
or
-MOD=beta;@cba;@ace;@acex

Now if you still have what you believe is valuable feedback but do not have the exact mod lines here please share it and list your MOD line. Any feedback will be helpful.

Here is some recent feedback we received from Xeno

[3:46:43 PM] Xeno: played air cav, server was running with 15-20 FPS with about 30-40 players
but suddenly the server crashed
and performance dregades during a mission, haven't seen that before 
when playing just with a few people (up to 20) on  a closed server

If the feedback was Server running 15-20 FPS with 50+ players or 10 FPS with 80+ players I would be much happier.

However Server running 15-20 FPS with 30-40 players, seems to deserver some investigation.

We Need the following info along with your summary

Server Side FPS:
Number Of Players:
Server MOD Line Used:
Mission Attached or Identified:

Any other helpful information you can give us.


Related issues

related to A.C.E. for OA - Bug #7039: Servers and Clients crashing lately Closed 12/16/2009

History

Updated by ViperMaul about 5 years ago

  • Target version changed from 0.6 to 0.9

Updated by ViperMaul about 5 years ago

  • Target version changed from 0.9 to 1.0.0

Updated by mrmookie about 5 years ago

Have noticed recent server degradation after about 8 AO's are completed in Domination ACE.. FPS drops in the single digits until restart of the mission.

Updated by rocko about 5 years ago

  • Due date set to 01/25/2010
  • Category set to Review
  • Status changed from New to Assigned
  • Assignee set to ViperMaul
  • Priority changed from Normal to Urgent

Updated by rocko about 5 years ago

  • Assignee deleted (ViperMaul)

Updated by Sickboy about 5 years ago

  • Target version changed from 1.0.0 to 1.0.1

Updated by Sickboy about 5 years ago

  • Status changed from Assigned to Feedback
  • % Done changed from 0 to 20

How is this with the most recent updates?

Updated by Sickboy about 5 years ago

  • Assignee set to Rommel

Updated by Rommel about 5 years ago

Large performance loss related issues concur with the presence of particular BIS modules. Try and keep 3rd party (ie non complex scripting efforts such as Domination) out of the picture, so it can be purely related to game play which is related to the ACE2 mod...

Updated by Sickboy about 5 years ago

  • % Done changed from 20 to 80

Updated by Lt.Chris about 5 years ago

We will be doing a test with about 50+ people on sunday on with server signature and strictly only allowing the following
@CBA
@ACE
@ACEX
@ACEX_PLA

The mission itslef is very simple so there wont be any real scripting involved, will post rpt if it crashes and that hopefully may narrow down the problem

Updated by Sickboy about 5 years ago

Lt.Chris wrote:

We will be doing a test with about 50+ people on sunday on with server signature and strictly only allowing the following
@CBA
@ACE
@ACEX
@ACEX_PLA

The mission itslef is very simple so there wont be any real scripting involved, will post rpt if it crashes and that hopefully may narrow down the problem

Awesome, thank you very much!

Updated by Rommel about 5 years ago

Ran server for three hours still no crash. Consistent play with around 12 players. No errors other than client side ones which were resolved in upcoming ACE2 patch, they were desync causing.
Server is running at high framerate (around 39 consistently).

Mods(loaded on server): @CBA;@ACE;@ACEX;@AAW
Allowed Signatures: DFS;SAP;acex_b188;LandTex_2009_08_17;acex_sm_b19;NST;TRSM;ibr;ARD;ace_b243;AAW;bi;SAH;acex_b182;at;CSM2;FRAN;six_sap_clutter;cba_b68;lang_de-en

Updated by pufu about 5 years ago

confirms for KH.
I had a small game yesterday (after almost 2 months without touching A2), and the server performance seemed way way better, including JIP connections. Didn't feel the need to keep the server locked anymore. Xeno was there as well, he can confirm it

30 players average
1 connection/disconnection per minute average

Updated by Rommel about 5 years ago

  • Priority changed from Urgent to High
  • % Done changed from 80 to 90

3 Hours. 14 Players. No crash; only desync issues sorted in upcoming patch. Server framerate low 40's high 30's.
Same ad dons as previous.

Updated by Lt.Chris about 5 years ago

outcome of play

40ish players no crash, no desync or any issues whatsoever, this looks like theres an addon out there combined with ace which can cause crashes, we will start doing an elimation now of what "evil" addon could be doing this

Updated by Xeno about 5 years ago

Nice to hear.

Please let us know what addon or which addons cause problems.

I think we can close this ticket now.

Stability and performance are greatly improved.

Well done!

Updated by Sickboy about 5 years ago

  • Status changed from Feedback to Closed

Awesome news indeed! Thanks for the tests and results!
And props to the team for the performance and stability :)

Closing, but feel free to let keep us updated on your progress! Thanks again.

Also available in: Atom PDF