Bug #6638

Fix SetMimic command

Added by UgolSkosa over 5 years ago. Updated about 2 years ago.

Status:Closed Start date:12/08/2009
Priority:Normal Due date:
Assignee:Dwarden % Done:

50%

Category:Scripting: Problem
Target version:1.60.87580
Affected ArmA II version:1.60 BETA First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using:OA only BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Obs
SetMimic command is broken since the first version of arma2.

Exp
It's very useful command for cutscenes. I often used it in OFP and arma1.
And now I can't use close-up in cutscenes, because all characters stay with "stone" face.

Notes
SetMimic is not so important command from one hand (i see there are very important AI behavior in last patches),
but from other hand setMimic very important for cutscenes and therefore important for quality campaigns.

Repro
ftp://www.armedassault.info/_hosted/otk/test/mimic.utes.rar

There are player and unarmed bot with name sol
and 3 triggers with radio (0-0-1, 0-0-2, 0-0-3)

  • 0-0-1 - hurt mimic just by trigger (sol setMimic "hurt")
  • 0-0-2 - hurt mimic by sqf (null=[sol,"hurt"] execVM "mimic.sqf")

mimic.sqf

1 _unit = _this select 0;
2 _mimic = _this select 1;
3 _unit setMimic _mimic;

  • 0-0-3 - hurt mimic by FSMscripted (null=[sol,"hurt"] execFSM "hurt.fsm")
    sqf like code

sol stay with stone face until you kill him
and only after that you can see death mask on his face

I tried all mimics not only "hurt".

mimic.utes.rar (1.9 kB) Fireball, 12/08/2009 12:28

History

Updated by Fireball over 5 years ago

  • Due date set to 01/08/2010
  • Status changed from New to Assigned
  • Target version deleted (1.04.59026)
  • Affected ArmA II version changed from 1.05 BETA to 1.04.59026

Updated by Fireball over 5 years ago

Updated by zGuba over 5 years ago

  • Operating system deleted (WinXP 32 bit)
  • Reproduced by another DH user changed from No to Yes

Updated by Fireball about 5 years ago

  • Due date changed from 01/08/2010 to 02/08/2010
  • Affected ArmA II version changed from 1.04.59026 to 1.05.62017

Updated by Fireball about 5 years ago

  • Due date changed from 02/08/2010 to 03/08/2010
  • Assignee set to Luca

Updated by kju over 4 years ago

  • Due date changed from 03/08/2010 to 10/01/2010
  • Status changed from Assigned to Feedback
  • Assignee deleted (Luca)

Updated by kju over 4 years ago

  • Due date changed from 10/01/2010 to 12/01/2010
  • Status changed from Feedback to Assigned
  • Affected ArmA II version changed from 1.05.62017 to 1.52.71816

Updated by kju over 4 years ago

  • Affected ArmA II version changed from 1.52.71816 to 1.55 BETA

Updated by Undeceived over 4 years ago

Undeceived setMimic "Sad";

It still is not fixed in 1.56. Waiting for this since Arma 2 1.0...

Updated by kju over 4 years ago

  • Due date changed from 12/01/2010 to 02/01/2011
  • Assignee set to Dwarden
  • Affected ArmA II version changed from 1.55 BETA to 1.56.76134
  • I am using set to OA only

Updated by BigDawgKS over 4 years ago

It seems setFaceAnimation doesn't work either (in 1.55 at least); as a matter of fact characters don't appear to ever blink anymore...

Updated by Undeceived over 4 years ago

It continues not working with patch 1.57.

Updated by kju over 4 years ago

  • Due date changed from 02/01/2011 to 03/01/2011
  • Affected ArmA II version changed from 1.56.76134 to 1.57.76815
  • Reproducible for you changed from No to Yes

Updated by Denisko-Redisko over 4 years ago

Now in arma2 used a full skeletal facial animation: "CfgHeads" >> "Default" >> "Grimaces":

        class Grimaces {
            class Eyes {
                type = "eyes";
                eyeMaxAngle = 0.5;
                eyelidUpStartAngle = 0.5;
                eyelidUpMaxAngle = 0.7;
                eyelidDownStartAngle = 0.25;
                eyelidDownMaxAngle = 0.3;
            };

            class Lipsync {
                type = "lipsync";
                vizem[] = {"ca\characters\Heads\Data\RTM\Neutral.rtm", "ca\characters\Heads\data\RTM\vizem\a.rtm", "ca\characters\Heads\data\RTM\vizem\e2.rtm", "ca\characters\Heads\data\RTM\vizem\f.rtm", "ca\characters\Heads\data\RTM\vizem\m.rtm", "ca\characters\Heads\data\RTM\vizem\y.rtm", "ca\characters\Heads\data\RTM\vizem\v.rtm", "ca\characters\Heads\data\RTM\vizem\i.rtm"};
            };

            class RTM_Face {
                type = "rtm";
                anim = "ca\characters\Heads\Data\RTM\Neutral.rtm";
            };

            class NeutralFace : RTM_Face {
                anim = "ca\characters\Heads\Data\RTM\Neutral.rtm";
            };

            class DeadFace : RTM_Face {
                anim = "ca\characters\Heads\Data\RTM\Dead.rtm";
            };

            class DangerFace : RTM_Face {
                anim = "ca\characters\Heads\Data\RTM\Danger.rtm";
            };

            class HurtFace : RTM_Face {
                anim = "ca\characters\Heads\Data\RTM\Hurt.rtm";
            };

For example, DeadFace used for dead soldiers, and it looks much better than earlier in OFP.
All we need is to make available these animations for our scripts. Why hasnt it been done so far?

Updated by Danil-ch almost 4 years ago

Still true in 1.59

Updated by Fireball almost 4 years ago

  • Due date changed from 03/01/2011 to 08/05/2011
  • Affected ArmA II version changed from 1.57.76815 to 1.59.79384

Updated by Suma over 3 years ago

  • Status changed from Assigned to Resolved

The repro steps are way below expected quality for such a high voted issue (terrible formatting, hard to read). Fortunately they contain all necessary information.

Resolved in 83085

Acceptable mimics are:
"neutral", "dead", "danger", "hurt", "aware", "safe", "combat"

Updated by zGuba over 3 years ago

  • Target version set to Upcoming version

Updated by Dwarden over 3 years ago

  • Status changed from Resolved to In progress
  • % Done changed from 0 to 50

according to forums this fix resolved the bug only for black faces and not rest, can anyone confirm ?

Updated by Danil-ch over 3 years ago

i can confirm SetMimic work only with black face.
For all others only work Mimic "dead".

Updated by Li0n over 3 years ago

Agree

Updated by kju over 3 years ago

  • Description updated (diff)
  • Due date changed from 08/05/2011 to 11/01/2011
  • Affected ArmA II version changed from 1.59.79384 to 1.60 BETA
  • CPU deleted (Please specify!)
  • Audio card deleted (Please specify!)
  • Size of OS swap file deleted (Please specify!)

Updated by Suma over 3 years ago

  • Status changed from In progress to Resolved

i can confirm SetMimic work only with black face.

The problem is unfortunately data side this time, with the skinning of the white head models. I am afraid this is something we will not fix for A2/OA, as it is not game breaking enough.

Updated by kju over 3 years ago

  • Due date deleted (11/01/2011)
  • Status changed from Resolved to Closed
  • Target version changed from Upcoming version to 1.60 BETA

Alright. Thanks for looking into it and the info Suma!

I guess people will be happy, if you manage to get it working for all units in arma 3 again.

On a sidenote:
It could be useful for the modding community to learn what the important parts
in the skinning of models to get it working for their work.

Updated by kju about 3 years ago

  • Target version changed from 1.60 BETA to 1.60.87580

Also available in: Atom PDF