Bug #6476

AIs get stuck on the "Danger" setting (\+7+2)

Added by Nimrod almost 6 years ago. Updated over 4 years ago.

Status:Closed Start date:12/04/2009
Priority:Normal Due date:
Assignee:- % Done:

90%

Category:AI Issues
Target version:1.55.75445
Affected ArmA II version:1.52.71816 First affected build:
Reproduced by another DH user:No First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:No NGUrl:
Related to content of DLC: WIKIurl:

Description

Version ARMA2_Build_60718

Once you order them "Danger" (\+7+2), they don't take any other behaviour orders you give them. They get stuck in "Danger", even after they died and you call new soldiers, they spawn stuck in the "Danger" behaviour.

Repro.JPG (176.2 kB) Nimrod, 12/04/2009 06:32


Related issues

related to ARMA2 Community Issue Tracker - Bug #6601: AIs go in Combat Mode even if only their leader or a spli... Assigned 12/07/2009 10/28/2011

History

Updated by Nimrod almost 6 years ago

Updated by Nimrod almost 6 years ago

update: they don't get stuck, it only takes a lot of time for them to switch to new behaviour, even if they are not in combat zone - means engaged.

Updated by MadDogX almost 6 years ago

  • Status changed from New to Feedback
  • Target version set to Upcoming version
  • % Done changed from 0 to 100

Apparently this was fixed in beta 60819.

Updated by kju almost 6 years ago

  • Due date set to 12/11/2009
  • Category set to AI Issues
  • Target version changed from Upcoming version to 1.05 BETA

Updated by Nimrod almost 6 years ago

sorry the build is 60803! Will report after 60819!

Updated by Suma almost 6 years ago

  • Status changed from Feedback to Resolved

Updated by kju almost 6 years ago

  • Due date deleted (12/11/2009)

Updated by Nimrod over 5 years ago

Fixed, confirmed!

Updated by Fireball over 5 years ago

  • Status changed from Resolved to Closed

Induced by BETA, fixed in BETA. Closing on confirmation.

Updated by Nimrod over 5 years ago

Sorry but i have to report that the bug has been "half" fixed.
Buy some troops. Send them in a clear area.
Place urself in a war zone, with your AIs miles away.
As you get fired upon, the AI will auto-start their "danger" behaviour, even if they are in a clear-of-enemy area and obiouvsly not engaged.
Latest version 60899 used, in Warfare BE 0.49.

Updated by kju over 5 years ago

Nimrod please create a new ticket for this.

Updated by Fireball over 5 years ago

  • Due date set to 12/24/2009
  • Status changed from Closed to Assigned
  • Assignee set to Suma
  • Target version deleted (1.05 BETA)
  • % Done changed from 100 to 0

Unfortunately I see this still happening to the worst, that they do not ever fall back into aware mode anymore. It happened after disembarking from a chopper and then they engaged an enemy AI group in the forest.

The enemy was long cleared, when I went out to help capturing the town and my AI squad remained in the forest not responding to any status change order (i.e. Aware) or to rejoin formation.

Worse even, the AI tends to just heed what ever they think is right and run off. Maybe few of them thought the gunner remaining in the chopper was their leader or something, but there was no clear indication whatsoever.

The video was taken after I returned to the wood to check (i.e. they were already in danger mode for a long time):

http://www.youtube.com/watch?v=YseHFaa-cEE

Updated by Fireball over 5 years ago

Two bugs in one.

Found out about the reason why few of my guys were running away from me, when I ordered them back in formation, ticket #6728.

Now I still need to find out why they got stuck in danger mode.

Updated by Fireball over 5 years ago

  • Status changed from Assigned to Feedback
  • Assignee deleted (Suma)

Can't repro so far.

Updated by Fireball over 5 years ago

Ah yes, I think I've found it out, but I can't figure out how to reproduce it:

- my squad spots a soldier of the enemy squad (of course others too, but that one is important)
- during the fire-fight that enemy soldier panics and runs away
- my squad is stuck in danger mode, even if I tell them to be 7-3 (Aware)

Updated by Nimrod over 5 years ago

they still get stuck in the combat behaviour.

Updated by Fireball over 5 years ago

Nimrod wrote:

they still get stuck in the combat behaviour.

Can you provide a way to repro it?

Updated by Luca over 5 years ago

  • Status changed from Feedback to Assigned
  • Assignee set to Luca

Updated by Nimrod over 5 years ago

Fireball wrote:

Nimrod wrote:

they still get stuck in the combat behaviour.

Can you provide a way to repro it?

oh well, like in the other thread
A2 Community Issue Tracker - Bug #6601
If u are in warzone, let's say, in elektrozavodsk
call in some troops, the enemy is attacking in huge number
you defend the city, the enemy retreats, and when it seems all clear (\+2=no objectives/contacts on the list), they still behave in combat mode.
you search around, 500 mtrs area, obviously finding nothing, and they keep that mode.
Sometimes they say "clear", but when they don't...
I can imagine my soldier can "smell" an enemy AI stuck in some building, hard to find for myself, and still no signs of it in the \+2 (targets) menù, so how to solve that?
have to embark 'em in a truck and get away.

Updated by Nimrod over 5 years ago

probably AIs can see through walls and buildings because of some "alpha channel" badly modeled? just throwing my 2 cents...

Updated by Fireball over 5 years ago

Nimrod wrote:

probably AIs can see through walls and buildings because of some "alpha channel" badly modeled? just throwing my 2 cents...

Then you'd see the targets listed.

Updated by Nimrod over 5 years ago

damn right...mmmm

Updated by Fireball over 5 years ago

  • Due date changed from 12/24/2009 to 01/24/2010
  • Affected ArmA II version changed from 1.05 BETA to 1.05.62017

Confirming as of todays game, this still happens when enemy units are retreating alive. It took my group at least half an hour until my 2nd said "Clear".

Updated by Fireball over 5 years ago

  • Due date changed from 01/24/2010 to 02/24/2010

Updated by Undeceived over 5 years ago

I can confirm this! It is very very annoying...

It is especially frustrating and deadly when you e.g. want to leave a combat zone quickly with your group. It happened to me twice in the last days on different missions, the AIs stay in "Combat" status (7-2). You can put them as "Aware" (7-3) as much as you want (or any other status). You can tell them "No target", "Look at that position [the way out of the combat zone]!", "2, move to XY!", etc. It doesn't work. They stay stuck in the combat mode and move (as slow) like this.

If I am right, the AI switches to "Combat" mode when fired upon (or maybe even if an enemy AI gets the command to attack?). But what if e.g. I save hostages and need to move out of the area of operation quickly, even if under enemy fire? The mission I played* was like this. I ordered the group to retreat in "Aware" mode (7-3) but they didn't switch to that mode but stayed in "Combat", which prevented me to finish the mission properly (all died under enemy fire, instead of retreat).

The other mission I played where this happened was the mission "Operation Cobalt" in the so called campaign. My group even wasn't under fire anymore for more than 10 minutes. But they remained stuck in the "Combat" mode (7-2)...

Is there any solution for this?

*Mission is called "Crash and Grab -> http://www.armaholic.com/page.php?id=8682
I only use the 1.05 final version, not the most updated beta. Sorry...

Updated by kju over 5 years ago

I am not sure if the beta improves/fixes it.
It is certainly worth a try though.

Updated by kju about 5 years ago

  • Due date changed from 02/24/2010 to 10/01/2010
  • Status changed from Assigned to Feedback
  • Assignee deleted (Luca)
  • Audio card set to Please specify!
  • Size of OS swap file set to Please specify!
  • I am using some Mods set to No
  • Reproducible for you set to No

Any difference in latest OA?

Updated by Fireball about 5 years ago

  • Status changed from Feedback to Assigned
  • Affected ArmA II version changed from 1.05.62017 to 1.52.71816
  • Reproduced by another DH user changed from No to Yes

Nope still an issue, unfortunately.

Updated by Fireball about 5 years ago

  • Status changed from Assigned to Feedback
  • Reproduced by another DH user changed from Yes to No

Sorry, confused the issue with another.

Updated by Fireball about 5 years ago

  • Due date changed from 10/01/2010 to 09/15/2010
  • Status changed from Feedback to Resolved
  • Target version set to 1.55 BETA

Fixed with latest BETA; AI calls out "Clear" much quicker now.

For anything else ticket #12895 still applies.

Updated by kju almost 5 years ago

  • Due date deleted (09/15/2010)

Please confirm fixed.

Updated by Dwarden almost 5 years ago

  • % Done changed from 0 to 90

Updated by Undeceived almost 5 years ago

Fireball wrote:

Fixed with latest BETA; AI calls out "Clear" much quicker now.

Yes, I noticed that too.
But what if the area is NOT clear and you need to move your squad out quickly?

Updated by Fireball almost 5 years ago

Well let's say, the "stuck" issue was part feature, part bug. To definitely resolve the problem with AIs not moving out quickly enough we need #12895.

Updated by kju almost 5 years ago

  • Target version changed from 1.55 BETA to 1.55.75445

Updated by kju over 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF