Bug #6472

Eliteness 2.60 does not start with DePBO.dll 2.70

Added by Trexian almost 6 years ago. Updated over 5 years ago.

Status:Closed Start date:12/03/2009
Priority:High Due date:
Assignee:mikero % Done:


Target version:Completed
Affected Version:


Installed by un-raring Eliteness 2.60 and DePBO 2.70 into separate folders. Copy DePBO into Eliteness folder.

Issue: Eliteness doesn't start. Get this error, that "The procedure entry point ?strError@DePbo@@QAEPBDXZ could not be located in the dynamic link library DePbo.dll." as shown in the below-referenced file

Workaround: Eliteness 2.60 with DePbo 2.41 and it at least opens and appears to work.

System: working on Windows XP without admin rights.

Eliteness260.jpg - jpg of the error message (30 kB) Trexian, 12/03/2009 16:42

Eliteness261files.jpg - Eliteness folder (151.3 kB) Trexian, 12/04/2009 16:05


Updated by kju almost 6 years ago

  • Status changed from New to Assigned
  • Priority changed from Normal to High

Thanks for the post Trexian! :)

Updated by mikero almost 6 years ago

  • Status changed from Assigned to Resolved
  • Target version set to Completed


thank you for the detailed reply.

fixed at 2.61

Updated by Trexian almost 6 years ago

No problem! :)

Thanks for such a wonderful suite of tools! ===================
Sorry, perhaps the error is on my side, but E2.61 doesn't start with either DePbo 2.7 or 2.71. Now, the difference is that I get the more generic error that the application configuration is incorrect and to try reinstalling Eliteness, as if it doesn't recognize the dll or something. Using the 2.41 dll now gives the same error.

The installation was still just un-raring to folders, copying the dll to the Eliteness folder. Believe me- I could easily screw something up as simple as that. :)

MD5s (in case I got corrupt versions?) are:
Eliteness 2.61: a3f5b29b43b6f5ba06102de2401ee33b
DePBO.dll 2.71: dfe35dd29a4f94af92f5a380f7b9ad07

Updated by Trexian almost 6 years ago

Sorry to spam, but I just found the util GetDePboVersion (1.53) and ran it. It confirms that I'm using 2.71 with E2.61.

(And ZOWIE there are alot of tools around here I'm only now realizing the importance of!)

Updated by kju almost 6 years ago

Works here (XP32b):

GetDePboVersion.exe Version 1.53, Dll Version 2.71

MD5: DFE35DD29A4F94AF92F5A380F7B9AD07
SHA-1: EF138D4082D7B86908B6D4D6F350D87FD6CB614C

v2.61 for eliteness.

CRC32: 7F67D218
MD5: A3F5B29B43B6F5BA06102DE2401EE33B
SHA-1: 120733DCA8B099E90EFF3DC2762A625B3C56A397

Do you have the dll in the same folder?
If so make sure, you have no outdated dll in system32.

Updated by Trexian almost 6 years ago

Same MD5s, have dll in same folder, double checked nothing in system32. Attached a pic of the folder.

Any chance that admin privs are required? I don't have them on this machine. I guess another thing is that I'm running it from a USB drive. Wasn't a problem in the past, so I didn't mention it.

Also - WinXP Pro 32b.

Updated by kju almost 6 years ago

  • Status changed from Resolved to Feedback

Mikero any idea?

Updated by mikero almost 6 years ago

umm. Plank reported what sounds like a v similar issue in an earlier release of Eliteness. It is something to do with vista (eg) registering the fact that the new version has changed, and (i think) it has still associated the older eliteness with certain file types. There is an (almost) indecipherable system notice about it from Msoft, but I know nothing more. Perhaps you've associated .pbo's (eg) with Elite? Perhaps that, or simtjhing similar is the issue?

Updated by Trexian almost 6 years ago

Have gone through the XP registry, and found more references to pbo and eliteness than I thought I would! This includes one association of pbo to some other things that I don't recall making, and that didn't show up in the File Association list. Reboot.

Same problem as most recent - the generic error.

If it helps, Eliteness 2.51 with dll 2.41 still works. But, dll 2.54a causes it to have the same error as in the original post. But, E2.61 with dll 2.41 has the more generic error that it is not configured properly.

Not sure if that really helps, or if it is worth you spending time on. I will try it at another computer this weekend (with admin privs) and see what happens.

Updated by Trexian almost 6 years ago

Guys - sorry about this.

Tried it here at home, and it works just fine.

I wonder if it is an issue with admin privs. (Damn those IT people for not trusting ME!) :) But, that is beyond the scope of what you can address.

Thanks for a great tool!

Updated by mikero over 5 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF