Bug #6471

AI too slow to get to cover when ordered "take cover"

Added by Bouben over 7 years ago. Updated over 4 years ago.

Status:Closed Start date:12/03/2009
Priority:Normal Due date:
Assignee:Dwarden % Done:

0%

Category:AI Issues
Target version:1.59.79384
Affected ArmA II version:1.57.76815 First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Repro 1 - Bouben:

1. Load mission "Reproduction_20TAKE_20COVER"
2. Your squad is holding fire and is set behind an unaware enemy soldier.
3. Simply select "all" and "take cover" and watch what will happen.

Repro 2 - Fireball

1. Load mission "CIT_6471_OATakeCover"
2. Hit Space, 1-8
3. Run for your own cover (waypoint)
4. Watch your men struggle and die

Video showing the repro:
http://www.youtube.com/watch?v=pguQ0n0rbX8

Observed
They are slow, that's the first thing you should notice. They are somehow "bounding" and very often changing position. Also they fail to get to cover in time, resulting into many losses.

Expected
They should scramble to nearby cover without using the bounding overwatch and later switch to Danger mode, when they reached their cover posits.

---
Further Notes
AI use danger mode while given order to TAKE COVER. Because of that is the AI very slow in process of taking up their covered positions.

While the priority of taking cover is actually to take cover, and not to perform bounding overwatch and scaning of enviroment, the AI should run very quickly (!) to cover practically without care of enemy presence and incoming fire - immediately after the order has been given. Then, when AI is behind some obstacle (crouched behind wall, sticking out from house corner, prone behind rocks...etc) then they can start taking care of enemy itself and actually start fire. BUT NOT BEFORE THEY HAVE SOME PROPER COVER.

To make it more simple, there is a suggestion how to solve this problem:

AI should perform taking cover in practically (!) CARELESS mode instead of COMBAT/DANGER mode. This should lead to AI quickly running behind cover. All of that WITHOUT any stopping in movement (!), waiting, observing and bounding. Then, when AI is already in cover the COMBAT mode is activated again which is then truly desirable and AI can continue fighting an enemy.

Reproduction_20TAKE_20COVER.utes.pbo - reproduction mission (3 kB) Bouben, 12/03/2009 20:05

CIT_6471_OATakeCover.Desert_E.zip (1.6 kB) Fireball, 08/08/2010 10:04

History

Updated by dvolk over 7 years ago

I agree.

I'd like to add that when ordered to heal or mount a vehicle, they should do it in safe or aware mode.

There's nothing quite as dumb as a soldier who runs back and forth, proning, scanning, etc. when you just want him to heal or get in a car.

Updated by Bouben over 7 years ago

Yes, very similar problem.

Updated by kju over 7 years ago

  • Due date set to 12/10/2009
  • Status changed from New to Feedback
  • Priority changed from High to Normal

Updated by Bouben over 7 years ago

While a lot of people had a problem to understand in full details, what problem it actually is, I think, that text is minimal already. No offense.

I am afraid, that someone (in the worst case developers) could omit the problem's quite big relevancy otherwise.

Updated by Suma over 7 years ago

The fact the text is quite long is minor problem compared to the fact the repro is missing. I can always ignore the text if it is too long, but I cannot follow and debug repro when it is not there.

Updated by Bouben over 7 years ago

There you go, reproduction mission for you.

1. Your squad is holding fire and is set behind an unaware enemy soldier.

2. Simply select "all" and "take cover" and watch what will happen.

They are slow, that's the first thing you should notice. They are somehow "bounding" and very often changing position. They are simply behaving as I have written in details in the description.

Updated by zGuba over 7 years ago

  • Reproduced by another DH user changed from No to Yes

Reproduction up - I'll try it.

Updated by Bouben over 7 years ago

Yes, but honestly I think, that here is the reproduction mission just a formality because issue is 100% reproducable in every situation, in every mission at every time.

Updated by Bouben over 7 years ago

I just hope that it is not intentional behaviour because it really spoils gameplay and AI often lose their lifes for nothing.

Updated by zGuba over 7 years ago

This is very true, checked with beta 60819. I wonder though if we shouldn't have another command ("hide") instead, unless "Take cover" is ment to make our subordinates completely hidden from enemy.

Updated by Bouben over 7 years ago

Well, be it so, but there would be still the problem with an AI seeking for cover slowly and brokenly. IMHO essential is to solve their speed and prevent them from running around like frightened chickens which are always dissatisfied with their cover. They should take cover and totally hold their safe positions unless an enemy is flanking them or something like that. If you have proper cover, then there is no need to change it. You know what I mean.

Updated by Fireball over 7 years ago

  • Due date changed from 12/10/2009 to 12/24/2009
  • Status changed from Feedback to Resolved
  • Target version set to 1.05 BETA

This was changed according to discussion in BI forums, please confirm.

Updated by Bouben over 7 years ago

I am sorry to say that, but the problem has not been resolved at all and therefore is still actual. Tested with beta 61062.

AI looks smoother a little bit, but they are still very slow and often changes their good cover positions and running around totally unnecessarily. And I can still see and hear their "Go, I am covering!" and so on, so I think that they are doing some modified "bounding overwatch" or something.

Briefly: problem is not resolved

PS: can you please give me the link for that discussion in BI forums? Thanks.

Updated by Fireball over 7 years ago

  • Status changed from Resolved to Assigned

Jep, just saw that too, when I tested it.

Updated by Fireball over 7 years ago

  • Status changed from Assigned to Feedback
  • Target version deleted (1.05 BETA)

I think your request is something between a feature and something nobody wants "fixed": http://forums.bistudio.com/showthread.php?t=91198

EDIT: I've read your description again, and maybe we should alter the subject of the ticket, to avoid confusion.

Updated by Fireball over 7 years ago

  • Subject changed from AI use danger mode while given order "take cover" to AI too slow to get to cover when ordered "take cover"

Updated by Bouben over 7 years ago

Well, allright. But I think that combat/danger mode is the reason and AI should not use it while taking cover. And I also think that most people don't realize what danger mode means for taking cover situations - bounding overwatch should have its own command instead cause "take cover" means to take cover and to scan and move tacticaly.

Updated by Fireball over 7 years ago

  • Status changed from Feedback to Assigned

I concur.

Generally in Danger mode, they are too slow clearing open field and prefer to lay down if they don't find cover in time, so I guess this is the main issue. Shall we modify the ticket, or do you want to keep it specific on the "Take Cover" order?

Updated by Bouben over 7 years ago

Keep it specific on the "take cover" order.

Danger mode itself is not SO bad and should be tuned on its own.

So please, let this ticket just for "take cover" order.

Updated by fabrizioT over 7 years ago

Yes, no need to fix what's not broken.
I agree units should be able to take cover more quickly.

Updated by Fireball over 7 years ago

  • Due date changed from 12/24/2009 to 02/04/2010
  • Assignee set to Luca

Updated by kju over 7 years ago

  • Due date changed from 02/04/2010 to 03/04/2010

Updated by BeerHunter almost 7 years ago

  • Size of OS swap file set to Please specify!

Good one.. I too would like to see the commanded AI RUN for cover , then set to "aware" or "danger" mode if at all possible.

Updated by kju almost 7 years ago

  • Due date changed from 03/04/2010 to 07/14/2010
  • Status changed from Assigned to Feedback
  • Assignee deleted (Luca)

Updated by kju almost 7 years ago

  • Due date deleted (07/14/2010)
  • Status changed from Feedback to Expired
  • I am using some Mods set to No
  • Reproducible for you set to No

Updated by Fireball almost 7 years ago

  • Due date set to 08/20/2010
  • Status changed from Expired to Feedback
  • Assignee set to Fireball

Updated by Fireball almost 7 years ago

  • File CIT_6471_OATakeCover.Desert_E.zip added
  • Due date changed from 08/20/2010 to 11/20/2010
  • Status changed from Feedback to Assigned
  • Assignee changed from Fireball to Dwarden
  • Affected ArmA II version changed from 1.05 BETA to 1.53 BETA
  • I am using set to CO (A2+OA)
  • Reproducible for you changed from No to Yes

Still an issue, new repro attached:

1. Load mission "CIT_6471_OATakeCover"
2. Hit Space, 1-8
3. Run for your own cover (waypoint)
4. Watch your men struggle and die

I remember a poll in the BIF where many voted that boundig overwatch would be a good idea when you order them to take cover. I don't get why - it's a disaster!

Updated by Salah almost 7 years ago

People are stupid, that's why. I suppose, no soldier would vote for that, only leet armchair commandos (not that I'm a soldier myself).

I 100% agree with the original proposal: Take Cover! = Move ASAP to the next cover

Updated by Fireball almost 7 years ago

Updated by fabrizioT over 6 years ago

1.58 beta, Issue still there

Updated by Fireball over 6 years ago

  • Affected ArmA II version changed from 1.53 BETA to 1.57.76815

Updated by kju over 6 years ago

  • Due date deleted (11/20/2010)
  • Status changed from Assigned to Resolved
  • Target version set to 1.58.78473
  • Operating system deleted (Vista 64 bit)
  • Graphics card deleted (ATI Radeon HD 3850)
  • CPU deleted (Please specify!)
  • Audio card deleted (Please specify!)
  • Size of OS swap file deleted (Please specify!)

From what I can tell fixed in 1.58 RC for both demo missions.

In the one from fireball some lay down and return fire immediately,
while others run for nearby stones. Overall they fight back very well.

As alternative run to the drill station first, if you want the AI to
take cover there.

Also keep in mind that AI follows the stance they are told to be in
while looking for cover. So tell them first to "stand up", if you want
them to be as fast as possible.

Updated by kju about 6 years ago

  • Target version changed from 1.58.78473 to 1.59.79384
  • Language set to Please set for missions

Updated by kju about 6 years ago

  • Status changed from Resolved to Closed
  • I am using deleted (CO (A2+OA))

Also available in: Atom PDF