Bug #6452

Ejection seats do not catapult you high enough

Added by mr.g-c over 5 years ago. Updated about 5 years ago.

Status:Closed Start date:12/03/2009
Priority:Urgent Due date:01/25/2010
Assignee:tcp % Done:

100%

Category:Script
Target version:1.0.1
Component:ace_sys_eject Affected Version:
Close Reason:

Description

The Ejection Seats do not catapult you far enough away from your plane. Especially when you are using them from the ground they only catapult you like 2m in the air, while in RL its around 30m afaik.
(Other than that a great system :-) )


Related issues

related to A.C.E. for OA - Task #8718: Convert sys_eject up to A2 Closed 02/01/2010

History

Updated by rocko over 5 years ago

  • Assignee set to zGuba

Updated by rocko over 5 years ago

  • Target version set to 395

Updated by zGuba about 5 years ago

  • Due date set to 12/30/2009
  • Category set to Script
  • Status changed from New to Assigned
  • Component set to ace_sys_eject

Updated by zGuba about 5 years ago

Might be caused by seat config. I'll try attaching seats to parachute instead of replacing BIS code (shall get a bit more reliable).

Updated by mr.g-c about 5 years ago

zGuba wrote:

Might be caused by seat config. I'll try attaching seats to parachute instead of replacing BIS code (shall get a bit more reliable).

Might it not be related to speed of the vehicle? I think the faster you go the higher the seat goes....

Updated by tcp about 5 years ago

For ground taxi, I can confirm going faster will make you eject higher. Going slower (below ~70kmph) will eject you too low resulting in death unless you aren't moving at all and land on the top of the aircraft.

It should be the same irregardless of speed and altitude (not accounting for air resistance).

There appears to be two chutes on the ground when you land. It may be spawning two initially, although, in that case, they must overlap because it looks like only one when descending in the chute.

The US Navy/Marine Corps doesn't use the same nomenclature as the British. It would be a Martin Baker SJU-4 for the AV-8B. Not sure if they've deviated from the SJU naming for the F-35, possibly US16E.

Updated by rocko about 5 years ago

  • Target version changed from 395 to 1.0.0

Updated by rocko about 5 years ago

  • Due date changed from 12/30/2009 to 01/27/2010

Updated by rocko about 5 years ago

  • Due date changed from 01/27/2010 to 01/25/2010

Updated by rocko about 5 years ago

  • Priority changed from Trivial to Urgent

Updated by tcp about 5 years ago

  • Assignee changed from zGuba to tcp
  • % Done changed from 0 to 60

In Work. 0/0 ejection fixed. Outward Catapult/Rocket Motor propulsion no longer directly dependent on plane's velocity. Just need to finish tweaking seat-man separation. Will fine-tune the system in the future.

Updated by tcp about 5 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 60 to 100

FIXED
0/0 ejection normalized, altitude/velocity do not multiply boost anymore
Pilot goes left, co-pilot right
Simulation a little more realistic
Don't expect AI to fare well, yet

Updated by Sickboy about 5 years ago

  • Target version changed from 1.0.0 to 1.0.1

Updated by Sickboy about 5 years ago

  • Target version changed from 1.0.1 to 1.0.2

Updated by Sickboy about 5 years ago

  • Target version changed from 1.0.2 to 1.0.1

Also available in: Atom PDF