Bug #6419

m4 Eotech sight problem

Added by hibrid over 5 years ago. Updated over 5 years ago.

Status:Closed Start date:12/01/2009
Priority:Normal Due date:
Assignee:Scubaman3D % Done:

100%

Category:Texture
Target version:0.9
Component: Affected Version:
Close Reason:

Description

If you are standing in the shadow and use eotech sight in the daytime, the crosshair alpha is very low, but when you move left or right the crosshair showes bright while it is moved.

it is reproducable easily, but will post a screenshot if needed.

weapon.jpg (154.9 kB) hibrid, 12/05/2009 11:32

eotech.jpg (274.3 kB) hibrid, 12/05/2009 11:32

eotech_inshade.jpg (235.8 kB) hibrid, 12/05/2009 11:32

History

Updated by rocko over 5 years ago

  • Category set to Texture
  • Assignee set to Scubaman3D

Updated by rocko over 5 years ago

  • Target version set to 395

Updated by rocko over 5 years ago

  • Assignee changed from Scubaman3D to hibrid
  • Priority changed from Normal to Urgent

Screen and weapon used, please.

Updated by hibrid over 5 years ago

here comes detail the weapon and screenshots of the problem. i recorded a video too.
please check the crosshair brightness in shade and in the bright.

and the capture
http://www.nemo.hu/gabor/eotech.html

Updated by hibrid over 5 years ago

the blinking of the crosshair when its moved only can be noticed in the video.
it might caused by my hardware i use a Radeon HD 5850, somebody please check

Updated by VKing over 5 years ago

I reported something similar a while ago (#5529), but it was fixed.
I haven't seen anything like this since then. I'm using a GTX295, btw.
This doesn't look like the exact same thing, but maybe they're related?

Updated by rocko over 5 years ago

I have GTX260 and I am unable to reproduce it.

I might have a possible solution, but need to clarify first with Scubaman.

Updated by rocko over 5 years ago

  • Priority changed from Urgent to Normal

Updated by InstaGoat over 5 years ago

http://img13.imageshack.us/img13/5281/missingdotm4socomeotech.jpg

http://img300.imageshack.us/img300/3686/missingdotm16a4aim.jpg

http://img11.imageshack.us/img11/7468/missingdotm4socomaimpoi.jpg

http://www.youtube.com/watch?v=-UTDI35iXik

I encountered this bug too in the initial beta release today. I´m also running on a GTX-260 and winXP. This seems to occur with all ACE2 red dot sights I´ve tested so far (all contained in the special weapons ammo box as well as the M16A4 of the Marines). Furthermore, the sight becomes visible when the view is rotated, both when post processing is on or off.

Updated by RobertHammer over 5 years ago

--> http://forums.bistudio.com/showthread.php?t=89083
For aimpoint dot/holo use kolimator.rvmat and bug is fixed ;-)

Updated by pufu over 5 years ago

cannot confirm, using gtx260 216c here

Updated by RobertHammer over 5 years ago

Easy FIX guys :
It's bad rvmat , i had same problem
This is Bad bugged which is ACE using right now
kolimator.rvmat or ReticleShine.rvmat (don't know which one is ACE using in acex_c_wep_m16.pbo)
1 ambient[]={1.000000,1.000000,1.000000,1.000000}; 2 diffuse[]={1.000000,1.000000,1.000000,1.000000}; 3 forcedDiffuse[]={0.000000,0.000000,0.000000,0.000000}; 4 emmisive[]={1.000000,1.000000,1.000000,0.801001}; 5 specular[]={0.000000,0.000000,0.000000,1.000000}; 6 specularPower=1.000000; 7 renderFlags[]= 8 { 9 "NoZWrite", 10 "AddBlend" 11 }; 12 PixelShaderID="Normal"; 13 VertexShaderID="Basic";
This add into your kolimator.rvmat
1 ambient[] = {100.0, 0.5, 0.5, 1.0}; 2 diffuse[] = {1.0, 0.5, 0.5, 1.0}; 3 forcedDiffuse[] = {10.0, 2.0, 2.0, 0.0}; 4 emmisive[] = {10.0, 10.0, 10.0, 1.0}; 5 specular[] = {0.0, 0.0, 0.0, 1.0}; 6 specularPower = 1.0; 7 renderFlags[] = {"AddBlend"}; 8 PixelShaderID = "Normal"; 9 VertexShaderID = "Basic";
And this problem is fixed , so ACE fix this quickly as possible and add in next update , thx ;-p

Updated by rocko over 5 years ago

  • Status changed from New to Closed
  • Target version changed from 395 to 0.9
  • % Done changed from 0 to 100

Updated by Sickboy over 5 years ago

  • Assignee changed from hibrid to Scubaman3D

Updated by Minoza over 5 years ago

I have same problem on HD 5870

Also available in: Atom PDF