Bug #6383

[60588] Some ammo are not reloaded if empty

Added by alef over 5 years ago. Updated over 4 years ago.

Status:Closed Start date:11/30/2009
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Multiplayer
Target version:1.55.75445
Affected ArmA II version:1.55 BETA First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:No NGUrl:
Related to content of DLC: WIKIurl:

Description

AH-1Z, pilot and gunner MP.
Ammunution, Fuel and Repair truck.

Obs
Not all vehicle weapons can be reloaded by ammo trucks.

Exp:
Any subweapon of a vehicle should get reloaded.

Repro

  • ammo at lowest values but greater than 0
  • vehicle local to w1 (server)
    • w1 gets in as pilot
    • w1 waits for full repair
    • w1 switches to manual fire
  • no HF, nor SW
    • w2 gets in as gunner
  • same status as w1

Related issues

related to ARMA2 Community Issue Tracker - Bug #6367: [74123] Vehicle repair MP issues Assigned 11/29/2009 11/25/2010
related to ARMA2 Community Issue Tracker - Bug #1720: Rearming vehicles: Can only rearm 1 magazine Closed 06/02/2009
related to ARMA2 Community Issue Tracker - Bug #14456: Unit ammo slider at zero makes it impossible to rearm the... Assigned 10/17/2010 12/01/2010

History

Updated by zGuba over 5 years ago

  • Category set to Gameplay

Updated by kju almost 5 years ago

  • Due date changed from 02/28/2010 to 10/01/2010
  • Status changed from Assigned to Feedback
  • Assignee set to alef
  • Audio card set to Please specify!
  • Size of OS swap file set to Please specify!
  • I am using some Mods set to No
  • Reproducible for you set to No

It seems you forgot to attach the demo mission?

Updated by alef over 4 years ago

  • Status changed from Feedback to Assigned
  • Affected ArmA II version changed from 1.05 BETA to 1.55 BETA

Same as #6367. It still happens in 73112, will provide a video for both.

Updated by alef over 4 years ago

  • Due date changed from 10/01/2010 to 11/01/2010
  • Category changed from Gameplay to Multiplayer
  • Status changed from Assigned to Resolved
  • Target version set to 1.55 BETA

Fixed following exactly repro steps.

There are other issues caused by slightly different repro variants (who enters first, where is veh local at first, etc.) that will deserve separated tickets.

Updated by kju over 4 years ago

  • Target version changed from 1.55 BETA to 1.55.75445

Updated by alef over 4 years ago

  • Due date deleted (11/01/2010)
  • Status changed from Resolved to Closed
  • Assignee deleted (alef)

Also available in: Atom PDF