Bug #6043

Unit mounts occupied vehicle position

Added by Fireball almost 6 years ago. Updated almost 5 years ago.

Status:Closed Start date:11/22/2009
Priority:Normal Due date:10/01/2010
Assignee:Fireball % Done:

100%

Category:AI Control
Target version:1.51.71083
Affected ArmA II version:1.05.62017 First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using:CO (A2+OA) BIForumURL:
Reproducible for you:No NGUrl:
Related to content of DLC: WIKIurl:

Description

When you select some unit and use the action cursor/quick menu to order units into a in-game spawned vehicle (tested it with a M1A2 Tusk), you order the unit potentially into an already occupied position.

Repro (with attached mission):

1. Disembark Commander
2. Order them to wait for you (1-7)
3. Mount Tusk as loader (!)
4. Switch to commander seat
5. Select disembarked unit and order it to mount again using quick menu (or 4-2-1)

Result:

Unit tries to mount commander position even though it's occupied by you.

Expected:

You order him into the loader position directly, since it's the only unoccupied position.

If this affects other vehicles is subject to further experiments.

Remount_Bug_CIT_6043.utes.zip (1.2 kB) Fireball, 11/22/2009 03:58

History

Updated by Fireball almost 6 years ago

  • Subject changed from Default boarding position random when using quick menu/action cursor to Random boarding position when using quick menu/action cursor

Updated by Fireball almost 6 years ago

  • Status changed from Assigned to Feedback
  • Reproduced by another DH user changed from Yes to No

Will provide a repro, if I still can do it...

Updated by Fireball almost 6 years ago

  • Reproduced by another DH user changed from No to Yes

Repro Video: http://www.youtube.com/watch?v=WfjvdfjZZ0Q

First and important conclusion is that it's only working with a spawned vehicle such as in Warfare.

Repro mission coming up, if I manage to script it; I've used Warfare BE for the repro video.

Updated by Fireball almost 6 years ago

  • File Remount_Bug_CIT_6043.utes.zip added
  • Subject changed from Random boarding position when using quick menu/action cursor to Unit mounts occupied vehicle position
  • Status changed from Feedback to Assigned

Attached repro mission and updated repro steps in description.

Updated by Fireball almost 6 years ago

  • Priority changed from Normal to High

Updated by Fireball over 5 years ago

  • Due date changed from 12/22/2009 to 01/17/2010
  • Assignee set to Fireball
  • Priority changed from High to Normal

Need to try this again.

Updated by Fireball over 5 years ago

  • Due date changed from 01/17/2010 to 02/17/2010
  • Assignee changed from Fireball to Luca
  • Affected ArmA II version changed from 1.05 BETA to 1.05.62017

Confirming, still happens.

Updated by kju about 5 years ago

  • Due date changed from 02/17/2010 to 10/01/2010
  • Status changed from Assigned to Resolved
  • Assignee changed from Luca to Fireball
  • Target version set to 1.51.71083
  • Audio card set to Please specify!
  • Size of OS swap file set to Please specify!
  • I am using some Mods set to No
  • I am using set to CO (A2+OA)
  • Reproducible for you set to No

Works fine here.

Unit gets into loader position (now) rather than (player occupied) commander.

Updated by Dwarden almost 5 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF