Bug #5937

Linked Directorys which are 'invalid' will crash cache rebuild and break local file update check

Added by oktane almost 6 years ago. Updated almost 6 years ago.

Status:Closed Start date:11/20/2009
Priority:High Due date:
Assignee:Yoma % Done:


Target version:2009_11_18 1.0.35 Beta


Links via windows mklink
I had a 'ramdrive' directory link which went to a folder on a ramdisk. This 'ramdisk' folder was located in Arma2\ folder.

At some point the data on the ramdisk was cleared and the directory link became invalid. I didn't care because it was ready to go should I put the data back on the ramdisk. However, I went to use YAS today and check for new caa updates, and it said all of my files were out of date. (it said 'comparing server addons to local', but seemed to not be doing anything, and allowed me to press 'download addons' (maybe you should disable that button while checking?)) I thought this to be wrong, since nobody would want users redownloading 2gb of data! (What was really happening, is YAS got stuck on the invalid directory and sat there.) So I told YAS to rebuild the cache. It crashed. I tried the previous version of YAS and it crashed too. Due to the lack of debug spew 'Blah blah has stopped working' in W7, I opened it in a visual studio debugger and checked out what the error was. It said it couldn't open my ramdisk folder because it was invalid. (which it was)

Deleting the ramdisk directory link fixed it.

Possible solution: You could make that directory open silently fail or pop msgboxa and skip to the next directory? That way if a user has invalid directory links or mixed up permissions,(I assume the latter would cause it too) the app doesn't crash mysteriously.

Also if the local check is in progress, don't allow 'download addons button'.

Rare problem, I agree. But handling invalid user configurations gracefully has its merits. :D


Updated by Yoma almost 6 years ago

This seems a reproducable situation.
I'll try and repro it tonight and see what i can do.
Welcome to the wonderfull world of junctions :-)

Updated by Yoma almost 6 years ago

  • Assignee set to Yoma
  • Priority changed from Low to High
  • Target version set to 2009_11_18 1.0.35 Beta

Took a look at it, should be fixed in next version.
Thanks for reporting it.

Updated by Yoma almost 6 years ago

  • Status changed from New to Resolved

Updated by Yoma almost 6 years ago

  • % Done changed from 0 to 100

Updated by Yoma almost 6 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF