Bug #5896

Skiptime Lag

Added by Rommel over 5 years ago. Updated over 3 years ago.

Status:Duplicate Start date:11/17/2009
Priority:Normal Due date:12/01/2009
Assignee:- % Done:

0%

Category:Scripting: Problem
Target version:-
Affected ArmA II version: First affected build:
Reproduced by another DH user:No First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:No NGUrl:
Related to content of DLC: WIKIurl:

Description

Skiptime iterations on Utes cause no lag compared to the 2-3second pause that occurs on Chernarus. No logical reason behind this; very frustrating for regular iterations.

Example:

1 while {true} do {
2         sleep 1;
3         skipTime 1;
4 };

Delay on Utes: ~0.0003s (unnoticeable)
Delay on Chernarus: ~1.5s (very noticeable, game effective freezes if the delay between iterations is less)


Related issues

duplicates ARMA2 Community Issue Tracker - Bug #3437: skipTime and setDate freeze the game to 0 fps for a short... Assigned 08/07/2009

History

Updated by Fireball over 5 years ago

  • Due date set to 12/17/2009
  • Status changed from New to Assigned
  • Reproduced by another DH user changed from Yes to No

Updated by kju over 5 years ago

Duplicate of #3437?

skipTime and setDate freeze the game to 0 fps for a short while

Updated by kju over 5 years ago

  • Due date changed from 12/17/2009 to 12/01/2009

Updated by Fireball over 5 years ago

  • Status changed from Assigned to Duplicate

It is.

Updated by kju over 3 years ago

  • Description updated (diff)
  • Affected ArmA II version deleted (1.04.59026)
  • I am using some Mods set to No
  • Reproducible for you set to No

Also available in: Atom PDF