Bug #5840

M16A2/M203 aim bug

Added by Li0n over 5 years ago. Updated almost 3 years ago.

Status:Closed Start date:11/14/2009
Priority:Normal Due date:
Assignee:Dwarden % Done:

0%

Category:Weapons
Target version:1.51.71083
Affected ArmA II version:1.07.71750 First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Here is a picture:

As you can see, muzzle sight is not in the center of aim and bullets stike not where you are aiming.

m16a2m203.jpg (44.9 kB) Li0n, 11/14/2009 15:57

mission.sqm (1.9 kB) Fireball, 01/25/2010 07:06

M16A2_M203_Ironsights_Offset.jpg (250 kB) Fireball, 08/15/2010 23:06


Related issues

related to ARMA2 Community Issue Tracker - Bug #14153: M16A2 M203 ironsight model bug increases zeroing to 500m Assigned 10/03/2010 12/01/2011

History

Updated by zGuba over 5 years ago

  • Due date changed from 11/28/2009 to 12/14/2009
  • Status changed from New to Assigned
  • Reproduced by another DH user changed from No to Yes

Updated by Mudkip over 5 years ago

Could possibly be because you're crouching. Try shooting while standing or prone.

Updated by Li0n over 5 years ago

The picture was from stand position. Try yourself.

Updated by Fireball about 5 years ago

Thing is, that you tend to move a bit around, unable to hold completely still while standing and it gets worse when you're wounded. Interesting enough it's also getting worse while crouching.

Most stable position is when you're lying down, of course.

Updated by Fireball about 5 years ago

  • Due date changed from 12/14/2009 to 01/14/2010

Updated by kju about 5 years ago

Isn't that weapon sway?
Or is it fixed at some weird offset?

Updated by Li0n about 5 years ago

It is fixed

Updated by kju about 5 years ago

  • Due date deleted (01/14/2010)
  • Status changed from Assigned to Closed
  • Target version set to 1.05.62017

tx :)

Updated by Fireball about 5 years ago

  • Due date set to 01/14/2010
  • Status changed from Closed to Feedback
  • Target version deleted (1.05.62017)

Ehm, I think he didn't mean it's fixed in terms of resolved, but a fixed view, not weapon sway. :-D

Updated by Li0n about 5 years ago

Yes, a fixed view, and a fixed offset of bullet impact :)

Updated by Fireball about 5 years ago

  • Status changed from Feedback to Assigned

Updated by Fireball about 5 years ago

  • Due date changed from 01/14/2010 to 02/14/2010
  • Affected ArmA II version changed from 1.04.59026 to 1.05.62017

Whole lot of weapon bugs around; maybe we should make an own category for them as IMO they are important.

Updated by Fireball about 5 years ago

  • Category changed from Model to Weapons

Updated by Li0n about 5 years ago

Maybe you should fix any of them first?

Updated by Fireball about 5 years ago

  • File mission.sqm added
  • Assignee set to Luca

Yep, I can see it now myself, ironsights are off (plus, there are no leaf ironsights for the M203).

Model name: M16A2GL

Updated by Fireball about 5 years ago

  • File deleted (mission.sqm)

Updated by CarlGustaffa over 4 years ago

I prefer having the option of leaf or no leaf if it's not possible to change it mid game. Sometimes you need the M203 only for flares, and then the leaf is only in the way. So M16A2 without leaf and M16A4 with leaf seems like the best option to me.

Updated by kju over 4 years ago

  • Due date changed from 02/14/2010 to 10/01/2010
  • Status changed from Assigned to Feedback
  • Assignee deleted (Luca)

Any difference in latest OA?

Updated by Fireball over 4 years ago

We got leaf ironsights now, but for shooting bullets, the ironsights are more than offset to the right, they're also too low and thus completely unusable.

New screenshot attached.

Updated by Fireball over 4 years ago

  • Due date changed from 10/01/2010 to 11/01/2010
  • Affected ArmA II version changed from 1.05.62017 to 1.52.71816
  • Reproducible for you changed from No to Yes

Updated by Fireball over 4 years ago

  • Status changed from Assigned to Feedback

The offset to the right in the picture was only because of recoil.

My question remains only, if it's possibly just got a fixed zeroing on 500m; at this distance, you can hit exactly over the bead.

Updated by Fireball over 4 years ago

  • Due date changed from 11/01/2010 to 09/26/2010
  • Status changed from Feedback to Resolved

Marking resolved. The original issue was fixed.

Updated by Kill_MiG over 4 years ago

Status changed from Feedback to Resolved

Really? In what version?

Updated by Fireball over 4 years ago

  • Target version set to 1.54.72888
  • Affected ArmA II version changed from 1.52.71816 to 1.07.71750

Since OA, it was my mistake to move on the affected version, but the bead is centered now, along with the leaf sight now available. The offset you can see im my latest picture is the result of muzzle climb.

What remains is the fixed zeroing to 500m - the M16A4 doesn't exhibit that, thus I filed a new bug ticket for that: #14153

Updated by Fireball over 4 years ago

  • Target version changed from 1.54.72888 to 1.51.71083

Updated by Fireball over 4 years ago

Please confirm my observation.

Updated by Kill_MiG over 4 years ago

Fireball wrote:

What remains is the fixed zeroing to 500m - the M16A4 doesn't exhibit that, thus I filed a new bug ticket for that: #14153

Oh, God, that's bad.. BIS can't fix this bug since Arma2, and now it might take a couple of months to pay attention to this problem again.. Sorry for my bad english..

Updated by kju over 4 years ago

  • Due date deleted (09/26/2010)
  • Status changed from Resolved to Closed

Confirmed fixed.

Also available in: Atom PDF