Feature #5795

Introduce a separate "locked" state

Added by oktane almost 6 years ago. Updated about 5 years ago.

Status:Closed Start date:11/12/2009
Priority:Trivial Due date:
Assignee:- % Done:


Target version:1.51.71083
Affected ArmA II version: First affected ArmA II version:
Reproduced by another DH user:Yes Single / Multi Player?:
I am using some Mods:No BIForumURL:
I am using: NGUrl:
Reproducible for you:No WIKIurl:
Related to content of DLC:


As the title says, locked servers are displayed as passworded. This confuses someone trying to join. They are asked for a password which nobody has set.

It's a simple usability issue of consistency.

This was not an issue in ArmA 1, it did not ask for a password, instead it immediately said 'Server is currently Locked'.


Updated by oktane almost 6 years ago

here is a small comparison, note the 'password' field in the arma2 column. There is no password set.

a1 locked a1 unlocked a2 locked
gamever 1.16 1.16 1.04.59026
numteams 0 0 0
gamemode openwaiting openwaiting openwaiting
timelimit 0 0 0
password 0 0 1
param1 0 0 1
param2 0 0 0
currentVersion 116 116 104
requiredVersion 116 116 104
mod CA;beta CA;beta CA;@CBA;@506Air
equalModRequired 0 0 0
gameState 1 1 1
dedicated 1 1 1
platform win win win
language 65545 65545 65545
difficulty 0 0 1
gamename armedass armedass arma2pc
sv_battleye 0 0 0

Edit: alef: removed the pre block

Updated by Fireball almost 6 years ago

  • Due date set to 12/12/2009
  • Status changed from New to Assigned
  • Affected ArmA II version changed from Please select... to 1.04.59026

Good one, thanks.

Updated by kju almost 6 years ago

  • Priority changed from Low to Normal

Updated by kju almost 6 years ago

I dont quite get the table. What should it tell us in regards to the issue at hand?

Updated by Dwarden almost 6 years ago

in A2 the locked server is for query reported as passworded == 1,
this is to allow such server being filtered and also not being shown as open server when not filtered ...

changed due locked server were shown as open in early ARMA 2 builds but that was confusing users
they joined green 'open' server and got after moment 'this server is locked' window and failed to join

so this behaviour is by design and was changed from ARMA 1 and early ARMA 2 builds ...

Updated by Dwarden almost 6 years ago

  • Assignee set to Dwarden
  • Priority changed from Normal to Trivial

Updated by oktane almost 6 years ago

Locked server is not a passworded server. Normally admins lock servers for two reasons
  • to prevent lag on a server which has high traffic, to ensure the people already on the server have a quality experience, this is by far the most popular use.
  • to change the server to a temporary private event. (this is much less frequent)

I don't think there was anything wrong with the old handling. The servers were not passworded, simply locked, so the password filter should not filter them out.

In whatever case that the system was envisioned for, I am just presenting the way the actual users use it. Any number of things could be done to satisfy both your vision and keep the consistency of the game's interface. For example, add an sv_locked variable to the gamespy protocol output, etc.

It still stands that the password dialog shouldn't be shown for a locked server, it's misleading to folks. I'm not trying to pick on trivial issues, just to improve the experience for a new player so he isn't put off with nonsense dialogs or server admins dealing with people requesting 'what is the password' on voice chat.

Also, the approach that BIS took to solve "changed due locked server were shown as open in early ARMA 2 builds but that was confusing users
they joined green 'open' server and got after moment 'this server is locked' window and failed to join", being that they set password=1, is kind of crappy, no? It breaks their own interface in that it causes their game client to ask for a password when there isn't one.

And, you may not be aware of this: In ArmA1, the client would initiate a connection to the server before being told it was locked. So the admin on the server at the time could see that a player was trying to join and unlock it if that person was a regular or someone that would increase the quality of play. (squad mate, etc) The admin could see 'player oktane connecting...', and most people knew to try to connect twice.. since their first connect would signal to the admin they wanted in, and the second would be their actual connection after the admin had unlocked it. In A2, this has come to a halt because of this issue. (likely because people think the server is actually passworded, even though when they try to put a password in it says it is locked)

Thanks for the nice table.

Updated by zyklone almost 6 years ago

The ideal and trivial solution would be to add a 'locked' variable.

I don't think this should be underestimated in importance atleast for OA, it's one of those annoying usability things which do upset new players.

Updated by kju almost 6 years ago

I agree that a locked server is NOT passworded in a practical sense.
Filtering out as passworded is bad and will only confuse people.

You only need to add a different icon in addition..

Updated by Fireball almost 6 years ago

  • Tracker changed from Bug to Feature

Updated by Fireball almost 6 years ago

  • Due date changed from 12/12/2009 to 02/12/2010

Feature, alright?

Updated by Fireball almost 6 years ago

  • Subject changed from Locked servers are displayed as passworded to Introduce a separate "locked" state
  • Due date deleted (02/12/2010)
  • Affected ArmA II version deleted (1.04.59026)

Updated by oktane over 5 years ago

Hello. It's been 6 months, revisiting old tickets. I still don't see this as a feature request. As was mentioned by Dwarden, a bit of code was changed, but it had unintended consequences. The consequences are the password box is shown when there is no password! At least the bug could be admitted, even if you stick to how it was designed. But from the sound of it, a variable would have to be added or existing modified (password == 2?) to check if the server is locked, and in doing so would probably satisfy both bug and supposed feature. Or maybe it can't be changed, but nobody said anything to that end.

In no logic-based universe can I see a misleading password box popping up for a client, when there is no password, to be intentional by the designer. Unless it's a compromise based on an inability/constraint to work around the issue. But it seems like it's another tiny inconsistency in the GUI that contributes to it's unneeded complexity and confusing nature for people new to the game. (http://stuffthathappens.com/blog/2008/03/05/simplicity/ :D ) Daily people ask, around the ArmA MP world, dude what's the password?

If you would like me to rewrite it at a bug about the password box, I could. (Although I thought the initial posting was pretty clear and free of opinion, and I don't intend to abuse the CIT) I don't want you to change it for me or even care what I think. I'm pleading that you use the information on these CIT tickets to better the game, polish it, fix issues, for the goal of improving the game's success... to the benefit of your business. (and indirectly your die-hard customers)

And I've been on teams that shipped games with bugs, glaring horrible gameplay-breaking bugs that were marked 'shippable', 'as designed' or 'not doing' by AP's.. It had to be done due to ship dates and !@# publishers with their deadlines, but it still broke our hearts. But we were also shipping final, perfect as reasonably possible, set in stone DVD's for consoles. (Patches on consoles cost big bucks!) In this regard, your platform (PC) offers you many advantages, and even has allowed you to seemingly evolve the game constantly over the course of 8 years! I am not saying this is a huge glaring bug, it is quite the contrary. The GUI improvements over the last 18mo via patches have been quite phenomenal. In the end, I'm making an assumption that those improvements your team made (ex: MP lobby gui) would fall under the same usability improvement goal I am yapping about here and on other similar tickets*.

There is no feature request here imo, but I'll settle for a 'not doing' too. :P


Ah the lies of game development: http://mediacast.sun.com/share/ChrisM/BeAGameDesigner.mpg

*Those other tickets of similar nature, some already completed:
http://dev-heaven.net/issues/1955 (used to be able to zoom while guys were selected, even though the command menu scrolled at the same time)

(sorry, last edit: added list)

Updated by oktane over 5 years ago

  • Audio card set to Please specify!
  • Size of OS swap file set to Please specify!

Server shows a locked state in OA now. This can be closed, thank you.

Updated by kju over 5 years ago

  • Status changed from Assigned to Closed
  • Assignee deleted (Dwarden)
  • Target version set to 1.51.71083


Also available in: Atom PDF