Bug #5540

Program catches Windows taskbar focus mouse click while windowed

Added by ceeeb almost 6 years ago. Updated over 4 years ago.

Status:Closed Start date:10/30/2009
Priority:Normal Due date:08/30/2011
Assignee:- % Done:

0%

Category:Other
Target version:1.07.71750
Affected ArmA II version:Please select... First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

When running ArmA2 in windowed mode, switching focus from another application to ArmA2 (by clicking on ArmA 2 in the taskbar) sometimes results in ArmA2 catching the mouse click as if it occured within ArmA2 (resulting in firing of the player's weapon, or drawing a box in the mission editor).

Repro

- Start the game windowed or switch to windowed mode after starting
- Place a player unit in the editor and start the preview
- Alt-Tab off the game
- Click on the taskbar button of ArmA2/OA

Observed

- Active weapon fires a shot

Expected

- No shot is fired, game becomes active again


Related issues

related to ARMA2 Community Issue Tracker - Bug #11591: Keyboard input in windowed mode still captured, even whil... Assigned 07/01/2010 05/01/2011

History

Updated by Fireball almost 6 years ago

  • Status changed from New to Feedback

Can you check if -nopause has/had an influence?

Updated by ceeeb almost 6 years ago

-nopause has no influence on this issue.

Okay, done some more testing. I now think this bug is caused by clicking on another application to exit windowed session of ArmA2 (generally from the editor or menus). The click is registered by ArmA2 when it regains focus. If I'm correct, this bug is much less of a problem than I originally suspected.

Updated by Fireball almost 6 years ago

  • Due date changed from 11/14/2009 to 12/14/2009
  • Status changed from Feedback to Assigned
  • Priority changed from Normal to Trivial
  • Reproduced by another DH user changed from No to Yes

Yes, I can see that happening too. I think that's a pretty trivial bug, and potentially there's nothing to be done about - I guess you shouldn't be doing your hyper-important clan battles in windowed mode.

Updated by CarlGustaffa almost 6 years ago

I'll actually vote on this one. As I think it is related to the editor hang bug, when alt tabbing in windowed mode editor. I didn't have any of these issues prior to 1.04, but both have been apparent since 1.04 and all its beta patches. I won't guarantee about this one prior to 1.04, but at least I've never noticed it until 1.04.

If it is unrelated, then indeed it is trivial. But if it actually is related, I would say it was critical. Editing is for me now hopeless due to the constant editor hangs.

Updated by Fireball almost 6 years ago

CarlGustaffa wrote:

Editing is for me now hopeless due to the constant editor hangs.

Did you file a bug ticket about this providing all your details?

Updated by Fireball over 5 years ago

  • Due date changed from 12/14/2009 to 01/14/2010
  • Reproduced by another DH user changed from Yes to No

Updated by Fireball over 5 years ago

  • Reproduced by another DH user changed from No to Yes

Sorry, mistake.

Updated by Fireball over 5 years ago

  • Due date changed from 01/14/2010 to 04/14/2010
  • Affected ArmA II version changed from 1.05 BETA to 1.05.62017

Updated by Dwarden about 5 years ago

  • Assignee set to Dwarden

Updated by Dwarden about 5 years ago

  • Status changed from Assigned to Feedback
  • Audio card set to Please specify!
  • Size of OS swap file set to Please specify!
  • I am using some Mods set to No
  • Reproducible for you set to No

still issue ?

Updated by kju about 5 years ago

  • Due date changed from 04/14/2010 to 08/01/2010

Updated by Fireball about 5 years ago

  • Status changed from Feedback to Resolved
  • Target version set to 1.07.71750

Cannot repro this with A2 1.07 anymore.

Does it still happen in OA?

Updated by kju about 5 years ago

  • Due date deleted (08/01/2010)
  • Status changed from Resolved to Closed
  • Assignee deleted (Dwarden)

Updated by Fireball over 4 years ago

  • Subject changed from Arma2 catches Windows task bar focus mouse click to Program catches Windows taskbar focus mouse click while windowed
  • Due date set to 08/30/2011
  • Status changed from Closed to Assigned
  • Priority changed from Trivial to Normal
  • Target version deleted (1.07.71750)
  • Affected ArmA II version changed from 1.05.62017 to 1.60 BETA
  • Reproducible for you changed from No to Yes
  • Language set to Please set for missions

Still happens in OA, needs to be windowed for repro.

Updated by Fireball over 4 years ago

  • Status changed from Assigned to Closed
  • Target version set to 1.07.71750
  • Affected ArmA II version changed from 1.60 BETA to Please select...

Updated by Fireball over 4 years ago

Cannot repro anymore.

Also available in: Atom PDF