Bug #5470

Logo not working

Added by sbsmac about 6 years ago. Updated about 6 years ago.

Status:Feedback Start date:10/27/2009
Priority:Normal Due date:
Assignee:- % Done:


Target version:3.00


MarcU says he has a map where the logo is not working. Maybe it is not 1024x1024 ?


Updated by sbsmac about 6 years ago

Marc, could you check the size of the logo ? It needs to be 512x512 pixels or 1024x1024. If the size is correct but it is still not working could you upload/link to the logo.jpg, description.ext, mission.sqm and ctfConfig.sqf you are using ?

Updated by sbsmac about 6 years ago

More info from Marc...

Now this time I turned the map back to your default of OFF in the
description.ext file, in fact I just copied over it with your .5 one. This
time when I tested just bymyself the logo appears but only for about 1
second. When I hosted the game it did the same on my computer but did
not show at all on the other. So after testing I began to think, what is
different between the custom logos I have done that work and this football
one that doesn't. Now the coop and the koth map each have thier own
custom logo which is a real life combat photo. The
Coop one is pretty simple and is around 175 kb in size, the koth is more
detailed and is around 300 kb and the football one which is a real life
photo of guys at a camp in afghanistan playing football in the dirt, is
I noticed that the logos that come with the script
pack is around 250 kb. I also noticed that the koth logo does not appear for
as long as the coop logo which is much smaller in size and your stock logo.
I noticed in one of your files that you have the computers wait until
certain things are done. I am wondering, even though
the file size is small, could the wait time be too short? too long?? This
hampers those that want to do thier own logo's so needs attention

The wait time should not be a factor nor should the map. As I say in the earlier note, I strongly suspect the image-size is not correct (must be 512x512 or 1024x1024) but it could still be something else.

Updated by AceOfSpades about 6 years ago

All logo's I have created on working maps and now this one that does not work are 1024X1024 in size and is a jpg.. I have looked and compared this jpg to other logo's endlessly lol. I am at work on a laptop atm. Tonite will send a copy of the pic and the cfg file. Shouldn't need anything else because I have not changed a single thing in any other file positive, for sure. Btw the picture does come up, just long enough for you to see that it was the right pic ( about half a second). Also if this helps any.... the picture flashes on the screen at the end of the recieving "cycle". So it basically goes like... click continue...get black no map briefing screen..click continue... get black recieving screen...flash logo....start intro song and flyby. Could the jpg itself be corrupted?? It loads up fine in photoshop or any other program, and arma apparently is detecting and can display cause it does come up, if but for a half a second. Anyhow will send files this afternoon. Also before I do that I will run a quik test and replace the logo that is not working with a logo from another script pack map of mine that does work and see what happens with just the logo changed out. Process of elimination and will report back to wiki with results before I send files.

Updated by sbsmac about 6 years ago

Ah I had misunderstood the original report and thought you weren't seeing anything at all. If you are getting the logo at all then the timing should not depend on which file you are using so I would suspect something else - in this case description.ext and ctfConfig.sqf are the most relevant files.

Updated by AceOfSpades about 6 years ago

ok buddy, you ready for a curve ball? lol here it comes....

I tested and tested and no it is definately not the logo. But it just gets strange and I mean strange and hard to replicate. First off I eliminated the possibility of the logo being bad somehow by getting it to work in another mission. Once I had that out of the way I started to try and weed things out. So I replaced all files folders again except the sound folder and images folder for the custom content and the ctfConfig.sqf file. Ran mission, still broken, so concentrated on the ctfCFG. I removed it from the mission folder to desktop and in its place put a brand new .5 copy all default, ran mission and the logo worked. So I then I started down line by line at what was different, testing each difference between the two individually. After a ton of uncommenting,setting default,running,,commenting line back again rinse and repeat cycles I finally narrowed down to the terrain distance setting, yes I said the terrain distance setting. Now this is where I wish I understood the scripts so I could understand...how in the heck is that connected with the logo lol. Any how after playing with the setting I found anything over a setting of 1000 would break the logo. Under 1000 and logo works fine. Set at 1000 and logo flashes, disappears for 10 seconds then comes back for 10 seconds which is longer that what happens when it is set over 1000. I confirmed this by deleting the ctfConfig file from the mission folder, moving my original back from the desktop into mission folder and made the terrain view distance 800 and it worked. This also has to be something new because it is my first occurance with this problem and I have always set the view distance to 1600. Now....it gets really wierd.
I tried to replicate it further in a template rugby mission and no matter what I tried I could not relplicate it. But currently mission is fixed if terrain view is set below 1k and broken if above 1k. So if you need me to send a copy of it, let me know. Also if any other testers can please and try and replicate this problem, please do, I seem to be striking out after the first few hits. Last thing, also after having my mission working with a default of 800 view set, I ran mission and changed the dialog for terrain view setting it to 2000 and it did not break the mission so it is probably safe to say that the dialog for this is broken as well. Thanks.
I will be not testing anything else for lack of time until thursday of friday but I will be keeping up with the wiki and results ect. Also will be available to send you mission files if requested.

Also available in: Atom PDF