Bug #5353

MG Nest switches to low LOD way too quick. Unable to see unit inside even with scoped weapons.

Added by kju over 5 years ago. Updated over 3 years ago.

Status:Closed Start date:10/23/2009
Priority:Normal Due date:12/01/2011
Assignee:Dwarden % Done:

100%

Category:Model
Target version:1.11.86734
Affected ArmA II version:1.60 BETA First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using:CO (OA+A2) BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Obs:
MG Nest switches to low LOD way too quick.
Unable to see unit inside even with scoped weapons.

Exp:
Able to see unit inside with scoped, when close (~20m).

Repro:
Launch attached mission and look at the MG Nest straight ahead in the woods.

GPU settings:
All very high, apart textures high, PP and shadows off, AA low.

0002.jpg (196.2 kB) kju, 10/23/2009 06:34

cit_bug_mg_nest_bad_lod.Chernarus.7z (671 Bytes) kju, 10/23/2009 06:34

gdtmod_mg_nest.zip (2.5 MB) Buliwyf, 03/29/2011 20:08

0003.jpg (213.1 kB) kju, 03/30/2011 09:58

0004.jpg (147.3 kB) kju, 03/30/2011 09:58


Related issues

related to ARMA2 Community Issue Tracker - Bug #4231: Low LOD of vehicles should be reviewed and improved Assigned 09/02/2009 06/01/2011
related to ARMA2 Community Issue Tracker - Bug #24501: Objects disappear early when turning away Assigned 09/13/2011

History

Updated by Dwarden over 5 years ago

  • Assignee set to Dwarden

Updated by zGuba over 5 years ago

  • Due date set to 12/23/2009
  • Affected ArmA II version changed from 1.04 BETA to 1.04.59026

Updated by Fireball over 5 years ago

  • Status changed from Assigned to Resolved

Seems to be resolved with latest patch(es), tested with build 60819, Object Detail set to Normal and a sniper from 200m.

Also, if you set Object Detail to High or Very High, the MG Nest stays at the high(er) LoD model earlier (or always even).

Updated by Fireball over 5 years ago

  • Status changed from Resolved to Assigned

Nope, guess Sniper wasn't the issue here anyway.

Just re-verified using a soldier with a red dot and it still switches to a "usable" LoD at approx 40m while holding RMB down ("focusing"), that's too late, considering that an assault rifle is supposed to have an optimal range of approx. 300m.

I guess the MG Nests are a special case and should be "locked" to high LoD, while the rest may still adapt dynamically.

Updated by Fireball about 5 years ago

  • Due date changed from 12/23/2009 to 04/23/2010
  • Assignee changed from Dwarden to Luca
  • Affected ArmA II version changed from 1.04.59026 to 1.05.62017

Updated by kju over 4 years ago

  • Assignee deleted (Luca)

Updated by kju over 4 years ago

  • Due date changed from 04/23/2010 to 12/01/2010
  • Assignee set to Dwarden
  • Affected ArmA II version changed from 1.05.62017 to 1.55 BETA
  • I am using changed from OA only to CO (A2+OA)

Updated by kju over 4 years ago

  • Due date changed from 12/01/2010 to 03/01/2011
  • Affected ArmA II version changed from 1.55 BETA to 1.57.76815

Updated by Buliwyf almost 5 years ago

Problem still exists in latest beta v1.59.79384. It would be nice to see the problem fixed in near future. These bunkers are really annoying when you are not able to see gunner to get him first...

Updated by kju almost 5 years ago

  • Due date changed from 03/01/2011 to 07/01/2011
  • Affected ArmA II version changed from 1.57.76815 to 1.59.78955
  • Audio card deleted (Please specify!)
  • Size of OS swap file deleted (Please specify!)
  • I am using changed from CO (A2+OA) to CO (OA+A2)
  • Reproducible for you changed from No to Yes

Updated by Buliwyf almost 4 years ago

Workaround: Try attached addon made by [GDT]HeinBloed! It removes the "view killing" LOD.

Updated by kju almost 4 years ago

thanks - works!

Updated by Dwarden almost 4 years ago

  • Target version set to Upcoming version

Updated by kju almost 4 years ago

  • Target version changed from Upcoming version to 1.59 BETA

Updated by kju almost 4 years ago

  • Target version deleted (1.59 BETA)

Updated by kju almost 4 years ago

  • Affected ArmA II version changed from 1.59.78955 to 1.59 BETA

Updated by kju almost 4 years ago

  • Target version set to Upcoming version

Updated by kju over 3 years ago

  • Due date changed from 07/01/2011 to 12/01/2011
  • Affected ArmA II version changed from 1.59 BETA to 1.59.79384

Updated by Dwarden over 3 years ago

  • Target version changed from Upcoming version to 1.60 BETA

Updated by Dwarden over 3 years ago

  • Status changed from Assigned to Resolved

nestSmall_east and nestSmall_nato got improved LODs (data fix)

Updated by Sickboy over 3 years ago

  • % Done changed from 50 to 100
  • Affected ArmA II version changed from 1.59.79384 to 1.60 BETA

Updated by kju over 3 years ago

  • Status changed from Resolved to Closed
  • Target version changed from 1.60 BETA to 1.60.87580

confirmed fixed

Updated by kju over 3 years ago

  • Target version changed from 1.60.87580 to 1.11.86734

Also available in: Atom PDF