Bug #5161

AI get out from repaired vehicle

Added by kondor almost 6 years ago. Updated almost 5 years ago.

Status:Closed Start date:10/13/2009
Priority:Normal Due date:
Assignee:- % Done:

50%

Category:AI Issues
Target version:1.55.75445
Affected ArmA II version:1.55 BETA First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using:OA only BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

When some vehicle is critical dammaged then AI get out from it.
After repairing of this vehicle, AI (after "get in" order) sometimes try to get in but immedietaly get out.
What I remember it's old bug (for sure it was in arma1 also).

Repro video:

http://www.youtube.com/watch?v=EawNqAX_65g

5161.Desert_E.7z (760 Bytes) kju, 10/18/2010 06:44


Related issues

related to ARMA2 Community Issue Tracker - Feature #3787: Make AI not abandoning immobilized vehicles under enemy fire Assigned 08/19/2009
related to ARMA2 Community Issue Tracker - Bug #6367: [74123] Vehicle repair MP issues Assigned 11/29/2009 11/25/2010

History

Updated by zGuba almost 6 years ago

  • Due date set to 11/13/2009
  • Status changed from New to Assigned
  • Affected ArmA II version changed from 1.04 BETA to 1.04.59026

Confirmed - sometimes AI "can't use this vehicle" flag is not taken away after repairing vehicle with repair truck.

Issue present since original OFP.

Related to #3787

Updated by zGuba almost 6 years ago

  • Due date changed from 11/13/2009 to 10/20/2009
  • Status changed from Assigned to Feedback
  • Assignee set to zGuba

Gonna check it myself.

Updated by zGuba almost 6 years ago

  • Assignee changed from zGuba to Fireball
  • Reproduced by another DH user changed from No to Yes

We have reproduced the bug successfully in MP environment. Fireball will post video soon.

Updated by Fireball almost 6 years ago

  • Due date changed from 10/20/2009 to 11/20/2009
  • Status changed from Feedback to Assigned

I put the video link in the description.

Updated by Dwarden almost 6 years ago

  • Assignee changed from Fireball to Dwarden

Updated by Alex72 almost 6 years ago

I have stumble upon this without even having the vehicle repaired.

What happened was that me and my AI squad (4 men total) was shot upon in our Hummer MK19. I was driving and one AI in the backseat (directly behind the driving seat) got killed. The other 2 AI jumps out when i stop the vehicle and refuses to get in again. They actually go in saying YES SIR to the GET IN comand, but jump out instantly saying NEGATIVE.

The armor had gone down 1 bar (damage bar) and the car had all tires full of air and was working perfectly. No slowdown or windows cracked etc.

Version Beta 59210.

Updated by Fireball over 5 years ago

  • Due date changed from 11/20/2009 to 01/03/2010

Updated by kju over 5 years ago

  • Due date changed from 01/03/2010 to 03/02/2010

Updated by kju about 5 years ago

  • Due date changed from 03/02/2010 to 07/14/2010
  • Status changed from Assigned to Feedback
  • Assignee deleted (Dwarden)
  • Affected ArmA II version changed from 1.04.59026 to 1.05.62017
  • Size of OS swap file set to Please specify!

Still valid in 1.07 / OA?

Updated by kondor about 5 years ago

I don't have environment to test it (no team members available).

Updated by kju about 5 years ago

Sorry I don't get your response. One can test this alone with just AI, or not?

Updated by kondor about 5 years ago

  • Reproducible for you set to No

What I understood - it's locality problem - vehicle repaired on client A will be still dammaged on client B.
That is why you need 2 clients to test this.
Unfortunatelly you can't test this in your own dedicated server, because for repairing vehicle by support truck you need to be within this vehicle. So you need 2 players - one for driver while repairing and another one for ordering his AI to try get in.

Updated by kju about 5 years ago

  • Due date changed from 07/14/2010 to 10/01/2010
  • Status changed from Feedback to Assigned
  • Affected ArmA II version changed from 1.05.62017 to 1.53 BETA

ty

Updated by Vipera about 5 years ago

I had this problem on CTI map. I captured enemy tank which was damaged. I repaired it and ordered my AI to get in. AI goes inside than jumps out instantly saying NEGATIVE.

Updated by kju almost 5 years ago

  • File 5161.Desert_E.7z added
  • Due date changed from 10/01/2010 to 11/01/2010
  • Status changed from Assigned to Feedback
  • % Done changed from 0 to 50
  • Reproducible for you changed from No to Yes

Demo mission added.

Can someone please restart in DS env.
In SP/editor they AI get back in.

  1. Damage the left track of the M2A3 with the M136.
  2. AI gets out
  3. Use the repair truck to repair it
  4. Order AI to get back in

If they do, fixed - if not, still a locality issue or something.

Updated by kju almost 5 years ago

  • Due date deleted (11/01/2010)
  • Status changed from Feedback to Closed
  • Target version set to 1.55 BETA
  • Affected ArmA II version changed from 1.53 BETA to 1.55 BETA

This is fixed even in MP! :)

Updated by kju almost 5 years ago

  • Target version changed from 1.55 BETA to 1.55.75445

Also available in: Atom PDF