Bug #5149

Illogical AI engagement ranges for several weapons

Added by vilas over 5 years ago. Updated about 5 years ago.

Status:Closed Start date:10/13/2009
Priority:Normal Due date:02/05/2010
Assignee:- % Done:

0%

Category:Config
Target version:1.05.62017
Affected ArmA II version:1.04.59026 First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods: Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you: NGUrl:
Related to content of DLC: WIKIurl:

Description

i have no idea, how this dev.heaven tracker works
AKS74U should not have 600 meters range, if BIS gave 400 to G36A and 300 to M4
i think under this condition AKS74U should have 250-300 meters
SVD should have 100-200 meters smaller AI fire range than M24/M40, instead of 300 meters bigger

History

Updated by zGuba over 5 years ago

  • Subject changed from wrong weapon ranges to Illogical AI engagement ranges for several weapons
  • Due date set to 11/13/2009
  • Category set to Config
  • Status changed from New to Assigned
  • Affected ArmA II version changed from Please select... to 1.04.59026
  • Reproduced by another DH user changed from No to Yes

Any suggestions for other weapons?

Updated by Vic over 5 years ago

The actual issue is that muzzle velocity is specified in magazines config, so all the weapons sharing the same mags will fire the same way. A workaround for this issue has been implemented by ACE and ACE2 by replacing mags depending on the weapon used via scripting: http://community.bistudio.com/wiki/ACE2_Features#Magazines_System

Updated by zGuba over 5 years ago

It's not the issue.

The issue is that AI actually tries to shoot with these rifles from unrealistic ranges.

Updated by mr.g-c over 5 years ago

Correct, and for the other issue Vic is stating, there is a ticket, hopfeully it will be in the game sooner ot later...
#2411

Updated by kju over 5 years ago

  • Due date changed from 11/13/2009 to 01/02/2010
  • Affected ArmA II version changed from 1.04.59026 to 1.05 BETA

No change so far that I am aware of.

Updated by vilas over 5 years ago

BIS is military ignorance :/
it has nothing to magazine and another ACE advertisement goddamn spam sticking in every hole :/
it is MaxAIrange=...;
it is silly bug, very easy to change by BIS in releases, a.t.m. only addons fix this issue

Updated by zGuba about 5 years ago

  • Status changed from Assigned to Resolved
  • Target version set to 1.05.62017
  • Affected ArmA II version changed from 1.05 BETA to 1.04.59026

Updated by kju about 5 years ago

  • Due date changed from 01/02/2010 to 02/05/2010

Updated by Fireball about 5 years ago

  • Status changed from Resolved to Closed

Ticket overdue, closing.

Also available in: Atom PDF