Bug #5029

Bullet proof/deflecting shrubs/bushes

Added by 76 over 5 years ago. Updated almost 5 years ago.

Status:Rejected Start date:10/06/2009
Priority:Normal Due date:01/02/2010
Assignee:- % Done:

0%

Category:Model
Target version:-
Affected ArmA II version:1.04.59026 First affected build:
Reproduced by another DH user:No First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:No NGUrl:
Related to content of DLC: WIKIurl:

Description

As the title states.

I pretty sure shrubs and bushes deflect 80-90% of the rounds you fire into them, not all bushes though or maybe just not all the time...

Maybe related to issue 4848
http://dev-heaven.net/issues/show/4848

bulletproofshrub.Chernarus.pbo (2.3 kB) 76, 10/12/2009 02:50

bulletsthroughshrubs.Chernarus.sqm (5.9 kB) Fireball, 11/06/2009 07:35


Related issues

related to ARMA2 Community Issue Tracker - Bug #4848: Self suppressing foliage Closed 09/25/2009
related to ARMA2 Community Issue Tracker - Bug #5815: Sabot can't go through some bushes and branches Closed 11/13/2009
related to ARMA2 Community Issue Tracker - Bug #7173: Smoke Puffs from Bullets hitting Leaves' Assigned 12/20/2009 03/01/2011
related to ARMA2 Community Issue Tracker - Bug #8371: Bullet penetration of objects Expired 01/21/2010
duplicated by ARMA2 Community Issue Tracker - Bug #7154: High calibre HE rounds does not penetrate bush and tree l... Duplicate 12/19/2009

History

Updated by Fireball over 5 years ago

  • Due date set to 11/06/2009
  • Status changed from New to Assigned
  • Affected ArmA II version changed from Please select... to 1.04.59026

Updated by Fireball over 5 years ago

  • Category set to Model
  • Reproduced by another DH user changed from No to Yes

Reproed. Had my bullets caught by the leaves of some sort of tree last night at Warfare, S in Berezino.

I'll try and make a repro mission.

Updated by Fireball over 5 years ago

  • Reproduced by another DH user changed from Yes to No

Probably was one specific tree...can't repro it anymore right now.

Updated by Fireball over 5 years ago

  • Status changed from Assigned to Feedback

I've been trying quite a few bushes and put soldiers behind them - I was always able to shoot them.

What you see is that when you shoot through the bush it will give you (audible and visual) feedback, you'll even cut some leaves or twigs at times, but the bullet traverses the shrub.

Please bring repros.

Updated by 76 over 5 years ago

Fireball wrote:

I've been trying quite a few bushes and put soldiers behind them - I was always able to shoot them.

What you see is that when you shoot through the bush it will give you (audible and visual) feedback, you'll even cut some leaves or twigs at times, but the bullet traverses the shrub.

Please bring repros.

demo mission (its in the 'Oil Fields" 064068)

Updated by Fireball over 5 years ago

  • Status changed from Feedback to Assigned

Updated by Fireball over 5 years ago

  • Status changed from Assigned to Rejected

Bad repro. You put the man inside the FireGeo of the shrub using the editor - you cannot walk through/in there nor could it walk out of there.

I've just moved the soldier a bit back behind the bush and shot again through it and bang down he goes.

Updated by 76 over 5 years ago

Fireball wrote:

Bad repro. You put the man inside the FireGeo of the shrub using the editor - you cannot walk through/in there nor could it walk out of there.

I've just moved the soldier a bit back behind the bush and shot again through it and bang down he goes.

Simply not true, when it was an enemy unit I'd shot into the bushes and he'd run off so I could only get one burst off... so I changed it to a friendly unit so he wouldn't run away 'no positions changed' so saying units couldn't walk from that spot in incorrect as the enemy unit I fired at ran off straight away...

Regardless we play one of SBS's AAS missions ([AAS50]ElysianFields-S) that is in that area and this issue happens all the time to many players...

Updated by Fireball over 5 years ago

  • Status changed from Rejected to Feedback

Well, try it for yourself:

- you cannot walk into the place where you set the soldier
- if you set it behind the bush and shoot through it, it's getting killed

Can you make a better repro?

EDIT:

Maybe the issue is a different one; as you say the enemy AI seems to be able to move to that place where you couldn't - maybe that is the root cause?

Updated by Fireball over 5 years ago

Units (and even players) placed inside of the firegeo of an item can walk out but not back in.

I've made another mission which proves that they don't deflect bullets - can't even prove that they reduce the bullet speed (they shouldn't). After a while everyone lies down on the floor which makes them exceptionally hard to hit. Could need some optimization to deny them laying down, but still you can see that you basically can mow them down through shrubs.

Updated by Fireball over 5 years ago

  • Due date changed from 11/06/2009 to 11/20/2009

Updated by kondor over 5 years ago

  • File armored_bushes.utes.pbo added

Updated by Fireball over 5 years ago

Okay, that sounds like a different issue though, kondor. Can you open a new ticket with that?

Updated by Fireball over 5 years ago

  • File deleted (armored_bushes.utes.pbo)

Updated by Fireball over 5 years ago

Thanks kondor, Sabot's got a new bug #5815.

Updated by zGuba over 5 years ago

  • Status changed from Feedback to Expired

Updated by 76 over 5 years ago

expired?... ok, its not my product

Updated by kju over 5 years ago

Fireball asked for a better repro / more feedback.
You and on one self did, so it expired.

It can be reopen any day, if the required information is provided.

Updated by kju over 5 years ago

  • Due date changed from 11/20/2009 to 01/02/2010
  • Status changed from Expired to Feedback

Lets try this again..

Updated by Fireball over 5 years ago

I've just been recently shooting AI through bushes/tree branches and it worked fine.

It only looks like it's deflecting (impact effect), but in fact it's not.

Updated by kju over 5 years ago

From what I recall, the bullet flight path might be slight affected
according to BI dev in BIF.

This would be plausible I guess.

The question is more if the FX effect should happen, right?

Updated by Fireball over 5 years ago

I think the FX is apropriate except for the smoke puffs; you even see little branches falling down from time to time - at least that gives me the hint that it was done that way by design.

Updated by 76 over 5 years ago

Fireball wrote:

I think the FX is apropriate except for the smoke puffs; you even see little branches falling down from time to time - at least that gives me the hint that it was done that way by design.

I think you may be right and if it is by design then I appreciate that there would be some deflection, you did say a few replies back that it did seem to happen on a particular shrub/bush... I've tried to find it but no luck... BI software truly does have gremlins... maybe this is one of them :)

edit: maybe you or I should create a ticket for 'smoke puffs from bullets hitting leaves' 'visual'

edit2: done :)

Updated by Fireball over 5 years ago

  • Status changed from Feedback to Rejected

Thanks - we're done here then.

I might have hit the thicker branches of a fir or something or simply may have missed due to the partially obstructed view - as long we have no repro at all, I guess it's for naught.

Also available in: Atom PDF