Bug #4915

Technicals navigate less intelligently when grouped (AI Convoys)

Added by bartkusa over 5 years ago. Updated almost 4 years ago.

Status:Closed Start date:09/29/2009
Priority:Normal Due date:
Assignee:Dwarden % Done:

0%

Category:AI Issues
Target version:1.59.79384
Affected ArmA II version:1.56.76134 First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using:CO (A2+OA) BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Repro steps

  1. Create a group of technicals, UAZs, or any other light wheeled vehicle with weapons
  2. Create an ungrouped instance of the same vehicle
  3. Give both groups waypoints to the same destination
    • Set waypoint speed to "Full." According to the Biki, "[t]he group leader will move as quickly as possible to the waypoint. He will make no effort to slow himself down to allow the formation to keep up."
    • Make sure the group and the solo unit do not interfere with each others' driving
  4. Compare travel times, and how erratic their driving is.

(I have attached a mission file that demonstrates this.)

Expected Behavior

  • The group's lead vehicle should not be significantly slower than a solo vehicle, if driving at Full speed.
  • The group's trailing vehicles should not swerve all over the road like drunken housewives.

Actual Behavior

  • The group's lead vehicle does not seem to travel at Full speed, and is much slower than the solo vehicle.
  • The group's trailing vehicles, well, they swerve a lot. If I put the time-rate to 4x, I get motion sick watching it.

Impact

It's hard to manage a group of technicals as a fast-reaction force (either as a scripted opponent or via High Command) if they can't get anywhere quickly.

4915.chernarus.7z (2.1 kB) kju, 12/20/2010 13:02

ConvoyFullCareless.Chernarus.7z (969 Bytes) kju, 12/20/2010 13:02

ConvoyFullCombat.Chernarus.7z (966 Bytes) kju, 12/20/2010 13:02

ConvoyFullSafe.Chernarus.7z (963 Bytes) kju, 12/20/2010 13:02

ConvoyLimitedSafe.Chernarus.7z (965 Bytes) kju, 12/20/2010 13:02


Related issues

related to ARMA2 Community Issue Tracker - Bug #1820: AI vehicles follow you/GL into ponds and destroy their ve... Assigned 06/04/2009 03/01/2011
related to ARMA2 Community Issue Tracker - Bug #3249: AI pathfinding: high slope rocks Assigned 08/01/2009
related to ARMA2 Community Issue Tracker - Bug #1845: Supply truck pathfinding very poor Closed 06/05/2009
related to ARMA2 Community Issue Tracker - Feature #16121: Add a "non formation" mode that avoids AI to regroup Assigned 12/20/2010
related to ARMA2 Community Issue Tracker - Bug #27361: AI Convoy driving/pathfinding is terrible Assigned 12/26/2011
related to ARMA2 Community Issue Tracker - Feature #26308: AI pathfinding over ruins/terrain-like objects Assigned 11/11/2011
related to ARMA2 Community Issue Tracker - Bug #42666: AI driven UAZ are unable to stick to roads well Assigned 08/20/2012
related to ARMA2 Community Issue Tracker - Bug #42669: 2nd AI driven UAZ in covoy completely misses to turn into... Assigned 08/20/2012
related to ARMA2 Community Issue Tracker - Bug #42670: AI convoy gets stuck on clear road Assigned 08/20/2012
related to ARMA2 Community Issue Tracker - Bug #16120: Cars/trucks not sticking to roads in combat mode Assigned 12/20/2010

History

Updated by Fireball over 5 years ago

  • Status changed from New to Assigned

Most likely related to #1845.

But please do not create tickets now for every AI you might want to put into any vehicle. Can you verify that this might also apply to other soldiers, not specifically to techies (what to you mean by technicals btw.)?

Updated by Fireball over 5 years ago

  • Status changed from Assigned to Feedback

Updated by bartkusa over 5 years ago

I've only tried making vehicle groups with technicals (and maybe a UAZ doesn't count as a technical). Searching for all bugs (open or closed) with "Technical", "Offroad", or "Pickup" in the title didn't yield any results, so I made a new bug. After looking at #1845, it looks like all wheeled vehicles are affected.

I agree this is a duplicate of #1845.

Updated by bartkusa over 5 years ago

I'm not sure this is a duplicate of #1845, if 1845 "...is not about general pathfinding issue," but is only about Supply Trucks.

I think the general issue here is that vehicles in a group try to maintain a distance/interval between themselves, and they swerve off the road trying to maintain that interval.

There might be a second issue where grouped vehicles traveling at Full speed try to maintain interval, even though documentation suggests that the leaders of Full-speed groups are not supposed to try to stay in formation.

Updated by Fireball over 5 years ago

  • Subject changed from Technicals navigate less intelligently when grouped to Units navigate less intelligently when grouped
  • Status changed from Feedback to Assigned

Added some new relations - I think they are more approriate.

Updated by Fireball over 5 years ago

  • Subject changed from Units navigate less intelligently when grouped to Technicals navigate less intelligently when grouped

Sorry, I understand what you mean with technicals. You mean combat vehicles.

Updated by Fireball over 5 years ago

  • Due date changed from 10/13/2009 to 11/13/2009

Updated by Dwarden over 5 years ago

  • Assignee set to Dwarden

Updated by Fireball about 5 years ago

  • Due date changed from 11/13/2009 to 01/13/2010

Updated by kju about 5 years ago

  • Due date changed from 01/13/2010 to 03/02/2010

Updated by kju over 4 years ago

  • Due date changed from 03/02/2010 to 07/14/2010
  • Status changed from Assigned to Feedback
  • Assignee deleted (Dwarden)
  • Affected ArmA II version changed from 1.04.59026 to 1.05.62017
  • Audio card set to Please specify!
  • Size of OS swap file set to Please specify!

Updated by bartkusa over 4 years ago

  • I am using some Mods set to No
  • Reproducible for you set to No

Combined Arms v1.52: not as bad as I remembered

I reran the mission file that I attached to the bug. I notice that vehicles in convoy drive worse at 2x time-scale than 1x, and 4x is worst of all (probably because the AI is only correcting its course and speed 1/4th as often).

Examining the AI driving at 1x time, it still suffers from some "uncertainty" or "hesitation." I think this "uncertainty" comes from the AI trying to both stay on the road AND maintain the convoy's interval between vehicles.

  • The AI swerves sideways across the road, oscillating to one side and the other. This behavior is more severe (or more apparent) with smaller vehicles like sedans and pickup trucks; AI in large vehicles like utility trucks and tanks seem to be happy with being on the road at all, while smaller vehicles try very, very hard to cleave to the right-hand side of the road. On many roads, this isn't a big problem, but certain roads (like the forest north of Nadezhdino on Chernarus) are cramped, and driving problems are more apparent. Turns at intersections with nearby buildings can also lead to knocked-down fences and lightposts.
  • All vehicles in the convoy speed up and slow down frequently. They all seem to care deeply about maintaining an exact distance from the vehicle in front of them, and not leaving the vehicles behind. There is no steady-state speed, and the convoy moves about 60% as fast as any single vehicle in the convoy would be by itself. It might help if each vehicle
    • cared more about maintaining interval with the car in front of it, than the one behind it
    • didn't slam the brakes and the gas pedal so hard
    • didn't worry about the vehicles behind it unless any interval between two consecutive vehicles were more than, say, 150% of what it ought to be.

Finally, the "Full speed" waypoint setting doesn't seem to apply to convoys; even at Full speed, the convoy leader never let the rest of the convoy lag behind too much.

Updated by kju over 4 years ago

  • Due date changed from 07/14/2010 to 10/01/2010
  • Status changed from Feedback to Assigned
  • Assignee set to Dwarden
  • Affected ArmA II version changed from 1.05.62017 to 1.52.71816

Updated by Krycek about 4 years ago

  • File Bad_20Driving.Chernarus.pbo added

It's still bad in 1.56 Combined Arms.

Convoys are a nightmare because AI cars try to maintain formation and maintain distance from other vehicles at the same time. This results in the convoy stopping often.

Also some cars in the convoy simply turn left or right and stopping without an obstacle in their front.

It was improved but the results are minimal, this issue has plagued A2 since release and all the wheeled vehicles are affected.

I've also made a small mission, all the vehicles are set to "safe" mode and in column formation with limited speed. With normal speed things go more smoothly but the cars still randomly turn&stop before going again making the other convoy cars to stop and so on.

Updated by kju about 4 years ago

  • Due date changed from 10/01/2010 to 03/01/2011
  • Operating system deleted (Win7 64 bit)
  • Affected ArmA II version changed from 1.52.71816 to 1.56.76134
  • Reproduced by another DH user changed from No to Yes
  • I am using set to CO (A2+OA)
  • Reproducible for you changed from No to Yes

Updated by kju about 4 years ago

  • File deleted (Bad_20Driving.Chernarus.pbo)

Updated by kju about 4 years ago

  • File deleted (mission.sqm)

Updated by kju about 4 years ago

Reworked the demo mission to be addon-less (CO still though) and more meaningful.

Updated by Fireball about 4 years ago

Jep, really sad behavior.

Updated by Suma about 4 years ago

  • Status changed from Assigned to Resolved

Convoy behaviour significantly improved with 77703.

Updated by Suma about 4 years ago

  • Subject changed from Technicals navigate less intelligently when grouped to Technicals navigate less intelligently when grouped (AI Convoys)

Updated by kju about 4 years ago

  • Due date deleted (03/01/2011)
  • Target version set to Upcoming version

Yay!

Updated by kju about 4 years ago

  • Target version changed from Upcoming version to 1.58 BETA

Updated by kju about 4 years ago

  • Status changed from Resolved to Closed

A lot better. The stick to the road now quite well and able to mostly in the same distance.

At times they are still going to an abrupt stop and drive a meter off the road and right back.
But that's for another ticket.

Updated by Sickboy about 4 years ago

Also @ BIF there's report of stuck vehicles, the last ones in the formation; http://forums.bistudio.com/showpost.php?p=1842956&postcount=37

Updated by kju almost 4 years ago

  • Target version changed from 1.58 BETA to 1.59.79384
  • Language set to Please set for missions

Also available in: Atom PDF